RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/SuperLU#292446b84e3a345ba29e5a5da1dc676b109e43b6
This commit is contained in:
parent
9d8845165b
commit
c51e2207d0
5
.gitignore
vendored
5
.gitignore
vendored
@ -0,0 +1,5 @@
|
||||
/superlu_4.3.tar.gz
|
||||
/superlu_5.1.1.tar.gz
|
||||
/superlu_5.2.0.tar.gz
|
||||
/superlu_5.2.1.tar.gz
|
||||
/superlu-5.2.1.tar.gz
|
11
SuperLU-5.2.1-set_soname.patch
Normal file
11
SuperLU-5.2.1-set_soname.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/SRC/CMakeLists.orig.txt 2018-04-25 15:17:39.786715000 +0200
|
||||
+++ b/SRC/CMakeLists.txt 2018-04-25 15:25:00.253317607 +0200
|
||||
@@ -230,7 +230,7 @@
|
||||
|
||||
target_link_libraries(superlu ${BLAS_LIB} m)
|
||||
set_target_properties(superlu PROPERTIES
|
||||
- VERSION ${PROJECT_VERSION} SOVERSION ${VERSION_MAJOR}
|
||||
+ VERSION ${PROJECT_VERSION} SOVERSION ${VERSION_MAJOR}.${VERSION_MINOR}
|
||||
)
|
||||
|
||||
include(GNUInstallDirs)
|
262
SuperLU.spec
Normal file
262
SuperLU.spec
Normal file
@ -0,0 +1,262 @@
|
||||
%global __cmake_in_source_build 1
|
||||
%global genname superlu
|
||||
%global libver 5
|
||||
|
||||
Name: SuperLU
|
||||
Version: 5.2.1
|
||||
Release: 14%{?dist}
|
||||
Summary: Subroutines to solve sparse linear systems
|
||||
License: BSD and GPLv2+
|
||||
URL: https://portal.nersc.gov/project/sparse/superlu/
|
||||
Source0: https://github.com/xiaoyeli/superlu/archive/v%{version}/%{genname}-%{version}.tar.gz
|
||||
Patch0: %{genname}-cmake-includedir.patch
|
||||
Patch1: %{genname}-removemc64.patch
|
||||
|
||||
# Patch soname (5 -> 5.2) of shared library
|
||||
Patch2: %{name}-%{version}-set_soname.patch
|
||||
|
||||
%if 0%{?fedora} >= 33
|
||||
BuildRequires: pkgconfig(flexiblas)
|
||||
%else
|
||||
%ifarch %{openblas_arches}
|
||||
BuildRequires: openblas-devel, openblas-srpm-macros
|
||||
%else
|
||||
BuildRequires: blas-devel
|
||||
%endif
|
||||
BuildRequires: atlas-devel
|
||||
%if 0%{?epel}
|
||||
BuildRequires: epel-rpm-macros
|
||||
%endif
|
||||
%endif
|
||||
BuildRequires: cmake3
|
||||
BuildRequires: gcc, gcc-gfortran
|
||||
BuildRequires: csh
|
||||
|
||||
%description
|
||||
SuperLU contains a set of subroutines to solve a sparse linear system
|
||||
A*X=B. It uses Gaussian elimination with partial pivoting (GEPP).
|
||||
The columns of A may be preordered before factorization; the
|
||||
preordering for sparsity is completely separate from the factorization.
|
||||
|
||||
%package devel
|
||||
Summary: Header files and libraries for SuperLU development
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains the header files
|
||||
and libraries for use with %{name} package.
|
||||
|
||||
%package doc
|
||||
Summary: Documentation and Examples for SuperLU
|
||||
BuildArch: noarch
|
||||
%description doc
|
||||
The %{name}-doc package contains all the help HTML documentation.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{genname}-%{version} -p1
|
||||
|
||||
rm -fr SRC/mc64ad.f.bak
|
||||
find . -type f | sed -e "/TESTING/d" | xargs chmod a-x
|
||||
# Remove the shippped executables from EXAMPLE
|
||||
find EXAMPLE -type f | while read file
|
||||
do
|
||||
[ "$(file $file | awk '{print $2}')" = ELF ] && rm $file || :
|
||||
done
|
||||
|
||||
# Change optimization level
|
||||
sed -i.bak '/NOOPTS/d' make.inc.in
|
||||
sed -e 's|-O0|-O2|g' -i SRC/CMakeLists.txt
|
||||
|
||||
%build
|
||||
# Do not use bundled CBLAS code
|
||||
%cmake3 -B build \
|
||||
-Denable_blaslib:BOOL=OFF \
|
||||
%if 0%{?fedora} >= 33
|
||||
-DBLAS_LIBRARIES=-lflexiblas \
|
||||
%endif
|
||||
-DCMAKE_BUILD_TYPE:STRING=Release
|
||||
%make_build -C build
|
||||
|
||||
# Compile Fortran example interface to use the C routines in SuperLU
|
||||
make -C FORTRAN
|
||||
make -C EXAMPLE
|
||||
|
||||
%install
|
||||
%make_install -C build
|
||||
|
||||
%check
|
||||
pushd build
|
||||
ctest3 -V %{?_smp_mflags}
|
||||
popd
|
||||
|
||||
# Test Fortran example interface to use the C routines in SuperLU
|
||||
pushd FORTRAN
|
||||
export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
|
||||
./df77exm < ../EXAMPLE/g20.rua
|
||||
./zf77exm < ../EXAMPLE/cg20.cua
|
||||
./test_omp < ../EXAMPLE/g20.rua
|
||||
make clean
|
||||
popd
|
||||
# Test sample programs
|
||||
pushd EXAMPLE
|
||||
export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
|
||||
./superlu
|
||||
make clean
|
||||
popd
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files
|
||||
%license License.txt
|
||||
%{_libdir}/libsuperlu.so.%{libver}*
|
||||
|
||||
%files devel
|
||||
%{_includedir}/%{name}/
|
||||
%{_libdir}/libsuperlu.so
|
||||
|
||||
%files doc
|
||||
%license License.txt
|
||||
%doc DOC
|
||||
|
||||
%changelog
|
||||
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.1-14
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.1-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Sat Jul 25 2020 Iñaki Úcar <iucar@fedoraproject.org> - 5.2.1-12
|
||||
- https://fedoraproject.org/wiki/Changes/FlexiBLAS_as_BLAS/LAPACK_manager
|
||||
|
||||
* Tue Jul 21 2020 Merlin Mathesius <mmathesi@redhat.com> - 5.2.1-11
|
||||
- Minor conditional fix for ELN
|
||||
- Stick to cmake in-source building
|
||||
|
||||
* Sun Apr 19 2020 Antonio Trande <sagitter@fedoraproject.org> - 5.2.1-10
|
||||
- Doc sub-package provides its own license file
|
||||
|
||||
* Sat Apr 18 2020 Antonio Trande <sagitter@fedoraproject.org> - 5.2.1-9
|
||||
- Some minor fixes
|
||||
- Compile/execute Fortran tests and examples
|
||||
- Do not pack example's source code
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.1-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.1-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Sep 14 2018 Antonio Trande <sagitter@fedoraproject.org> - 5.2.1-5
|
||||
- Remove gcc-gfortran as required package
|
||||
|
||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Apr 25 2018 Antonio Trande <sagitter@fedoraproject.org> - 5.2.1-3
|
||||
- Patch soname (5 -> 5.2) of shared library
|
||||
|
||||
* Sun Apr 15 2018 Antonio Trande <sagitter@fedoraproject.org> - 5.2.1-2
|
||||
- Use cmake3 on rhel
|
||||
- Use blas from system
|
||||
|
||||
* Fri Apr 13 2018 Rafael dos Santos <rdossant@redhat.com> - 5.2.1-1
|
||||
- Update to 5.2.1
|
||||
- Use cmake build system
|
||||
- Drop obsolete patches
|
||||
- Resolves #1547494 - build with standard Fedora flags
|
||||
|
||||
* Wed Feb 21 2018 Antonio Trande <sagitter@fedoraproject.org> - 5.2.0-8
|
||||
- Add gcc BR
|
||||
- Remove el5 bits
|
||||
|
||||
* Thu Feb 15 2018 Antonio Trande <sagitter@fedoraproject.org> - 5.2.0-7
|
||||
- Use %%ldconfig_scriptlets
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Sat Oct 21 2017 Mukundan Ragavan <nonamedotc@fedoraproject.org> - 5.2.0-5
|
||||
- Fix lib linking in EPEL (added conditionals; Thanks Antonio Trande))
|
||||
- Use license macro
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Apr 14 2016 Mukundan Ragavan <nonamedotc@fedoraproject.org> - 5.2.0-1
|
||||
- Update to 5.2.0
|
||||
- spec file cleanup
|
||||
|
||||
* Mon Mar 28 2016 Mukundan Ragavan <nonamedotc@fedoraproject.org> - 5.1.1-2
|
||||
- Added -doc subpackage
|
||||
- Added GPLv2 in the license field
|
||||
|
||||
* Mon Mar 21 2016 Mukundan Ragavan <nonamedotc@fedoraproject.org> - 5.1.1-1
|
||||
- Update to 5.1.1
|
||||
- Remove format security patch - not needed anymore
|
||||
- Edit patches to be version specific
|
||||
- Renamed patch4 to be consistent with others
|
||||
- Minor spec file housekeeping
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 4.3-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Jun 16 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.3-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sun Jan 25 2015 Mukundan Ragavan <nonamedotc@fedoraproject.org> - 4.3-12
|
||||
- Fix spec file errors and remove backup files
|
||||
- fixes 1084707
|
||||
|
||||
* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.3-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sun Jul 13 2014 Mukundan Ragavan <nonamedotc@gmail.com> - 4.3-10
|
||||
- Removed non-free files, fixes bz#1114264
|
||||
|
||||
* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.3-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Jan 06 2014 Björn Esser <bjoern.esser@gmail.com> - 4.3-8
|
||||
- fixed FTBFS if "-Werror=format-security" flag is used (#1037343)
|
||||
- devel-pkg must Requires: %%{name}%%{?_isa}
|
||||
- apply proper LDFLAGS
|
||||
- added needed bits for el5
|
||||
- reenable testsuite using Patch3
|
||||
|
||||
* Fri Oct 4 2013 Orion Poplawski <orion@cora.nwra.com> - 4.3-7
|
||||
- Rebuild for atlas 3.10
|
||||
- Handle UnversionedDocDirs change
|
||||
|
||||
* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.3-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Mon Mar 25 2013 Shakthi Kannan <shakthimaan [AT] fedoraproject dot org> 4.3-5
|
||||
- Ship SuperLU examples
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Sat Aug 25 2012 Shakthi Kannan <shakthimaan [AT] fedoraproject dot org> 4.3-3
|
||||
- Use README in main package and DOC in devel package
|
||||
- chmod a-x on SRC/qselect.c
|
||||
- Remove -latlas linking in prep section
|
||||
- Added Patch comments
|
||||
- Use name RPM macro in patch name
|
||||
|
||||
* Wed Feb 01 2012 Shakthi Kannan <shakthimaan [AT] fedoraproject dot org> 4.3-2
|
||||
- Use atlas library instead of blas.
|
||||
- Use RPM_OPT_FLAGS and LIBS when building sources.
|
||||
- Use macros as required for name and version.
|
||||
|
||||
* Fri Jan 06 2012 Shakthi Kannan <shakthimaan [AT] fedoraproject dot org> 4.3-1
|
||||
- First release.
|
1
sources
Normal file
1
sources
Normal file
@ -0,0 +1 @@
|
||||
SHA512 (superlu-5.2.1.tar.gz) = c5f9ca6055b6861dcc89e31c446c9f57a4e16333f9f24f109e8f375eded878005fa520ab39d2c1dd0ce12f289f9e251aef47da58c975bf5b1f09ca7539194e90
|
9
superlu-cmake-includedir.patch
Normal file
9
superlu-cmake-includedir.patch
Normal file
@ -0,0 +1,9 @@
|
||||
--- SuperLU_5.2.1/SRC/CMakeLists.txt 2018-04-13 17:01:44.007761121 +0200
|
||||
+++ CMakeLists.txt 2018-04-13 17:01:30.573718261 +0200
|
||||
@@ -242,5 +242,5 @@
|
||||
|
||||
install(FILES ${headers}
|
||||
# DESTINATION ${CMAKE_INSTALL_PREFIX}/include
|
||||
- DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
|
||||
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/SuperLU
|
||||
)
|
2662
superlu-removemc64.patch
Normal file
2662
superlu-removemc64.patch
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user