Update to 2.0.16
Resolves: rhbz#1989083
This commit is contained in:
parent
7e4a331aff
commit
4d74cb1c97
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@
|
|||||||
/SDL2-2.0.10.tar.gz
|
/SDL2-2.0.10.tar.gz
|
||||||
/SDL2-2.0.12.tar.gz
|
/SDL2-2.0.12.tar.gz
|
||||||
/SDL2-2.0.14.tar.gz
|
/SDL2-2.0.14.tar.gz
|
||||||
|
/SDL2-2.0.16.tar.gz
|
||||||
|
41
SDL2-2.0.16-PR4622.patch
Normal file
41
SDL2-2.0.16-PR4622.patch
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
index 26fe83205..9b7ae7098 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -2662,15 +2662,15 @@ endif()
|
||||||
|
|
||||||
|
##### Installation targets #####
|
||||||
|
install(TARGETS ${_INSTALL_LIBS} EXPORT SDL2Targets
|
||||||
|
- LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}${LIB_SUFFIX}"
|
||||||
|
- ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}${LIB_SUFFIX}"
|
||||||
|
+ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}"
|
||||||
|
+ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}"
|
||||||
|
RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}")
|
||||||
|
|
||||||
|
##### Export files #####
|
||||||
|
if (WINDOWS)
|
||||||
|
set(PKG_PREFIX "cmake")
|
||||||
|
else ()
|
||||||
|
- set(PKG_PREFIX "${CMAKE_INSTALL_LIBDIR}${LIB_SUFFIX}/cmake/SDL2")
|
||||||
|
+ set(PKG_PREFIX "${CMAKE_INSTALL_LIBDIR}/cmake/SDL2")
|
||||||
|
endif ()
|
||||||
|
|
||||||
|
include(CMakePackageConfigHelpers)
|
||||||
|
@@ -2717,7 +2717,7 @@ if(NOT (WINDOWS OR CYGWIN OR MINGW))
|
||||||
|
execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink
|
||||||
|
\"lib${SONAME}${SOPOSTFIX}${SOEXT}\" \"libSDL2${SOPOSTFIX}${SOEXT}\"
|
||||||
|
WORKING_DIRECTORY \"${SDL2_BINARY_DIR}\")")
|
||||||
|
- install(FILES ${SDL2_BINARY_DIR}/libSDL2${SOPOSTFIX}${SOEXT} DESTINATION "${CMAKE_INSTALL_LIBDIR}${LIB_SUFFIX}")
|
||||||
|
+ install(FILES ${SDL2_BINARY_DIR}/libSDL2${SOPOSTFIX}${SOEXT} DESTINATION "${CMAKE_INSTALL_LIBDIR}")
|
||||||
|
endif()
|
||||||
|
endif()
|
||||||
|
if(FREEBSD)
|
||||||
|
@@ -2725,7 +2725,7 @@ if(NOT (WINDOWS OR CYGWIN OR MINGW))
|
||||||
|
install(FILES ${SDL2_BINARY_DIR}/sdl2.pc DESTINATION "libdata/pkgconfig")
|
||||||
|
else()
|
||||||
|
install(FILES ${SDL2_BINARY_DIR}/sdl2.pc
|
||||||
|
- DESTINATION "${CMAKE_INSTALL_LIBDIR}${LIB_SUFFIX}/pkgconfig")
|
||||||
|
+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
|
||||||
|
endif()
|
||||||
|
install(PROGRAMS ${SDL2_BINARY_DIR}/sdl2-config DESTINATION "${CMAKE_INSTALL_BINDIR}")
|
||||||
|
# TODO: what about the .spec file? Is it only needed for RPM creation?
|
24
SDL2.spec
24
SDL2.spec
@ -1,6 +1,6 @@
|
|||||||
Name: SDL2
|
Name: SDL2
|
||||||
Version: 2.0.14
|
Version: 2.0.16
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Cross-platform multimedia library
|
Summary: Cross-platform multimedia library
|
||||||
License: zlib and MIT
|
License: zlib and MIT
|
||||||
URL: http://www.libsdl.org/
|
URL: http://www.libsdl.org/
|
||||||
@ -11,6 +11,10 @@ Patch0: multilib.patch
|
|||||||
# ptrdiff_t is not the same as khronos defines on 32bit arches
|
# ptrdiff_t is not the same as khronos defines on 32bit arches
|
||||||
Patch1: SDL2-2.0.9-khrplatform.patch
|
Patch1: SDL2-2.0.9-khrplatform.patch
|
||||||
|
|
||||||
|
# Proposed upstream
|
||||||
|
## From: https://github.com/libsdl-org/SDL/pull/4622
|
||||||
|
Patch0101: SDL2-2.0.16-PR4622.patch
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -34,11 +38,14 @@ BuildRequires: systemd-devel
|
|||||||
BuildRequires: pkgconfig(libpulse-simple)
|
BuildRequires: pkgconfig(libpulse-simple)
|
||||||
# Jack
|
# Jack
|
||||||
BuildRequires: pkgconfig(jack)
|
BuildRequires: pkgconfig(jack)
|
||||||
|
# PipeWire
|
||||||
|
BuildRequires: pkgconfig(libpipewire-0.3)
|
||||||
# D-Bus
|
# D-Bus
|
||||||
BuildRequires: pkgconfig(dbus-1)
|
BuildRequires: pkgconfig(dbus-1)
|
||||||
# IBus
|
# IBus
|
||||||
BuildRequires: pkgconfig(ibus-1.0)
|
BuildRequires: pkgconfig(ibus-1.0)
|
||||||
# Wayland
|
# Wayland
|
||||||
|
BuildRequires: pkgconfig(libdecor-0)
|
||||||
BuildRequires: pkgconfig(wayland-client)
|
BuildRequires: pkgconfig(wayland-client)
|
||||||
BuildRequires: pkgconfig(wayland-egl)
|
BuildRequires: pkgconfig(wayland-egl)
|
||||||
BuildRequires: pkgconfig(wayland-cursor)
|
BuildRequires: pkgconfig(wayland-cursor)
|
||||||
@ -78,7 +85,7 @@ Static libraries for SDL2.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -p1
|
%autosetup -p1
|
||||||
sed -i -e 's/\r//g' TODO.txt README.txt WhatsNew.txt BUGS.txt COPYING.txt CREDITS.txt README-SDL.txt
|
sed -i -e 's/\r//g' TODO.txt README.md WhatsNew.txt BUGS.txt LICENSE.txt CREDITS.txt README-SDL.txt
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Deal with new CMake policy around whitespace in LDFLAGS...
|
# Deal with new CMake policy around whitespace in LDFLAGS...
|
||||||
@ -92,8 +99,10 @@ export LDFLAGS="%{shrink:%{build_ldflags}}"
|
|||||||
-DNAS=OFF \
|
-DNAS=OFF \
|
||||||
-DPULSEAUDIO_SHARED=ON \
|
-DPULSEAUDIO_SHARED=ON \
|
||||||
-DJACK_SHARED=ON \
|
-DJACK_SHARED=ON \
|
||||||
|
-DPIPEWIRE_SHARED=ON \
|
||||||
-DALSA=ON \
|
-DALSA=ON \
|
||||||
-DVIDEO_WAYLAND=ON \
|
-DVIDEO_WAYLAND=ON \
|
||||||
|
-DLIBDECOR_SHARED=ON \
|
||||||
-DVIDEO_VULKAN=ON \
|
-DVIDEO_VULKAN=ON \
|
||||||
-DSSE3=OFF \
|
-DSSE3=OFF \
|
||||||
-DRPATH=OFF \
|
-DRPATH=OFF \
|
||||||
@ -114,12 +123,12 @@ install -p -m 644 %{SOURCE1} %{buildroot}%{_includedir}/SDL2/SDL_config.h
|
|||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%license COPYING.txt
|
%license LICENSE.txt
|
||||||
%doc BUGS.txt CREDITS.txt README-SDL.txt
|
%doc BUGS.txt CREDITS.txt README-SDL.txt
|
||||||
%{_libdir}/libSDL2-2.0.so.0*
|
%{_libdir}/libSDL2-2.0.so.0*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%doc README.txt TODO.txt WhatsNew.txt
|
%doc README.md TODO.txt WhatsNew.txt
|
||||||
%{_bindir}/*-config
|
%{_bindir}/*-config
|
||||||
%{_libdir}/lib*.so
|
%{_libdir}/lib*.so
|
||||||
%{_libdir}/pkgconfig/sdl2.pc
|
%{_libdir}/pkgconfig/sdl2.pc
|
||||||
@ -128,10 +137,13 @@ install -p -m 644 %{SOURCE1} %{buildroot}%{_includedir}/SDL2/SDL_config.h
|
|||||||
%{_datadir}/aclocal/*
|
%{_datadir}/aclocal/*
|
||||||
|
|
||||||
%files static
|
%files static
|
||||||
%license COPYING.txt
|
%license LICENSE.txt
|
||||||
%{_libdir}/lib*.a
|
%{_libdir}/lib*.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 26 2021 Neal Gompa <ngompa@fedoraproject.org> - 2.0.16-1
|
||||||
|
- Update to 2.0.16
|
||||||
|
|
||||||
* Thu Aug 26 2021 Tom Callaway <spot@fedoraproject.org> - 2.0.14-7
|
* Thu Aug 26 2021 Tom Callaway <spot@fedoraproject.org> - 2.0.14-7
|
||||||
- add -static Requires to -devel to make CMake stop failing on missing files (bz1965359)
|
- add -static Requires to -devel to make CMake stop failing on missing files (bz1965359)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (SDL2-2.0.14.tar.gz) = ebc482585bd565bf3003fbcedd91058b2183e333b9ea566d2f386da0298ff970645d9d25c1aa4459c7c96e9ea839fd1c5f2da0242a56892865b2e456cdd027ee
|
SHA512 (SDL2-2.0.16.tar.gz) = ec75ef8526792650c2647b78bb0244f973774418aeae33a2182d90ce696b30acb652f8be9c2012a16c1c5d5622f7630ff2e1eadae27ea3dc78ab47730cf5e62f
|
||||||
|
Loading…
Reference in New Issue
Block a user