Backport Wayland fixes from upstream
This includes revisions 10096 10098 10099 10113 10114 10119 10120 10130 10154 10302 10303 10304.
This commit is contained in:
parent
063e801036
commit
32e6c272b3
@ -1,24 +0,0 @@
|
||||
diff -up SDL2-2.0.4/src/video/wayland/SDL_waylanddyn.h.fix SDL2-2.0.4/src/video/wayland/SDL_waylanddyn.h
|
||||
--- SDL2-2.0.4/src/video/wayland/SDL_waylanddyn.h.fix 2016-02-05 12:18:29.514348406 -0500
|
||||
+++ SDL2-2.0.4/src/video/wayland/SDL_waylanddyn.h 2016-02-05 12:18:45.898990489 -0500
|
||||
@@ -79,6 +79,7 @@ void SDL_WAYLAND_UnloadSymbols(void);
|
||||
#define wl_proxy_get_user_data (*WAYLAND_wl_proxy_get_user_data)
|
||||
#define wl_proxy_add_listener (*WAYLAND_wl_proxy_add_listener)
|
||||
#define wl_proxy_marshal_constructor (*WAYLAND_wl_proxy_marshal_constructor)
|
||||
+#define wl_proxy_marshal_constructor_versioned (*WAYLAND_wl_proxy_marshal_constructor_versioned)
|
||||
|
||||
#define wl_seat_interface (*WAYLAND_wl_seat_interface)
|
||||
#define wl_surface_interface (*WAYLAND_wl_surface_interface)
|
||||
diff -up SDL2-2.0.4/src/video/wayland/SDL_waylandsym.h.fix SDL2-2.0.4/src/video/wayland/SDL_waylandsym.h
|
||||
--- SDL2-2.0.4/src/video/wayland/SDL_waylandsym.h.fix 2016-07-10 17:55:53.970424955 +0100
|
||||
+++ SDL2-2.0.4/src/video/wayland/SDL_waylandsym.h 2016-07-10 18:03:01.627109626 +0100
|
||||
@@ -55,6 +55,9 @@ SDL_WAYLAND_SYM(void, wl_list_insert_lis
|
||||
SDL_WAYLAND_MODULE(WAYLAND_CLIENT_1_4)
|
||||
SDL_WAYLAND_SYM(struct wl_proxy *, wl_proxy_marshal_constructor, (struct wl_proxy *, uint32_t opcode, const struct wl_interface *interface, ...))
|
||||
|
||||
+SDL_WAYLAND_MODULE(WAYLAND_CLIENT_1_10)
|
||||
+SDL_WAYLAND_SYM(struct wl_proxy *, wl_proxy_marshal_constructor_versioned, (struct wl_proxy *proxy, uint32_t opcode, const struct wl_interface *interface, uint32_t version, ...))
|
||||
+
|
||||
SDL_WAYLAND_INTERFACE(wl_seat_interface)
|
||||
SDL_WAYLAND_INTERFACE(wl_surface_interface)
|
||||
SDL_WAYLAND_INTERFACE(wl_shm_pool_interface)
|
1224
SDL2-wayland-fixes.patch
Normal file
1224
SDL2-wayland-fixes.patch
Normal file
File diff suppressed because it is too large
Load Diff
13
SDL2.spec
13
SDL2.spec
@ -1,6 +1,6 @@
|
||||
Name: SDL2
|
||||
Version: 2.0.4
|
||||
Release: 8%{?dist}
|
||||
Release: 9%{?dist}
|
||||
Summary: A cross-platform multimedia library
|
||||
|
||||
License: zlib and MIT
|
||||
@ -9,8 +9,8 @@ Source0: http://www.libsdl.org/release/%{name}-%{version}.tar.gz
|
||||
Source1: SDL_config.h
|
||||
|
||||
Patch0: multilib.patch
|
||||
# https://bugzilla.libsdl.org/show_bug.cgi?id=3255
|
||||
Patch1: SDL2-wayland-dyn-wl_proxy_marshal_constructor_versioned.patch
|
||||
# Wayland fixes backported from upstream
|
||||
Patch1: SDL2-wayland-fixes.patch
|
||||
# https://bugzilla.libsdl.org/show_bug.cgi?id=3295
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1366868
|
||||
Patch2: bug_822210_fix_sdl2-config.cmake_whitespace.patch
|
||||
@ -41,6 +41,8 @@ BuildRequires: pkgconfig(ibus-1.0)
|
||||
BuildRequires: pkgconfig(wayland-client)
|
||||
BuildRequires: pkgconfig(wayland-egl)
|
||||
BuildRequires: pkgconfig(wayland-cursor)
|
||||
BuildRequires: pkgconfig(wayland-protocols)
|
||||
BuildRequires: pkgconfig(wayland-scanner)
|
||||
BuildRequires: pkgconfig(xkbcommon)
|
||||
|
||||
%description
|
||||
@ -69,7 +71,7 @@ Static libraries for SDL2.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .multilib
|
||||
%patch1 -p1 -b .waylandfix
|
||||
%patch1 -p1 -b .wayland-fixes
|
||||
# Compilation without ESD
|
||||
sed -i -e 's/.*AM_PATH_ESD.*//' configure.in
|
||||
sed -i -e 's/\r//g' TODO.txt README.txt WhatsNew.txt BUGS.txt COPYING.txt CREDITS.txt README-SDL.txt
|
||||
@ -122,6 +124,9 @@ rm -f %{buildroot}%{_libdir}/*.la
|
||||
%{_libdir}/lib*.a
|
||||
|
||||
%changelog
|
||||
* Mon Sep 05 2016 Kalev Lember <klember@redhat.com> - 2.0.4-9
|
||||
- Backport Wayland fixes from upstream
|
||||
|
||||
* Sun Aug 14 2016 Igor Gnatenko <ignatenko@redhat.com> - 2.0.4-8
|
||||
- Fix whitespaces in CMake file (RHBZ #1366868)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user