Update to 2.0.8
This commit is contained in:
parent
6fb4b108da
commit
1e1633d609
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
||||
/SDL2-2.0.5.tar.gz
|
||||
/SDL2-2.0.6.tar.gz
|
||||
/SDL2-2.0.7.tar.gz
|
||||
/SDL2-2.0.8.tar.gz
|
||||
|
@ -1,20 +0,0 @@
|
||||
diff -Nur SDL2-2.0.7/src/core/linux/SDL_ibus.c SDL2-2.0.7n/src/core/linux/SDL_ibus.c
|
||||
--- SDL2-2.0.7/src/core/linux/SDL_ibus.c 2017-10-24 03:27:46.000000000 +0800
|
||||
+++ SDL2-2.0.7n/src/core/linux/SDL_ibus.c 2017-10-26 18:32:46.795026798 +0800
|
||||
@@ -299,7 +299,7 @@
|
||||
caps |= IBUS_CAP_PREEDIT_TEXT;
|
||||
}
|
||||
|
||||
- SDL_DBus_CallVoidMethod(IBUS_SERVICE, input_ctx_path, IBUS_INPUT_INTERFACE, "SetCapabilities",
|
||||
+ SDL_DBus_CallVoidMethodOnConnection(ibus_conn, IBUS_SERVICE, input_ctx_path, IBUS_INPUT_INTERFACE, "SetCapabilities",
|
||||
DBUS_TYPE_UINT32, &caps, DBUS_TYPE_INVALID);
|
||||
}
|
||||
}
|
||||
@@ -341,6 +341,7 @@
|
||||
dbus->bus_add_match(ibus_conn, "type='signal',interface='org.freedesktop.IBus.InputContext'", NULL);
|
||||
dbus->connection_try_register_object_path(ibus_conn, input_ctx_path, &ibus_vtable, dbus, NULL);
|
||||
dbus->connection_flush(ibus_conn);
|
||||
+ result = SDL_TRUE;
|
||||
}
|
||||
|
||||
SDL_IBus_SetFocus(SDL_GetKeyboardFocus() != NULL);
|
10
SDL2.spec
10
SDL2.spec
@ -1,6 +1,6 @@
|
||||
Name: SDL2
|
||||
Version: 2.0.7
|
||||
Release: 4%{?dist}
|
||||
Version: 2.0.8
|
||||
Release: 1%{?dist}
|
||||
Summary: Cross-platform multimedia library
|
||||
|
||||
License: zlib and MIT
|
||||
@ -9,9 +9,6 @@ Source0: http://www.libsdl.org/release/%{name}-%{version}.tar.gz
|
||||
Source1: SDL_config.h
|
||||
|
||||
Patch0: multilib.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1507444
|
||||
# https://bugzilla.libsdl.org/show_bug.cgi?id=3920
|
||||
Patch1: SDL2-2.0.7-fix-ibus.diff
|
||||
|
||||
BuildRequires: alsa-lib-devel
|
||||
BuildRequires: audiofile-devel
|
||||
@ -126,6 +123,9 @@ rm -vf %{buildroot}%{_libdir}/*.la
|
||||
%{_libdir}/lib*.a
|
||||
|
||||
%changelog
|
||||
* Sun Mar 4 2018 Peter Robinson <pbrobinson@fedoraproject.org> 2.0.8-1
|
||||
- Update to 2.0.8
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.7-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (SDL2-2.0.7.tar.gz) = eed5477843086a0e66552eb197a5c4929134522bc366d873732361ea0df5fb841ef7e2b1913e21d1bae69e6fd3152ee630492e615c58cbe903e7d6e47b587410
|
||||
SHA512 (SDL2-2.0.8.tar.gz) = 673c6058b8692a36b4a3594456b10ef6051efe79e4fb644421fc5c76b11fd68b895840a2c8b72413418c378733e2993d33f19767d0d7ed101eda6310bd70c869
|
||||
|
Loading…
Reference in New Issue
Block a user