Update to 2.8.3
Add patch to repair warning from compiler
This commit is contained in:
parent
25e1c8f041
commit
d47d50334a
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
|||||||
/2.4.0.tar.gz
|
/2.4.0.tar.gz
|
||||||
/2.8.0.tar.gz
|
/2.8.0.tar.gz
|
||||||
/2.8.1.tar.gz
|
/2.8.1.tar.gz
|
||||||
|
/2.8.3.tar.gz
|
||||||
|
32
PEGTL-compiler-warning.patch
Normal file
32
PEGTL-compiler-warning.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
diff --git a/include/tao/pegtl/contrib/rep_one_min_max.hpp b/include/tao/pegtl/contrib/rep_one_min_max.hpp
|
||||||
|
index 9173ad4a..2c9c25e6 100644
|
||||||
|
--- a/include/tao/pegtl/contrib/rep_one_min_max.hpp
|
||||||
|
+++ b/include/tao/pegtl/contrib/rep_one_min_max.hpp
|
||||||
|
@@ -45,6 +45,27 @@ namespace tao
|
||||||
|
}
|
||||||
|
};
|
||||||
|
|
||||||
|
+ template< unsigned Max, char C >
|
||||||
|
+ struct rep_one_min_max< 0, Max, C >
|
||||||
|
+ {
|
||||||
|
+ using analyze_t = analysis::counted< analysis::rule_type::any, 0 >;
|
||||||
|
+
|
||||||
|
+ template< typename Input >
|
||||||
|
+ static bool match( Input& in )
|
||||||
|
+ {
|
||||||
|
+ const auto size = in.size( Max + 1 );
|
||||||
|
+ std::size_t i = 0;
|
||||||
|
+ while( ( i < size ) && ( in.peek_char( i ) == C ) ) {
|
||||||
|
+ ++i;
|
||||||
|
+ }
|
||||||
|
+ if( i <= Max ) {
|
||||||
|
+ bump_help< result_on_found::success, Input, char, C >( in, i );
|
||||||
|
+ return true;
|
||||||
|
+ }
|
||||||
|
+ return false;
|
||||||
|
+ }
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
template< unsigned Min, unsigned Max, char C >
|
||||||
|
struct skip_control< rep_one_min_max< Min, Max, C > > : std::true_type
|
||||||
|
{
|
12
PEGTL.spec
12
PEGTL.spec
@ -1,8 +1,8 @@
|
|||||||
%global debug_package %{nil}
|
%global debug_package %{nil}
|
||||||
|
|
||||||
Name: PEGTL
|
Name: PEGTL
|
||||||
Version: 2.8.1
|
Version: 2.8.3
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Parsing Expression Grammar Template Library
|
Summary: Parsing Expression Grammar Template Library
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: https://github.com/taocpp/%{name}/
|
URL: https://github.com/taocpp/%{name}/
|
||||||
@ -11,6 +11,8 @@ Source0: https://github.com/taocpp/%{name}/archive/%{version}.tar.gz
|
|||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: /usr/bin/make
|
BuildRequires: /usr/bin/make
|
||||||
|
|
||||||
|
Patch0: PEGTL-compiler-warning.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The Parsing Expression Grammar Template Library (PEGTL) is a zero-dependency
|
The Parsing Expression Grammar Template Library (PEGTL) is a zero-dependency
|
||||||
C++11 header-only library for creating parsers according to a Parsing
|
C++11 header-only library for creating parsers according to a Parsing
|
||||||
@ -29,6 +31,8 @@ applications that use %{name}.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
|
|
||||||
|
%patch0 -p1 -b .compiler
|
||||||
|
|
||||||
%check
|
%check
|
||||||
make
|
make
|
||||||
|
|
||||||
@ -45,6 +49,10 @@ popd
|
|||||||
%{_includedir}/tao/pegtl
|
%{_includedir}/tao/pegtl
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 03 2020 Attila Lakatos <alakatos@redhat.com> - 2.8.3-1
|
||||||
|
- Update to 2.8.3
|
||||||
|
Resolves: rhbz#1742557
|
||||||
|
|
||||||
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.8.1-4
|
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.8.1-4
|
||||||
- Second attempt - Rebuilt for
|
- Second attempt - Rebuilt for
|
||||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (2.8.1.tar.gz) = 7a8f6829123fbbd5a0ef1c8ef2c72bdae48576ef94056a1dff7914e4bb85caac1df02839131ea5cfb4131c8902addeca92df48fe7dd5815bdf5cb35759dace49
|
SHA512 (2.8.3.tar.gz) = 9f7644b86741dfe61716bbc43b2ea0a02cfc21eaf229c47cc71a49e2f08bf2c1ff37d2b2242a1bcf518b1893be6b82c27b0e9010a1b47ef8df87ffd90d280f71
|
||||||
|
Loading…
Reference in New Issue
Block a user