Python3 update

This commit is contained in:
Josef Ridky 2018-04-18 09:00:24 +02:00
parent 90129e622b
commit ea41ad6fa5
2 changed files with 6 additions and 23 deletions

View File

@ -10,24 +10,6 @@ diff -urNp a/configure b/configure
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
$as_echo_n "checking for $ac_word... " >&6; }
if ${ac_cv_path_pythonprog+:} false; then :
@@ -13474,7 +13474,7 @@ fi
$as_echo "#define HAVE_PYTHON /**/" >>confdefs.h
- PYTHON_DIR=python
+ PYTHON_DIR=python3.6
PYTHON_CFLAGS="$pythoncflags"
PYTHON_INSTALL_DIR="$pythoninstalldir"
PYTHON_INSTALL_LIB_DIR="$pythoninstalllibdir"
@@ -13491,7 +13491,7 @@ else
$as_echo "#define HAVE_PYTHON /**/" >>confdefs.h
- PYTHON_DIR=python
+ PYTHON_DIR=python3.6
PYTHON_CFLAGS="$pythoncflags"
PYTHON_INSTALL_DIR="$pythoninstalldir"
PYTHON_INSTALL_LIB_DIR="$pythoninstalllibdir"
@@ -13500,12 +13500,12 @@ if test "x$pythonprog" != "x"; then
if test "x$pythonusepthreads" = "x"; then
cat - <<_ACEOF >conftest.py
@ -99,8 +81,7 @@ diff -urNp a/swig/python/Makefile.am b/swig/python/Makefile.am
- -PYTHONPATH=$(PYPATH) $(pythonprog) -O -c 'import OpenIPMI.py'
-
OpenIPMI_wrap.c OpenIPMI.py: $(top_srcdir)/swig/OpenIPMI.i OpenIPMI_lang.i
- $(SWIG) $(DEFS) -python -o OpenIPMI_wrap.c -I$(top_srcdir)/swig/python $<
+ $(SWIG) $(DEFS) -python -py3 -o OpenIPMI_wrap.c -I$(top_srcdir)/swig/python $<
$(SWIG) $(DEFS) -python -o OpenIPMI_wrap.c -I$(top_srcdir)/swig/python $<
-CLEANFILES = OpenIPMI_wrap.c OpenIPMI.py OpenIPMI.pyo OpenIPMI.pyc
+CLEANFILES = OpenIPMI_wrap.c OpenIPMI.py
@ -146,8 +127,7 @@ diff -urNp a/swig/python/Makefile.in b/swig/python/Makefile.in
- -PYTHONPATH=$(PYPATH) $(pythonprog) -O -c 'import OpenIPMI.py'
-
OpenIPMI_wrap.c OpenIPMI.py: $(top_srcdir)/swig/OpenIPMI.i OpenIPMI_lang.i
- $(SWIG) $(DEFS) -python -o OpenIPMI_wrap.c -I$(top_srcdir)/swig/python $<
+ $(SWIG) $(DEFS) -python -py3 -o OpenIPMI_wrap.c -I$(top_srcdir)/swig/python $<
$(SWIG) $(DEFS) -python -o OpenIPMI_wrap.c -I$(top_srcdir)/swig/python $<
-install-exec-local: _OpenIPMI.la OpenIPMI.py OpenIPMI.pyc OpenIPMI.pyo
+install-exec-local: _OpenIPMI.la OpenIPMI.py

View File

@ -4,7 +4,7 @@ Summary: IPMI (Intelligent Platform Management Interface) library and tools
Name: OpenIPMI
Version: 2.0.25
Release: 1%{?dist}
Release: 2%{?dist}
License: LGPLv2+ and GPLv2+ or BSD
URL: http://sourceforge.net/projects/openipmi/
Source: http://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
@ -207,6 +207,9 @@ echo ".so man1/openipmish.1" > %{buildroot}%{_mandir}/man1/ipmish.1
%{_mandir}/man5/ipmi_sim_cmd.5*
%changelog
* Wed Apr 18 2018 Josef Ridky <jridky@redhat.com> - 2.0.25-2
- Python3 update
* Tue Apr 17 2018 Josef Ridky <jridky@redhat.com> - 2.0.25-1
- New upstream release 2.0.25 (#1568194)
- Replace Python2 with Python3