This commit is contained in:
aledvink 2014-08-12 14:39:46 +02:00
parent 0b30e4fecb
commit d1a383d0ff
2 changed files with 79 additions and 1 deletions

View File

@ -0,0 +1,70 @@
diff -up ./cmdlang/Makefile.am.nobundle ./cmdlang/Makefile.am
--- ./cmdlang/Makefile.am.nobundle 2013-01-21 18:24:13.000000000 +0100
+++ ./cmdlang/Makefile.am 2014-08-12 13:35:09.836655867 +0200
@@ -4,7 +4,8 @@ LD_VERSION = 0:5:0
AM_CFLAGS = -Wall -Wsign-compare -I$(top_builddir)/include \
-I$(top_srcdir)/include \
- -I$(top_srcdir)/libedit -DIPMI_CHECK_LOCKS $(GLIB_CFLAGS) \
+ -DIPMI_CHECK_LOCKS $(GLIB_CFLAGS) \
+ $(EDIT_CFLAGS) \
$(TCL_CFLAGS)
lib_LTLIBRARIES = libOpenIPMIcmdlang.la
@@ -25,7 +26,7 @@ openipmish_LDADD = libOpenIPMIcmdlang.l
$(top_builddir)/utils/libOpenIPMIutils.la \
$(top_builddir)/lib/libOpenIPMI.la \
$(top_builddir)/unix/libOpenIPMIposix.la \
- $(top_builddir)/libedit/libedit.a \
+ $(EDIT_LIBS) \
$(TERM_LIBS) \
$(SNMPLIBS) $(GLIB_LIB) $(GLIB_LIBS) \
$(TCL_LIB) $(TCL_LIBS) \
diff -up ./configure.ac.nobundle ./configure.ac
--- ./configure.ac.nobundle 2014-01-28 20:35:02.000000000 +0100
+++ ./configure.ac 2014-08-12 13:35:09.836655867 +0200
@@ -930,7 +930,6 @@ AC_OUTPUT(Makefile
swig/perl/Makefile
swig/python/Makefile
swig/python/openipmigui/Makefile
- libedit/Makefile
cmdlang/Makefile
include/Makefile
include/OpenIPMI/Makefile
diff -up ./Makefile.am.nobundle ./Makefile.am
--- ./Makefile.am.nobundle 2012-07-22 00:01:45.000000000 +0200
+++ ./Makefile.am 2014-08-12 13:35:09.836655867 +0200
@@ -1,10 +1,10 @@
RPM = rpmbuild
RPMFLAGS = -ta
-SUBDIRS = include utils lib unix $(GLIB_DIR) $(TCL_DIR) libedit cmdlang \
+SUBDIRS = include utils lib unix $(GLIB_DIR) $(TCL_DIR) cmdlang \
ui lanserv sample doc man $(SWIG_DIR)
-DIST_SUBDIRS = include utils lib unix glib tcl libedit cmdlang \
+DIST_SUBDIRS = include utils lib unix glib tcl cmdlang \
ui lanserv sample doc man swig
EXTRA_DIST = FAQ TODO README.Force README.MotorolaMXP OpenIPMI.spec.in \
diff -up ./sample/Makefile.am.nobundle ./sample/Makefile.am
--- ./sample/Makefile.am.nobundle 2014-08-12 13:36:19.033804459 +0200
+++ ./sample/Makefile.am 2014-08-12 13:37:07.478907706 +0200
@@ -53,8 +53,8 @@ solterm_LDADD = $(POPTLIBS) $(top_buildd
rmcp_ping_SOURCES = rmcp_ping.c
ipmi_serial_bmc_emu_SOURCES = ipmi_serial_bmc_emu.c
-ipmi_serial_bmc_emu_LDADD = $(top_builddir)/libedit/libedit.a $(TERM_LIBS)
-ipmi_serial_bmc_emu_CFLAGS = -I $(top_srcdir)/libedit
+ipmi_serial_bmc_emu_LDADD = $(EDIT_LIBS) $(TERM_LIBS)
+ipmi_serial_bmc_emu_CFLAGS = $(EDIT_CFLAGS)
EXTRA_DIST = example_oem.c
@@ -65,4 +65,4 @@ install-data-local:
$(LN_S) openipmicmd $(DESTDIR)$(bindir)/ipmicmd
uninstall-local:
- rm -f $(DESTDIR)$(bindir)/ipmicmd
\ No newline at end of file
+ rm -f $(DESTDIR)$(bindir)/ipmicmd

View File

@ -1,5 +1,4 @@
%global _hardened_build 1 %global _hardened_build 1
# TODO: uses private copy of libedit, should be modified to use system one
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")} %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
Summary: IPMI (Intelligent Platform Management Interface) library and tools Summary: IPMI (Intelligent Platform Management Interface) library and tools
@ -20,6 +19,8 @@ BuildRequires: gdbm-devel swig glib2-devel net-snmp-devel ncurses-devel
BuildRequires: openssl-devel python-devel perl-devel tcl-devel tkinter BuildRequires: openssl-devel python-devel perl-devel tcl-devel tkinter
BuildRequires: desktop-file-utils BuildRequires: desktop-file-utils
BuildRequires: systemd-units BuildRequires: systemd-units
BuildRequires: pkgconfig
BuildRequires: libedit-devel
# aarch64 workaround remove once released package's config.sub contains aarch64 # aarch64 workaround remove once released package's config.sub contains aarch64
BuildRequires: automake BuildRequires: automake
@ -27,6 +28,7 @@ BuildRequires: autoconf
BuildRequires: libtool BuildRequires: libtool
# aarch64 end # aarch64 end
Requires: libedit
Requires(post): systemd-units Requires(post): systemd-units
Requires(preun): systemd-units Requires(preun): systemd-units
Requires(postun): systemd-units Requires(postun): systemd-units
@ -35,6 +37,8 @@ Requires:%{name}-libs = %{version}-%{release}
Patch1: OpenIPMI-2.0.18-pthread-pkgconfig.patch Patch1: OpenIPMI-2.0.18-pthread-pkgconfig.patch
Patch2: OpenIPMI-2.0.19-man.patch Patch2: OpenIPMI-2.0.19-man.patch
# switch from libedit bundle to system libedit
Patch3: OpenIPMI-2.0.21-nobundle.patch
%description %description
The Open IPMI project aims to develop an open code base to allow access to The Open IPMI project aims to develop an open code base to allow access to
@ -101,8 +105,12 @@ This package contains a network IPMI listener.
%setup -q %setup -q
%patch1 -p1 -b .pthread %patch1 -p1 -b .pthread
%patch2 -p1 -b .manscan %patch2 -p1 -b .manscan
%patch3 -p1 -b .nobundle
rm -rf ./libedit
%build %build
export EDIT_CFLAGS=`pkg-config --cflags libedit`
export EDIT_LIBS=`pkg-config --libs libedit`
export CFLAGS="-fPIC $RPM_OPT_FLAGS -fno-strict-aliasing" export CFLAGS="-fPIC $RPM_OPT_FLAGS -fno-strict-aliasing"
# aarch64 workaround remove once released package's config.sub contains aarch64 # aarch64 workaround remove once released package's config.sub contains aarch64