import OpenIPMI-2.0.27-1.el8
This commit is contained in:
parent
48b4927825
commit
9eeafc3e4f
@ -1,2 +1,2 @@
|
||||
06751d0cd4353edc9711405f829fa7039533239d SOURCES/OpenIPMI-2.0.25.tar.gz
|
||||
043738af9e1aaa6ae4f372d4af7870683e68faf8 SOURCES/OpenIPMI-2.0.27.tar.gz
|
||||
ade00c8a47a576e677ffc2efefca2d7269f175d6 SOURCES/openipmi.sysconf
|
||||
|
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
SOURCES/OpenIPMI-2.0.25.tar.gz
|
||||
SOURCES/OpenIPMI-2.0.27.tar.gz
|
||||
SOURCES/openipmi.sysconf
|
||||
|
@ -1,59 +0,0 @@
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -1,10 +1,10 @@
|
||||
RPM = rpmbuild
|
||||
RPMFLAGS = -ta
|
||||
|
||||
-SUBDIRS = include utils lib unix $(GLIB_DIR) $(TCL_DIR) libedit cmdlang \
|
||||
+SUBDIRS = include utils lib unix $(GLIB_DIR) $(TCL_DIR) cmdlang \
|
||||
ui lanserv sample doc man $(SWIG_DIR)
|
||||
|
||||
-DIST_SUBDIRS = include utils lib unix glib tcl libedit cmdlang \
|
||||
+DIST_SUBDIRS = include utils lib unix glib tcl cmdlang \
|
||||
ui lanserv sample doc man swig
|
||||
|
||||
EXTRA_DIST = FAQ TODO README.Force README.MotorolaMXP OpenIPMI.spec.in \
|
||||
--- a/cmdlang/Makefile.am
|
||||
+++ b/cmdlang/Makefile.am
|
||||
@@ -4,7 +4,8 @@ LD_VERSION = 0:5:0
|
||||
|
||||
AM_CFLAGS = -Wall -Wsign-compare -I$(top_builddir)/include \
|
||||
-I$(top_srcdir)/include \
|
||||
- -I$(top_srcdir)/libedit -DIPMI_CHECK_LOCKS $(GLIB_CFLAGS) \
|
||||
+ -DIPMI_CHECK_LOCKS $(GLIB_CFLAGS) \
|
||||
+ $(EDIT_CFLAGS) \
|
||||
$(TCL_CFLAGS)
|
||||
|
||||
lib_LTLIBRARIES = libOpenIPMIcmdlang.la
|
||||
@@ -25,7 +26,7 @@ openipmish_LDADD = libOpenIPMIcmdlang.la \
|
||||
$(top_builddir)/utils/libOpenIPMIutils.la \
|
||||
$(top_builddir)/lib/libOpenIPMI.la \
|
||||
$(top_builddir)/unix/libOpenIPMIposix.la \
|
||||
- $(top_builddir)/libedit/libedit.a \
|
||||
+ $(EDIT_LIBS) \
|
||||
$(TERM_LIBS) \
|
||||
$(SNMPLIBS) $(GLIB_LIB) $(GLIB_LIBS) \
|
||||
$(TCL_LIB) $(TCL_LIBS) \
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -926,7 +926,6 @@ AC_OUTPUT(Makefile
|
||||
swig/perl/Makefile
|
||||
swig/python/Makefile
|
||||
swig/python/openipmigui/Makefile
|
||||
- libedit/Makefile
|
||||
cmdlang/Makefile
|
||||
include/Makefile
|
||||
include/OpenIPMI/Makefile
|
||||
--- OpenIPMI-2.0.24/sample/Makefile.am~ 2017-07-27 23:01:19.000000000 +0100
|
||||
+++ OpenIPMI-2.0.24/sample/Makefile.am 2017-12-19 07:52:45.368954855 +0000
|
||||
@@ -73,7 +73,8 @@
|
||||
ipmi_serial_bmc_emu_SOURCES = ipmi_serial_bmc_emu.c
|
||||
ipmi_serial_bmc_emu_LDADD = $(top_builddir)/libedit/libedit.a $(TERM_LIBS) \
|
||||
$(SOCKETLIB)
|
||||
-ipmi_serial_bmc_emu_CFLAGS = -I $(top_srcdir)/libedit
|
||||
+ipmi_serial_bmc_emu_LDADD = $(EDIT_LIBS)
|
||||
+ipmi_serial_bmc_emu_CFLAGS = $(EDIT_CFLAGS)
|
||||
|
||||
EXTRA_DIST = example_oem.c
|
||||
|
||||
|
30
SOURCES/0002-readline-includes.patch
Normal file
30
SOURCES/0002-readline-includes.patch
Normal file
@ -0,0 +1,30 @@
|
||||
Fix including readline and readline history headers in OpenIPMI 2.0.27
|
||||
|
||||
It will probably be fixed in next release
|
||||
|
||||
diff --git a/cmdlang/ipmish.c b/cmdlang/ipmish.c
|
||||
index 139da67b..a4b8f0ba 100644
|
||||
--- a/cmdlang/ipmish.c
|
||||
+++ b/cmdlang/ipmish.c
|
||||
@@ -51,6 +51,7 @@
|
||||
#include <OpenIPMI/ipmi_cmdlang.h>
|
||||
#include <OpenIPMI/ipmi_debug.h>
|
||||
#include <readline/readline.h>
|
||||
+#include <readline/history.h>
|
||||
|
||||
#ifdef HAVE_GLIB
|
||||
#include <glib.h>
|
||||
diff --git a/sample/ipmi_serial_bmc_emu.c b/sample/ipmi_serial_bmc_emu.c
|
||||
index e0ae0197..184745ef 100644
|
||||
--- a/sample/ipmi_serial_bmc_emu.c
|
||||
+++ b/sample/ipmi_serial_bmc_emu.c
|
||||
@@ -42,7 +42,8 @@
|
||||
#include <unistd.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/select.h>
|
||||
-#include <editline/readline.h>
|
||||
+#include <readline/readline.h>
|
||||
+#include <readline/history.h>
|
||||
|
||||
#define _GNU_SOURCE
|
||||
#include <getopt.h>
|
@ -1,149 +0,0 @@
|
||||
diff -urNp a/configure b/configure
|
||||
--- a/configure 2018-04-17 08:47:58.528284066 +0200
|
||||
+++ b/configure 2018-04-17 10:00:24.091372864 +0200
|
||||
@@ -13406,7 +13406,7 @@ if test "x$pythoncflags" = "x" -o "x$pyt
|
||||
pythonprog=
|
||||
if test "x$trypython" != "xno"; then
|
||||
# Extract the first word of "python", so it can be a program name with args.
|
||||
-set dummy python; ac_word=$2
|
||||
+set dummy python3; ac_word=$2
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||
$as_echo_n "checking for $ac_word... " >&6; }
|
||||
if ${ac_cv_path_pythonprog+:} false; then :
|
||||
@@ -13500,12 +13500,12 @@ if test "x$pythonprog" != "x"; then
|
||||
if test "x$pythonusepthreads" = "x"; then
|
||||
cat - <<_ACEOF >conftest.py
|
||||
try:
|
||||
- import thread
|
||||
+ import threading
|
||||
print('yes')
|
||||
except:
|
||||
print('no')
|
||||
_ACEOF
|
||||
- pythonusepthreads=`python conftest.py`
|
||||
+ pythonusepthreads=`python3 conftest.py`
|
||||
rm -f conftest.py
|
||||
fi
|
||||
echo "checking for python threads... $pythonusepthreads"
|
||||
@@ -13537,7 +13537,7 @@ try:
|
||||
except:
|
||||
print('no')
|
||||
_ACEOF
|
||||
- tkinter=`python conftest.py`
|
||||
+ tkinter=`python3 conftest.py`
|
||||
rm -f conftest.py
|
||||
fi
|
||||
fi
|
||||
diff -urNp a/configure.ac b/configure.ac
|
||||
--- a/configure.ac 2018-04-17 08:47:58.529284062 +0200
|
||||
+++ b/configure.ac 2018-04-17 10:01:02.115576922 +0200
|
||||
@@ -526,7 +526,7 @@ AC_SUBST(PERL_POSIX_SO)
|
||||
if test "x$pythoncflags" = "x" -o "x$pythoninstalldir" = "x"; then
|
||||
pythonprog=
|
||||
if test "x$trypython" != "xno"; then
|
||||
- AC_PATH_PROG(pythonprog, python)
|
||||
+ AC_PATH_PROG(pythonprog, python3)
|
||||
fi
|
||||
if test "x$pythonprog" != "x"; then
|
||||
# Now find a proper installation location.
|
||||
@@ -578,12 +578,12 @@ if test "x$pythonprog" != "x"; then
|
||||
if test "x$pythonusepthreads" = "x"; then
|
||||
cat - <<_ACEOF >conftest.py
|
||||
try:
|
||||
- import thread
|
||||
+ import threading
|
||||
print('yes')
|
||||
except:
|
||||
print('no')
|
||||
_ACEOF
|
||||
- pythonusepthreads=`python conftest.py`
|
||||
+ pythonusepthreads=`python3 conftest.py`
|
||||
rm -f conftest.py
|
||||
fi
|
||||
echo "checking for python threads... $pythonusepthreads"
|
||||
@@ -615,7 +615,7 @@ try:
|
||||
except:
|
||||
print('no')
|
||||
_ACEOF
|
||||
- tkinter=`python conftest.py`
|
||||
+ tkinter=`python3 conftest.py`
|
||||
rm -f conftest.py
|
||||
fi
|
||||
fi
|
||||
diff -urNp a/swig/python/Makefile.am b/swig/python/Makefile.am
|
||||
--- a/swig/python/Makefile.am 2018-04-17 08:47:58.547283986 +0200
|
||||
+++ b/swig/python/Makefile.am 2018-04-17 14:43:01.703963727 +0200
|
||||
@@ -22,19 +22,14 @@ EXTRA_DIST = OpenIPMI_lang.i OpenIPMI.h
|
||||
OpenIPMI.pyc: OpenIPMI.py _OpenIPMI.la
|
||||
-PYTHONPATH=$(PYPATH) $(pythonprog) -c 'import OpenIPMI.py'
|
||||
|
||||
-OpenIPMI.pyo: OpenIPMI.py _OpenIPMI.la
|
||||
- -PYTHONPATH=$(PYPATH) $(pythonprog) -O -c 'import OpenIPMI.py'
|
||||
-
|
||||
OpenIPMI_wrap.c OpenIPMI.py: $(top_srcdir)/swig/OpenIPMI.i OpenIPMI_lang.i
|
||||
$(SWIG) $(DEFS) -python -o OpenIPMI_wrap.c -I$(top_srcdir)/swig/python $<
|
||||
|
||||
-CLEANFILES = OpenIPMI_wrap.c OpenIPMI.py OpenIPMI.pyo OpenIPMI.pyc
|
||||
+CLEANFILES = OpenIPMI_wrap.c OpenIPMI.py
|
||||
|
||||
-install-exec-local: _OpenIPMI.la OpenIPMI.py OpenIPMI.pyc OpenIPMI.pyo
|
||||
+install-exec-local: _OpenIPMI.la OpenIPMI.py
|
||||
$(INSTALL) -d $(DESTDIR)$(PYTHON_INSTALL_DIR)
|
||||
$(INSTALL_DATA) OpenIPMI.py "$(DESTDIR)$(PYTHON_INSTALL_DIR)"
|
||||
- $(INSTALL_DATA) OpenIPMI.pyc "$(DESTDIR)$(PYTHON_INSTALL_DIR)"
|
||||
- $(INSTALL_DATA) OpenIPMI.pyo "$(DESTDIR)$(PYTHON_INSTALL_DIR)"
|
||||
if test "x$(PYTHON_GUI_DIR)" = "xopenipmigui"; then \
|
||||
$(INSTALL) -d $(DESTDIR)$(bindir); \
|
||||
$(INSTALL_SCRIPT) $(srcdir)/openipmigui.py "$(DESTDIR)$(bindir)/openipmigui";\
|
||||
@@ -43,8 +38,6 @@ install-exec-local: _OpenIPMI.la OpenIPM
|
||||
uninstall-local:
|
||||
$(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(PYTHON_INSTALL_LIB_DIR)/_OpenIPMI.so"
|
||||
rm -f "$(DESTDIR)$(PYTHON_INSTALL_DIR)/OpenIPMI.py"
|
||||
- rm -f "$(DESTDIR)$(PYTHON_INSTALL_DIR)/OpenIPMI.pyc"
|
||||
- rm -f "$(DESTDIR)$(PYTHON_INSTALL_DIR)/OpenIPMI.pyo"
|
||||
rm -f "$(DESTDIR)$(bindir)/openipmigui"
|
||||
|
||||
rungui:
|
||||
diff -urNp a/swig/python/Makefile.in b/swig/python/Makefile.in
|
||||
--- a/swig/python/Makefile.in 2018-04-17 08:47:58.547283986 +0200
|
||||
+++ b/swig/python/Makefile.in 2018-04-17 14:43:28.969899859 +0200
|
||||
@@ -443,7 +443,7 @@ nodist__OpenIPMI_la_SOURCES = OpenIPMI_w
|
||||
_OpenIPMI_la_LDFLAGS = -module -avoid-version
|
||||
_OpenIPMI_la_LIBADD = $(OPENIPMI_SWIG_LIBS) $(PYTHON_POSIX_LIB)
|
||||
EXTRA_DIST = OpenIPMI_lang.i OpenIPMI.h openipmigui.py sample.py sample2.py
|
||||
-CLEANFILES = OpenIPMI_wrap.c OpenIPMI.py OpenIPMI.pyo OpenIPMI.pyc
|
||||
+CLEANFILES = OpenIPMI_wrap.c OpenIPMI.py
|
||||
all: all-recursive
|
||||
|
||||
.SUFFIXES:
|
||||
@@ -837,20 +837,12 @@ uninstall-am: uninstall-local uninstall-
|
||||
.PRECIOUS: Makefile
|
||||
|
||||
|
||||
-OpenIPMI.pyc: OpenIPMI.py _OpenIPMI.la
|
||||
- -PYTHONPATH=$(PYPATH) $(pythonprog) -c 'import OpenIPMI.py'
|
||||
-
|
||||
-OpenIPMI.pyo: OpenIPMI.py _OpenIPMI.la
|
||||
- -PYTHONPATH=$(PYPATH) $(pythonprog) -O -c 'import OpenIPMI.py'
|
||||
-
|
||||
OpenIPMI_wrap.c OpenIPMI.py: $(top_srcdir)/swig/OpenIPMI.i OpenIPMI_lang.i
|
||||
$(SWIG) $(DEFS) -python -o OpenIPMI_wrap.c -I$(top_srcdir)/swig/python $<
|
||||
|
||||
-install-exec-local: _OpenIPMI.la OpenIPMI.py OpenIPMI.pyc OpenIPMI.pyo
|
||||
+install-exec-local: _OpenIPMI.la OpenIPMI.py
|
||||
$(INSTALL) -d $(DESTDIR)$(PYTHON_INSTALL_DIR)
|
||||
$(INSTALL_DATA) OpenIPMI.py "$(DESTDIR)$(PYTHON_INSTALL_DIR)"
|
||||
- $(INSTALL_DATA) OpenIPMI.pyc "$(DESTDIR)$(PYTHON_INSTALL_DIR)"
|
||||
- $(INSTALL_DATA) OpenIPMI.pyo "$(DESTDIR)$(PYTHON_INSTALL_DIR)"
|
||||
if test "x$(PYTHON_GUI_DIR)" = "xopenipmigui"; then \
|
||||
$(INSTALL) -d $(DESTDIR)$(bindir); \
|
||||
$(INSTALL_SCRIPT) $(srcdir)/openipmigui.py "$(DESTDIR)$(bindir)/openipmigui";\
|
||||
@@ -859,8 +851,6 @@ install-exec-local: _OpenIPMI.la OpenIPM
|
||||
uninstall-local:
|
||||
$(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(PYTHON_INSTALL_LIB_DIR)/_OpenIPMI.so"
|
||||
rm -f "$(DESTDIR)$(PYTHON_INSTALL_DIR)/OpenIPMI.py"
|
||||
- rm -f "$(DESTDIR)$(PYTHON_INSTALL_DIR)/OpenIPMI.pyc"
|
||||
- rm -f "$(DESTDIR)$(PYTHON_INSTALL_DIR)/OpenIPMI.pyo"
|
||||
rm -f "$(DESTDIR)$(bindir)/openipmigui"
|
||||
|
||||
rungui:
|
@ -3,8 +3,8 @@
|
||||
Summary: IPMI (Intelligent Platform Management Interface) library and tools
|
||||
Name: OpenIPMI
|
||||
|
||||
Version: 2.0.25
|
||||
Release: 4%{?dist}
|
||||
Version: 2.0.27
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+ and GPLv2+ or BSD
|
||||
URL: http://sourceforge.net/projects/openipmi/
|
||||
Source: http://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
|
||||
@ -12,20 +12,18 @@ Source1: openipmi.sysconf
|
||||
Source2: openipmi-helper
|
||||
Source3: ipmi.service
|
||||
Patch1: 0001-man.patch
|
||||
Patch2: 0002-nobundle.patch
|
||||
Patch3: 0003-Python3.patch
|
||||
Patch2: 0002-readline-includes.patch
|
||||
|
||||
BuildRequires: gdbm-devel swig glib2-devel net-snmp-devel ncurses-devel
|
||||
BuildRequires: openssl-devel python3-devel perl-devel perl-generators
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: libedit-devel
|
||||
BuildRequires: readline-devel
|
||||
BuildRequires: automake
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: libtool
|
||||
%{?systemd_requires}
|
||||
BuildRequires: systemd
|
||||
|
||||
Requires: libedit
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
|
||||
@ -82,19 +80,8 @@ This package contains a network IPMI listener.
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
rm -rf ./libedit
|
||||
|
||||
%build
|
||||
export EDIT_CFLAGS=`pkg-config --cflags libedit`
|
||||
export EDIT_LIBS=`pkg-config --libs libedit`
|
||||
|
||||
# generate new configure script we need this since we removed the libedit directory
|
||||
%{__libtoolize} --copy --force --automake
|
||||
%{__aclocal}
|
||||
%{__autoheader}
|
||||
%{__automake} --add-missing --copy --foreign --force-missing
|
||||
%{__autoconf}
|
||||
# libedit end
|
||||
|
||||
%configure \
|
||||
CFLAGS="-fPIC %{optflags} -z now -fno-strict-aliasing" \
|
||||
@ -102,6 +89,7 @@ export EDIT_LIBS=`pkg-config --libs libedit`
|
||||
--disable-dependency-tracking \
|
||||
--disable-static \
|
||||
--with-pythoninstall=%{python3_sitearch} \
|
||||
--with-python=%{__python3} \
|
||||
--with-tcl=no \
|
||||
--with-tkinter=no
|
||||
|
||||
@ -110,7 +98,7 @@ export EDIT_LIBS=`pkg-config --libs libedit`
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
|
||||
make # not %{?_smp_mflags} safe
|
||||
make # not %%{?_smp_mflags} safe
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot}
|
||||
@ -207,6 +195,9 @@ echo ".so man1/openipmish.1" > %{buildroot}%{_mandir}/man1/ipmish.1
|
||||
%{_mandir}/man5/ipmi_sim_cmd.5*
|
||||
|
||||
%changelog
|
||||
* Tue Oct 08 2019 Vaclav Dolezal <vdolezal@redhat.com> - 2.0.27-1
|
||||
- New upstream release 2.0.27
|
||||
|
||||
* Thu Aug 09 2018 Josef Ridky <jridky@redhat.com> - 2.0.25-4
|
||||
- Rebuild for Net-SNMP
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user