Update to 3.0.5.
This commit is contained in:
parent
cb1fae0310
commit
a14aaf7129
3
.gitignore
vendored
3
.gitignore
vendored
@ -1,3 +1,6 @@
|
|||||||
/openexr-2.5.3.tar.gz
|
/openexr-2.5.3.tar.gz
|
||||||
/openexr-2.5.4.tar.gz
|
/openexr-2.5.4.tar.gz
|
||||||
/openexr-2.5.5.tar.gz
|
/openexr-2.5.5.tar.gz
|
||||||
|
/openexr-3.0.1.tar.gz
|
||||||
|
/openexr-3.0.4.tar.gz
|
||||||
|
/openexr-3.0.5.tar.gz
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
Index: openexr-2.5.3/OpenEXR/IlmImf/dwaLookups.cpp
|
|
||||||
===================================================================
|
|
||||||
--- openexr-2.5.3.orig/OpenEXR/IlmImf/dwaLookups.cpp
|
|
||||||
+++ openexr-2.5.3/OpenEXR/IlmImf/dwaLookups.cpp
|
|
||||||
@@ -300,7 +300,8 @@ generateNoop()
|
|
||||||
unsigned short src = (unsigned short)i;
|
|
||||||
Xdr::write <CharPtrIO> (tmp, src);
|
|
||||||
|
|
||||||
- printf("0x%04x, ", dst);
|
|
||||||
+ // DST is a short, so the right length modifier is 'h'
|
|
||||||
+ printf("0x%04hx, ", dst);
|
|
||||||
}
|
|
||||||
printf("\n};\n");
|
|
||||||
}
|
|
30
openexr.spec
30
openexr.spec
@ -1,19 +1,18 @@
|
|||||||
%{?!python3_pkgversion:%global python3_pkgversion 3}
|
%{?!python3_pkgversion:%global python3_pkgversion 3}
|
||||||
%global sover 25
|
%global sover 29
|
||||||
|
|
||||||
Name: openexr
|
Name: openexr
|
||||||
Version: 2.5.5
|
Version: 3.0.5
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Provides the specification and reference implementation of the EXR file format
|
Summary: Provides the specification and reference implementation of the EXR file format
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: https://www.openexr.com/
|
URL: https://www.openexr.com/
|
||||||
Source0: https://github.com/AcademySoftwareFoundation/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
Source0: https://github.com/AcademySoftwareFoundation/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
Patch0: openexr-gcc11.patch
|
|
||||||
|
|
||||||
BuildRequires: cmake gcc gcc-c++
|
BuildRequires: cmake gcc gcc-c++
|
||||||
BuildRequires: boost-devel
|
BuildRequires: boost-devel
|
||||||
|
BuildRequires: imath-devel
|
||||||
BuildRequires: python%{python3_pkgversion}-devel
|
BuildRequires: python%{python3_pkgversion}-devel
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
|
|
||||||
@ -72,14 +71,6 @@ useful mathematical objects, functions, and data types common in computer
|
|||||||
graphics applications, including the “half” 16-bit floating-point type.
|
graphics applications, including the “half” 16-bit floating-point type.
|
||||||
|
|
||||||
|
|
||||||
%package -n python%{python3_pkgversion}-openexr
|
|
||||||
Summary: Python 3 binding for OpenEXR
|
|
||||||
%{?python_provide:%python_provide python3-openexr}
|
|
||||||
|
|
||||||
%description -n python%{python3_pkgversion}-openexr
|
|
||||||
%{summary}.
|
|
||||||
|
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
@ -125,26 +116,19 @@ Summary: Development files for %{name}
|
|||||||
%doc CHANGES.md CONTRIBUTING.md GOVERNANCE.md SECURITY.md CODE_OF_CONDUCT.md CONTRIBUTORS.md README.md
|
%doc CHANGES.md CONTRIBUTING.md GOVERNANCE.md SECURITY.md CODE_OF_CONDUCT.md CONTRIBUTORS.md README.md
|
||||||
%license LICENSE.md
|
%license LICENSE.md
|
||||||
%{_libdir}/*.so.%{sover}*
|
%{_libdir}/*.so.%{sover}*
|
||||||
%exclude %{_libdir}/libPy*
|
|
||||||
|
|
||||||
%files -n python%{python3_pkgversion}-openexr
|
|
||||||
# Is it OK to dump the libraries in site-packages?
|
|
||||||
%{_libdir}/libPy*.so.%{sover}*
|
|
||||||
%{python3_sitearch}/*.so
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_docdir}/OpenEXR/
|
%{_docdir}/OpenEXR/
|
||||||
%{_includedir}/OpenEXR/
|
%{_includedir}/OpenEXR/
|
||||||
%{_libdir}/*.so
|
%{_libdir}/*.so
|
||||||
%{_libdir}/cmake/IlmBase/
|
|
||||||
%{_libdir}/pkgconfig/IlmBase.pc
|
|
||||||
%{_libdir}/cmake/PyIlmBase/
|
|
||||||
%{_libdir}/pkgconfig/PyIlmBase.pc
|
|
||||||
%{_libdir}/cmake/OpenEXR/
|
%{_libdir}/cmake/OpenEXR/
|
||||||
%{_libdir}/pkgconfig/OpenEXR.pc
|
%{_libdir}/pkgconfig/OpenEXR.pc
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 20 2021 Richard Shaw <hobbes1069@gmail.com> - 3.0.5-1
|
||||||
|
- Update to 3.0.5.
|
||||||
|
|
||||||
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 2.5.5-2
|
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 2.5.5-2
|
||||||
- Rebuilt for Python 3.10
|
- Rebuilt for Python 3.10
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (openexr-2.5.5.tar.gz) = e511af26a8fe2175a641fd25d2dcc6ef807e00bee2aff06a4784125f916ffd47fe376fe0621d385b604180a239bbfee063f8ceee3f7b731fde3c38558e9fdcdf
|
SHA512 (openexr-3.0.5.tar.gz) = 7a0f83320ad5e1d8f8414b5175a64eef3c6b06a7ccd7d66d0aa21472ea22146e2617ff10c20e04203fc2a3326d8bac2d95023bec315badb03e6a006596b64595
|
||||||
|
Loading…
Reference in New Issue
Block a user