import OpenEXR-2.2.0-11.el8
This commit is contained in:
commit
1467ea6b56
1
.OpenEXR.metadata
Normal file
1
.OpenEXR.metadata
Normal file
@ -0,0 +1 @@
|
||||
d09a68c4443b7a12a0484c073adaef348b44cb92 SOURCES/openexr-2.2.0.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/openexr-2.2.0.tar.gz
|
63
SOURCES/openexr-2.1.0-bigendian.patch
Normal file
63
SOURCES/openexr-2.1.0-bigendian.patch
Normal file
@ -0,0 +1,63 @@
|
||||
diff -up openexr-2.1.0/IlmImfTest/testFutureProofing.cpp.bigendian openexr-2.1.0/IlmImfTest/testFutureProofing.cpp
|
||||
--- openexr-2.1.0/IlmImfTest/testFutureProofing.cpp.bigendian 2013-11-11 17:09:51.000000000 -0600
|
||||
+++ openexr-2.1.0/IlmImfTest/testFutureProofing.cpp 2013-11-27 08:43:55.486026741 -0600
|
||||
@@ -40,6 +40,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <assert.h>
|
||||
+#include <byteswap.h>
|
||||
|
||||
#include "tmpDir.h"
|
||||
#include "testFutureProofing.h"
|
||||
@@ -64,6 +65,7 @@
|
||||
#include <ImfNamespace.h>
|
||||
#include <ImathNamespace.h>
|
||||
#include <IlmThreadNamespace.h>
|
||||
+#include <ImfSystemSpecific.h>
|
||||
|
||||
namespace IMF = OPENEXR_IMF_NAMESPACE;
|
||||
using namespace IMF;
|
||||
@@ -1234,6 +1236,12 @@ modifyType (bool modify_version)
|
||||
|
||||
//length of attribute
|
||||
fread(&length,4,1,f);
|
||||
+ if (!GLOBAL_SYSTEM_LITTLE_ENDIAN)
|
||||
+ {
|
||||
+ int tmp = bswap_32(length);
|
||||
+ length = tmp;
|
||||
+ }
|
||||
+
|
||||
if(!modify_version && attrib_name=="type")
|
||||
{
|
||||
// modify the type of part 1 to be 'X<whatevever>'
|
||||
diff -up openexr-2.1.0/IlmImfTest/testMultiPartFileMixingBasic.cpp.bigendian openexr-2.1.0/IlmImfTest/testMultiPartFileMixingBasic.cpp
|
||||
--- openexr-2.1.0/IlmImfTest/testMultiPartFileMixingBasic.cpp.bigendian 2013-11-11 17:09:52.000000000 -0600
|
||||
+++ openexr-2.1.0/IlmImfTest/testMultiPartFileMixingBasic.cpp 2013-11-27 08:44:19.370775892 -0600
|
||||
@@ -40,6 +40,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <assert.h>
|
||||
+#include <byteswap.h>
|
||||
|
||||
#include "tmpDir.h"
|
||||
#include "testMultiPartFileMixingBasic.h"
|
||||
@@ -59,6 +60,7 @@
|
||||
#include <ImfDeepScanLineInputPart.h>
|
||||
#include <ImfPartType.h>
|
||||
#include <ImfMisc.h>
|
||||
+#include <ImfSystemSpecific.h>
|
||||
|
||||
namespace IMF = OPENEXR_IMF_NAMESPACE;
|
||||
using namespace IMF;
|
||||
@@ -1383,6 +1385,11 @@ killOffsetTables (const std::string & fn
|
||||
|
||||
//length of attribute
|
||||
fread(&length,4,1,f);
|
||||
+ if (!GLOBAL_SYSTEM_LITTLE_ENDIAN)
|
||||
+ {
|
||||
+ int tmp = bswap_32(length);
|
||||
+ length = tmp;
|
||||
+ }
|
||||
|
||||
//value of attribute
|
||||
for(int i=0;i<length;i++)
|
271
SPECS/OpenEXR.spec
Normal file
271
SPECS/OpenEXR.spec
Normal file
@ -0,0 +1,271 @@
|
||||
Name: OpenEXR
|
||||
Summary: A high dynamic-range (HDR) image file format
|
||||
Version: 2.2.0
|
||||
Release: 11%{?dist}
|
||||
|
||||
License: BSD
|
||||
URL: http://www.openexr.com/
|
||||
Source0: http://download.savannah.nongnu.org/releases/openexr/openexr-%{version}.tar.gz
|
||||
# fix tests for big endian arches
|
||||
# https://github.com/openexr/openexr/issues/81
|
||||
Patch0: openexr-2.1.0-bigendian.patch
|
||||
|
||||
Obsoletes: openexr < %{version}-%{release}
|
||||
Provides: openexr = %{version}-%{release}
|
||||
|
||||
# https://github.com/openexr/openexr/issues/130
|
||||
BuildConflicts: OpenEXR-devel < 2.2.0
|
||||
|
||||
BuildRequires: ilmbase-devel >= %{version}
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: pkgconfig
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description
|
||||
OpenEXR is a high dynamic-range (HDR) image file format developed by Industrial
|
||||
Light & Magic for use in computer imaging applications. This package contains
|
||||
libraries and sample applications for handling the format.
|
||||
|
||||
%package devel
|
||||
Summary: Headers and libraries for building apps that use %{name}
|
||||
Obsoletes: openexr-devel < %{version}-%{release}
|
||||
Provides: openexr-devel = %{version}-%{release}
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: ilmbase-devel%{?_isa}
|
||||
%description devel
|
||||
%{summary}.
|
||||
|
||||
%package libs
|
||||
Summary: %{name} runtime libraries
|
||||
%description libs
|
||||
%{summary}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n openexr-%{version}
|
||||
%patch0 -p1 -b .bigendian
|
||||
|
||||
|
||||
%build
|
||||
%configure --disable-static
|
||||
|
||||
# hack to omit unused-direct-shlib-dependencies
|
||||
#sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot}
|
||||
|
||||
#unpackaged files
|
||||
rm -fv %{buildroot}%{_libdir}/lib*.la
|
||||
rm -rf %{buildroot}%{_docdir}/%{name}-%{version}
|
||||
|
||||
|
||||
%check
|
||||
export PKG_CONFIG_PATH=%{buildroot}%{_libdir}/pkgconfig
|
||||
test "$(pkg-config --modversion OpenEXR)" = "%{version}"
|
||||
make %{?_smp_mflags} check ||:
|
||||
|
||||
|
||||
%files
|
||||
%{_bindir}/exr*
|
||||
|
||||
%post libs -p /sbin/ldconfig
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%files libs
|
||||
%doc AUTHORS ChangeLog LICENSE NEWS README
|
||||
%{_libdir}/libIlmImf-2_2.so.22*
|
||||
%{_libdir}/libIlmImfUtil-2_2.so.22*
|
||||
|
||||
%files devel
|
||||
#omit for now, they're mostly useless, and include multilib conflicts (#342781)
|
||||
#doc rpmdocs/examples
|
||||
%{_datadir}/aclocal/openexr.m4
|
||||
%{_includedir}/OpenEXR/*
|
||||
%{_libdir}/libIlmImf*.so
|
||||
%{_libdir}/pkgconfig/OpenEXR.pc
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.0-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.0-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.0-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.0-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Oct 12 2016 Björn Esser <fedora@besser82.io> - 2.2.0-7
|
||||
- rebuild (GCC 6.2)
|
||||
- whitespace clean-up
|
||||
|
||||
* Tue Oct 11 2016 Rex Dieter <rdieter@fedoraproject.org> - 2.2.0-6
|
||||
- -devel: make ilmbase-devel dep arch'd
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Jun 16 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Thu Apr 16 2015 Rex Dieter <rdieter@fedoraproject.org> 2.2.0-3
|
||||
- rebuild (gcc5)
|
||||
|
||||
* Wed Feb 18 2015 Rex Dieter <rdieter@fedoraproject.org> 2.2.0-2
|
||||
- rebuild (gcc5)
|
||||
|
||||
* Thu Nov 20 2014 Rex Dieter <rdieter@fedoraproject.org> 2.2.0-1
|
||||
- 2.2.0
|
||||
|
||||
* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Fri Jan 31 2014 Rex Dieter <rdieter@fedoraproject.org> 2.1.0-3
|
||||
- respin headers patch (to match upstream fix)
|
||||
|
||||
* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 2.1.0-2
|
||||
- install ImfDeepImageStateAttribute.h header too
|
||||
|
||||
* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 2.1.0-1
|
||||
- 2.1.0
|
||||
|
||||
* Wed Nov 20 2013 Dan Horák <dan[at]danny.cz> 2.0.1-3
|
||||
- remove testing residue from optflags
|
||||
|
||||
* Wed Nov 20 2013 Dan Horák <dan[at]danny.cz> 2.0.1-2
|
||||
- fix tests for big endian arches
|
||||
|
||||
* Wed Aug 28 2013 Rex Dieter <rdieter@fedoraproject.org> 2.0.1-1
|
||||
- openexr-2.0.1
|
||||
|
||||
* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Sun Mar 10 2013 Nicolas Chauvet <kwizart@gmail.com> - 1.7.1-5
|
||||
- Back to upstream ABI (f19+, el7+)
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Mon Oct 15 2012 Nicolas Chauvet <kwizart@gmail.com> - 1.7.1-3
|
||||
- Bump to hide revertion
|
||||
|
||||
* Fri Aug 31 2012 Rex Dieter <rdieter@fedoraproject.org> 1.7.1-2
|
||||
- rebuild
|
||||
|
||||
* Thu Aug 02 2012 Nicolas Chauvet <kwizart@gmail.com> - 1.7.1-1
|
||||
- Update to 1.7.1
|
||||
|
||||
-* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-5
|
||||
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-4
|
||||
- Rebuilt for c++ ABI breakage
|
||||
|
||||
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Aug 11 2010 Rex Dieter <rdieter@fedoraproject.org> 1.7.0-1
|
||||
- openexr-1.7.0
|
||||
|
||||
* Wed Jul 29 2009 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-8
|
||||
- CVE-2009-1720 OpenEXR: Multiple integer overflows (#513995)
|
||||
- CVE-2009-1721 OpenEXR: Invalid pointer free by image decompression (#514003)
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.1-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Fri Dec 12 2008 Caolán McNamara <caolanm@redhat.com> 1.6.1-5
|
||||
- rebuild to get provides pkgconfig(OpenEXR)
|
||||
|
||||
* Fri May 09 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-4
|
||||
- drop: Obsoletes: OpenEXR-utils (see OpenEXR_Viewers review, bug #428228c3)
|
||||
|
||||
* Fri Feb 01 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-3
|
||||
- gcc43 patch
|
||||
- purge rpaths
|
||||
|
||||
* Wed Jan 09 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-2
|
||||
- hack to omit unused-direct-shlib-dependencies
|
||||
- conditionalize -libs (f8+)
|
||||
|
||||
* Mon Jan 07 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-1
|
||||
- openexr-1.6.1
|
||||
|
||||
* Tue Oct 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-5
|
||||
- multiarch conflicts in OpenEXR (#342781)
|
||||
- don't own %%_includedir/OpenEXR (leave that to ilmbase)
|
||||
|
||||
* Mon Oct 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-4
|
||||
- -libs: %%post/%%postun -p /sbin/ldconfig
|
||||
|
||||
* Fri Oct 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-2
|
||||
- openexr-1.6.0
|
||||
|
||||
* Mon Sep 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-6
|
||||
- libs: -Requires: %%name
|
||||
|
||||
* Wed Aug 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-5
|
||||
- -libs: new subpkg to be multilib friendly
|
||||
- -utils: package exrdisplay separately (separate fltk dep)
|
||||
|
||||
* Sat Oct 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-4
|
||||
- Obsoletes/Provides: openexr(-devel) (rpmforge compatibility)
|
||||
|
||||
* Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-3
|
||||
- pkgconfig patch to use Libs.private
|
||||
|
||||
* Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-2
|
||||
- -devel: +Requires: pkgconfig
|
||||
|
||||
* Tue Aug 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-1
|
||||
- openexr-1.4.0a
|
||||
|
||||
* Sat Feb 18 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-7
|
||||
- Further zlib fixes (#165729)
|
||||
|
||||
* Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-6
|
||||
- Rebuild for Fedora Extras 5
|
||||
|
||||
* Wed Aug 17 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-5
|
||||
- Remove *.a from %%files devel
|
||||
|
||||
* Tue Aug 16 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-4
|
||||
- Removed -devel dep on zlib-devel (#165729)
|
||||
- Added --disable-static to %%configure
|
||||
- Fixed build with GCC 4.0.1
|
||||
- Added .so links to -devel
|
||||
|
||||
* Wed May 18 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-3
|
||||
- Add zlib-devel to BR
|
||||
- Delete all .la files (#157652)
|
||||
|
||||
* Mon May 9 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
|
||||
- Add disttag
|
||||
|
||||
* Sun May 8 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
|
||||
- Fix BuildRequires
|
||||
- Fix Requires on -devel
|
||||
- Add %%post[un] scriptlets
|
||||
- Fix ownership in -devel
|
||||
- Don't have .deps files in %%doc
|
||||
|
||||
* Wed Mar 30 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-1
|
||||
- Initial RPM release
|
Loading…
Reference in New Issue
Block a user