- Fix WPA passphrase hashing on big endian (PPC, Sparc, etc) (rh #426233)
This commit is contained in:
parent
bbeb7a1f5f
commit
f7bb7f5f6c
@ -139,18 +139,17 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.
|
|||||||
nm_connection_editor_CPPFLAGS = \
|
nm_connection_editor_CPPFLAGS = \
|
||||||
$(NMA_CFLAGS) \
|
$(NMA_CFLAGS) \
|
||||||
-DICONDIR=\""$(datadir)/icons"\" \
|
-DICONDIR=\""$(datadir)/icons"\" \
|
||||||
@@ -24,7 +28,9 @@ nm_connection_editor_SOURCES = \
|
@@ -29,7 +33,9 @@ nm_connection_editor_LDADD = \
|
||||||
main.c
|
$(top_builddir)/src/gconf-helpers/libgconf-helpers.la \
|
||||||
|
${top_builddir}/src/wireless-security/libwireless-security.la \
|
||||||
nm_connection_editor_LDADD = \
|
${top_builddir}/src/utils/libutils.la \
|
||||||
- $(top_builddir)/src/gconf-helpers/libgconf-helpers.la \
|
- $(NMA_LIBS)
|
||||||
+ ${top_builddir}/src/gconf-helpers/libgconf-helpers.la \
|
+ $(NMA_LIBS) \
|
||||||
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la \
|
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la
|
||||||
$(NMA_LIBS)
|
|
||||||
|
|
||||||
gladedir = $(datadir)/nm-applet
|
gladedir = $(datadir)/nm-applet
|
||||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am
|
glade_DATA = nm-connection-editor.gladediff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am
|
||||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix 2007-10-27 18:11:31.000000000 -0400
|
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix 2007-10-27 18:11:31.000000000 -0400
|
||||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am 2007-11-13 15:14:13.000000000 -0500
|
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am 2007-11-13 15:14:13.000000000 -0500
|
||||||
@@ -4,6 +4,10 @@ NULL=
|
@@ -4,6 +4,10 @@ NULL=
|
||||||
|
@ -7,7 +7,7 @@ ExcludeArch: s390 s390x
|
|||||||
%define gtk2_version 2.12.0
|
%define gtk2_version 2.12.0
|
||||||
%define wireless_tools_version 1:28-0pre9
|
%define wireless_tools_version 1:28-0pre9
|
||||||
|
|
||||||
%define snapshot svn3181
|
%define snapshot svn3204
|
||||||
|
|
||||||
Name: NetworkManager
|
Name: NetworkManager
|
||||||
Summary: Network connection manager and user applications
|
Summary: Network connection manager and user applications
|
||||||
@ -18,7 +18,7 @@ Group: System Environment/Base
|
|||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.gnome.org/projects/NetworkManager/
|
URL: http://www.gnome.org/projects/NetworkManager/
|
||||||
Source: %{name}-%{version}.%{snapshot}.tar.gz
|
Source: %{name}-%{version}.%{snapshot}.tar.gz
|
||||||
Source1: nm-applet-%{version}.svn405.tar.gz
|
Source1: nm-applet-%{version}.svn429.tar.gz
|
||||||
Patch1: NetworkManager-0.6.5-fixup-internal-applet-build.patch
|
Patch1: NetworkManager-0.6.5-fixup-internal-applet-build.patch
|
||||||
Patch2: nm-applet-0.7.0-disable-stuff.patch
|
Patch2: nm-applet-0.7.0-disable-stuff.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -228,13 +228,13 @@ fi
|
|||||||
%{_bindir}/nm-tool
|
%{_bindir}/nm-tool
|
||||||
%{_libexecdir}/nm-dhcp-client.action
|
%{_libexecdir}/nm-dhcp-client.action
|
||||||
%{_libdir}/libnm-util.so*
|
%{_libdir}/libnm-util.so*
|
||||||
%{_libdir}/pppd/2.4.4/nm-pppd-plugin.so
|
|
||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
%{_mandir}/man8/*
|
%{_mandir}/man8/*
|
||||||
%dir %{_localstatedir}/run/NetworkManager
|
%dir %{_localstatedir}/run/NetworkManager
|
||||||
%{_prefix}/libexec/nm-crash-logger
|
%{_prefix}/libexec/nm-crash-logger
|
||||||
%dir %{_datadir}/NetworkManager
|
%dir %{_datadir}/NetworkManager
|
||||||
%{_datadir}/NetworkManager/gdb-cmd
|
%{_datadir}/NetworkManager/gdb-cmd
|
||||||
|
%{_libdir}/pppd/2.4.4/nm-pppd-plugin.so
|
||||||
|
|
||||||
%files gnome
|
%files gnome
|
||||||
%defattr(-,root,root,0755)
|
%defattr(-,root,root,0755)
|
||||||
@ -269,6 +269,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 4 2008 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.8.svn3204
|
||||||
|
- Fix WPA passphrase hashing on big endian (PPC, Sparc, etc) (rh #426233)
|
||||||
|
|
||||||
* Tue Dec 18 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.8.svn3181
|
* Tue Dec 18 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.8.svn3181
|
||||||
- Fixes to work better with new libnl (rh #401761)
|
- Fixes to work better with new libnl (rh #401761)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user