- New snapshot
- Fix applet icon sizing on start (mclasen) - Fix nm-tool installation (mclasen) - Fix 'state' method call return (#303271) - Fix 40-bit WEP keys (again) - Fix loop when secrets were wrong/invalid - Fix applet crash when clicking Cancel in the password dialog - Ensure NM doesn't get stuck waiting for the supplicant to re-appear if it crashes or goes away - Make VPN properties applet work again - Increase timeout for network password entry
This commit is contained in:
parent
8c53f10294
commit
ecd626da1c
@ -9,3 +9,5 @@ nm-applet-0.7.0.svn190.tar.gz
|
||||
NetworkManager-0.7.0.svn2849.tar.gz
|
||||
NetworkManager-0.7.0.svn2852.tar.gz
|
||||
nm-applet-0.7.0.svn191.tar.gz
|
||||
NetworkManager-0.7.0.svn2880.tar.gz
|
||||
nm-applet-0.7.0.svn199.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix 2007-09-19 22:10:17.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac 2007-09-20 08:11:45.000000000 -0400
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix 2007-09-24 11:02:11.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac 2007-09-25 03:27:22.000000000 -0400
|
||||
@@ -18,10 +18,10 @@ dnl
|
||||
dnl This doesn't depend on gnome support, only on gnome-common, autogen already
|
||||
dnl uses gnome-autogen
|
||||
@ -25,9 +25,34 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix NetworkManag
|
||||
gtk+-2.0 >= 2.6
|
||||
libglade-2.0
|
||||
gconf-2.0
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am.buildfix 2007-09-25 03:33:31.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am 2007-09-25 03:34:10.000000000 -0400
|
||||
@@ -1,6 +1,10 @@
|
||||
|
||||
bin_PROGRAMS = nm-vpn-properties
|
||||
|
||||
+INCLUDES = -I${top_srcdir}/../include \
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
+ -I${top_srcdir}/../libnm-glib
|
||||
+
|
||||
nm_vpn_propertiesdir=$(includedir)/NetworkManager
|
||||
|
||||
nm_vpn_properties_HEADERS = \
|
||||
@@ -28,7 +32,9 @@ nm_vpn_properties_CFLAGS = \
|
||||
|
||||
nm_vpn_properties_LDADD = \
|
||||
$(NMA_LIBS) \
|
||||
- ${top_builddir}/src/gconf-helpers/libgconf-helpers.la
|
||||
+ ${top_builddir}/src/gconf-helpers/libgconf-helpers.la \
|
||||
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la
|
||||
|
||||
CLEANFILES = $(server_DATA) *.bak *.gladep *~
|
||||
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am.buildfix 2007-09-19 22:53:14.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am 2007-09-20 08:15:42.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am 2007-09-25 03:27:22.000000000 -0400
|
||||
@@ -1,8 +1,15 @@
|
||||
+INCLUDES = -I${top_srcdir}/../include \
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
@ -47,7 +72,7 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am.buil
|
||||
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.buildfix 2007-09-20 07:40:37.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am 2007-09-20 08:16:10.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am 2007-09-25 03:27:22.000000000 -0400
|
||||
@@ -2,6 +2,10 @@ NULL=
|
||||
|
||||
bin_PROGRAMS = nm-connection-editor
|
||||
@ -72,7 +97,7 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.
|
||||
glade_DATA = nm-connection-editor.glade
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix 2007-09-20 07:43:02.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am 2007-09-20 08:11:45.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am 2007-09-25 03:27:22.000000000 -0400
|
||||
@@ -4,6 +4,10 @@ NULL=
|
||||
|
||||
bin_PROGRAMS = nm-applet
|
||||
|
@ -7,7 +7,7 @@ ExcludeArch: s390 s390x
|
||||
%define gtk2_version 2.10.0
|
||||
%define wireless_tools_version 1:28-0pre9
|
||||
|
||||
%define snapshot svn2852
|
||||
%define snapshot svn2880
|
||||
|
||||
Name: NetworkManager
|
||||
Summary: Network connection manager and user applications
|
||||
@ -18,8 +18,9 @@ Group: System Environment/Base
|
||||
License: GPLv2+
|
||||
URL: http://www.gnome.org/projects/NetworkManager/
|
||||
Source: %{name}-%{version}.%{snapshot}.tar.gz
|
||||
Source1: nm-applet-%{version}.svn191.tar.gz
|
||||
Source1: nm-applet-%{version}.svn199.tar.gz
|
||||
Patch1: NetworkManager-0.6.5-fixup-internal-applet-build.patch
|
||||
Patch2: nm-applet-0.7.0-no-connection-editor.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
PreReq: chkconfig
|
||||
@ -122,6 +123,7 @@ NetworkManager functionality from applications that use glib.
|
||||
# unpack the applet
|
||||
tar -xzf %{SOURCE1}
|
||||
%patch1 -p1 -b .buildfix
|
||||
%patch2 -p1 -b .no-connection-editor
|
||||
|
||||
%build
|
||||
# Even though we don't require named, we still build with it
|
||||
@ -257,6 +259,19 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Sep 25 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.3.svn2880
|
||||
- New snapshot
|
||||
- Fix applet icon sizing on start (mclasen)
|
||||
- Fix nm-tool installation (mclasen)
|
||||
- Fix 'state' method call return (#303271)
|
||||
- Fix 40-bit WEP keys (again)
|
||||
- Fix loop when secrets were wrong/invalid
|
||||
- Fix applet crash when clicking Cancel in the password dialog
|
||||
- Ensure NM doesn't get stuck waiting for the supplicant to re-appear
|
||||
if it crashes or goes away
|
||||
- Make VPN properties applet work again
|
||||
- Increase timeout for network password entry
|
||||
|
||||
* Fri Sep 21 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.3.svn2852
|
||||
- New snapshot (fix unencrypted & 40 bit WEP)
|
||||
|
||||
|
19
nm-applet-0.7.0-no-connection-editor.patch
Normal file
19
nm-applet-0.7.0-no-connection-editor.patch
Normal file
@ -0,0 +1,19 @@
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/applet.c.no-con-editor NetworkManager-0.7.0/nm-applet-0.7.0/src/applet.c
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/applet.c.no-con-editor 2007-09-25 05:18:05.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/applet.c 2007-09-25 05:18:41.000000000 -0400
|
||||
@@ -1781,6 +1781,7 @@ static GtkWidget *nma_context_menu_creat
|
||||
gtk_image_menu_item_set_image (GTK_IMAGE_MENU_ITEM (applet->info_menu_item), image);
|
||||
gtk_menu_shell_append (menu, applet->info_menu_item);
|
||||
|
||||
+#if 0
|
||||
/* 'Edit Connections...' item */
|
||||
applet->connections_menu_item = gtk_menu_item_new_with_mnemonic (_("Edit Connections..."));
|
||||
g_signal_connect (applet->connections_menu_item,
|
||||
@@ -1788,6 +1789,7 @@ static GtkWidget *nma_context_menu_creat
|
||||
G_CALLBACK (nma_edit_connections_cb),
|
||||
applet);
|
||||
gtk_menu_shell_append (menu, applet->connections_menu_item);
|
||||
+#endif
|
||||
|
||||
/* Separator */
|
||||
nma_menu_add_separator_item (menu);
|
Loading…
Reference in New Issue
Block a user