- core: add Bluetooth Dial-Up Networking (DUN) support (rh #136663)
- core: start DHCPv6 on receipt of RA 'otherconf'/'managed' bits - nmcli: allow enable/disable of WiFi and WWAN
This commit is contained in:
parent
91d90886ef
commit
d80f4aaeb0
@ -180,3 +180,5 @@ network-manager-applet-0.7.998.git20100106.tar.bz2
|
||||
NetworkManager-0.7.999.git20100122.tar.bz2
|
||||
network-manager-applet-0.7.999.git20100120.tar.bz2
|
||||
nmcli-git20100122.tar.bz2
|
||||
NetworkManager-0.7.999.git20100129.tar.bz2
|
||||
network-manager-applet-0.7.999.git20100129.tar.bz2
|
||||
|
@ -9,15 +9,16 @@
|
||||
%define libnl_version 1.1
|
||||
%define ppp_version 2.4.5
|
||||
|
||||
%define snapshot .git20100122
|
||||
%define applet_snapshot .git20100120
|
||||
%define snapshot .git20100129
|
||||
%define applet_snapshot .git20100129
|
||||
%define nmcli_snapshot -git20100129
|
||||
%define realversion 0.7.999
|
||||
|
||||
Name: NetworkManager
|
||||
Summary: Network connection manager and user applications
|
||||
Epoch: 1
|
||||
Version: 0.8.0
|
||||
Release: 0.1%{snapshot}%{?dist}
|
||||
Release: 0.2%{snapshot}%{?dist}
|
||||
Group: System Environment/Base
|
||||
License: GPLv2+
|
||||
URL: http://www.gnome.org/projects/NetworkManager/
|
||||
@ -25,7 +26,7 @@ URL: http://www.gnome.org/projects/NetworkManager/
|
||||
Source: %{name}-%{realversion}%{snapshot}.tar.bz2
|
||||
Source1: network-manager-applet-%{realversion}%{applet_snapshot}.tar.bz2
|
||||
Source2: nm-system-settings.conf
|
||||
Source3: nmcli-git20100122.tar.bz2
|
||||
Source3: nmcli%{nmcli_snapshot}.tar.bz2
|
||||
Patch1: nm-applet-internal-buildfixes.patch
|
||||
Patch2: explain-dns1-dns2.patch
|
||||
Patch3: nm-applet-no-notifications.patch
|
||||
@ -379,6 +380,11 @@ fi
|
||||
%{_datadir}/gtk-doc/html/libnm-util/*
|
||||
|
||||
%changelog
|
||||
* Fri Jan 29 2010 Dan Williams <dcbw@redhat.com> - 0.8-0.2.git20100129
|
||||
- core: add Bluetooth Dial-Up Networking (DUN) support (rh #136663)
|
||||
- core: start DHCPv6 on receipt of RA 'otherconf'/'managed' bits
|
||||
- nmcli: allow enable/disable of WiFi and WWAN
|
||||
|
||||
* Fri Jan 22 2010 Dan Williams <dcbw@redhat.com> - 0.8-0.1.git20100122
|
||||
- ifcfg-rh: read and write DHCPv6 enabled connections (rh #429710)
|
||||
- nmcli: update
|
||||
|
@ -72,28 +72,26 @@ diff -up NetworkManager-0.7.999/network-manager-applet-0.7.999/src/gnome-bluetoo
|
||||
--- NetworkManager-0.7.999/network-manager-applet-0.7.999/src/gnome-bluetooth/Makefile.am.buildfix 2009-07-28 13:23:40.282718683 -0400
|
||||
+++ NetworkManager-0.7.999/network-manager-applet-0.7.999/src/gnome-bluetooth/Makefile.am 2009-07-28 13:24:56.316719077 -0400
|
||||
@@ -6,6 +6,9 @@ INCLUDES = \
|
||||
-DLOCALEDIR="\"$(datadir)/locale\"" \
|
||||
-I$(top_srcdir)/src/gconf-helpers/ \
|
||||
-I$(top_builddir) \
|
||||
-I${top_builddir}/src/marshallers \
|
||||
-I${top_srcdir}/src/utils \
|
||||
+ -I${top_srcdir}/../include \
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
+ -I${top_srcdir}/../libnm-glib \
|
||||
$(GNOME_BLUETOOTH_CFLAGS) \
|
||||
$(WARN_CFLAGS)
|
||||
|
||||
@@ -14,7 +17,11 @@ plugin_LTLIBRARIES = libnma.la
|
||||
@@ -14,7 +17,9 @@ plugin_LTLIBRARIES = libnma.la
|
||||
|
||||
libnma_la_SOURCES = network-manager-applet.c
|
||||
libnma_la_LDFLAGS = -module -avoid-version
|
||||
-libnma_la_LIBADD = $(top_builddir)/src/gconf-helpers/libgconf-helpers.la $(GNOME_BLUETOOTH_LIBS)
|
||||
+libnma_la_LIBADD = \
|
||||
+ $(top_builddir)/src/gconf-helpers/libgconf-helpers.la \
|
||||
libnma_la_LIBADD = \
|
||||
$(top_builddir)/src/gconf-helpers/libgconf-helpers.la \
|
||||
- $(GNOME_BLUETOOTH_LIBS)
|
||||
+ $(GNOME_BLUETOOTH_LIBS) \
|
||||
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm-glib.la
|
||||
endif
|
||||
|
||||
EXTRA_DIST = network-manager-applet.c
|
||||
EXTRA_DIST = \
|
||||
diff -up NetworkManager-0.7.999/network-manager-applet-0.7.999/src/Makefile.am.buildfix NetworkManager-0.7.999/network-manager-applet-0.7.999/src/Makefile.am
|
||||
--- NetworkManager-0.7.999/network-manager-applet-0.7.999/src/Makefile.am.buildfix 2009-07-27 15:26:53.000000000 -0400
|
||||
+++ NetworkManager-0.7.999/network-manager-applet-0.7.999/src/Makefile.am 2009-07-28 11:29:11.686841642 -0400
|
||||
|
@ -5,12 +5,12 @@ diff -up NetworkManager-0.7.999/nmcli/src/CMakeLists.txt.foo NetworkManager-0.7.
|
||||
FIND_PACKAGE (PkgConfig REQUIRED)
|
||||
PKG_CHECK_MODULES (GLIB2 REQUIRED glib-2.0>=2.18 )
|
||||
PKG_CHECK_MODULES (DBUS_GLIB REQUIRED dbus-glib-1>=0.76)
|
||||
-PKG_CHECK_MODULES (NETWORK_MANAGER REQUIRED NetworkManager>=0.7)
|
||||
-PKG_CHECK_MODULES (LIBNM REQUIRED libnm-glib>=0.7)
|
||||
-PKG_CHECK_MODULES (LIBNM REQUIRED libnm-utils>=0.7)
|
||||
+#PKG_CHECK_MODULES (NETWORK_MANAGER REQUIRED NetworkManager>=0.7)
|
||||
+#PKG_CHECK_MODULES (LIBNM REQUIRED libnm-glib>=0.7)
|
||||
+#PKG_CHECK_MODULES (LIBNM REQUIRED libnm-utils>=0.7)
|
||||
-PKG_CHECK_MODULES (NETWORK_MANAGER REQUIRED NetworkManager>=0.7.998)
|
||||
-PKG_CHECK_MODULES (LIBNM REQUIRED libnm-glib>=0.7.998)
|
||||
-PKG_CHECK_MODULES (LIBNM REQUIRED libnm-utils>=0.7.998)
|
||||
+#PKG_CHECK_MODULES (NETWORK_MANAGER REQUIRED NetworkManager>=0.7.998)
|
||||
+#PKG_CHECK_MODULES (LIBNM REQUIRED libnm-glib>=0.7.998)
|
||||
+#PKG_CHECK_MODULES (LIBNM REQUIRED libnm-utils>=0.7.998)
|
||||
|
||||
INCLUDE_DIRECTORIES (${GLIB2_INCLUDE_DIRS})
|
||||
INCLUDE_DIRECTORIES (${DBUS_GLIB_INCLUDE_DIRS})
|
||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
||||
3269a3e71f546c4fec3d9029c12a6102 network-manager-applet-0.7.999.git20100120.tar.bz2
|
||||
9d2517416102480d29d92753bd52b299 NetworkManager-0.7.999.git20100122.tar.bz2
|
||||
9393afeae87158a4dcad6fbab7dbb343 NetworkManager-0.7.999.git20100129.tar.bz2
|
||||
f710c8a1f7f0f1bd7452f8f3138c41b7 network-manager-applet-0.7.999.git20100129.tar.bz2
|
||||
76eda6ab0acd9f4b32a793cf04697a3d nmcli-git20100122.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user