- Rework connection editor connection list
This commit is contained in:
parent
12e1ae9fbe
commit
d02fe96e33
@ -69,3 +69,5 @@ NetworkManager-0.7.0.svn3235.tar.gz
|
||||
nm-applet-0.7.0.svn438.tar.gz
|
||||
NetworkManager-0.7.0.svn3261.tar.gz
|
||||
nm-applet-0.7.0.svn468.tar.gz
|
||||
NetworkManager-0.7.0.svn3319.tar.gz
|
||||
nm-applet-0.7.0.svn526.tar.gz
|
||||
|
@ -174,15 +174,4 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.
|
||||
|
||||
if WITH_NOTIFY
|
||||
nm_applet_LDADD += $(NOTIFY_LIBS)
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/applet-dialogs.c.fix NetworkManager-0.7.0/nm-applet-0.7.0/src/applet-dialogs.c
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/applet-dialogs.c.fix 2008-02-07 18:23:50.000000000 -0500
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/applet-dialogs.c 2008-02-07 18:23:56.000000000 -0500
|
||||
@@ -259,7 +259,7 @@ applet_info_dialog_show (NMApplet *apple
|
||||
{
|
||||
GtkWidget *dialog;
|
||||
NMDevice *device;
|
||||
- NMConnection *connection;
|
||||
+ NMConnection *connection = NULL;
|
||||
|
||||
device = applet_get_first_active_device (applet);
|
||||
if (device)
|
||||
|
||||
|
@ -8,8 +8,8 @@ ExcludeArch: s390 s390x
|
||||
%define wireless_tools_version 1:28-0pre9
|
||||
%define libnl_version 1.0-0.15.pre8.git20071218
|
||||
|
||||
%define snapshot svn3302
|
||||
%define applet_snapshot svn516
|
||||
%define snapshot svn3319
|
||||
%define applet_snapshot svn526
|
||||
|
||||
Name: NetworkManager
|
||||
Summary: Network connection manager and user applications
|
||||
@ -278,6 +278,13 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 14 2008 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.8.svn3319
|
||||
- Rework connection editor connection list
|
||||
|
||||
* Tue Feb 12 2008 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.8.svn3312
|
||||
- Better handling of changes in the profile directory by the system settings
|
||||
serivce
|
||||
|
||||
* Thu Feb 7 2008 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.8.svn3302
|
||||
- Enable system settings service
|
||||
- Allow explicit disconnection of mobile broadband devices
|
||||
|
@ -1,15 +1,48 @@
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/nm-connection-list.c.foo NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/nm-connection-list.c
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/nm-connection-list.c.foo 2008-02-07 16:04:38.000000000 -0500
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/nm-connection-list.c 2008-02-07 16:05:11.000000000 -0500
|
||||
@@ -331,9 +331,11 @@ nm_connection_list_init (NMConnectionLis
|
||||
/* buttons */
|
||||
list->add_button = glade_xml_get_widget (list->gui, "add_connection_button");
|
||||
g_signal_connect (G_OBJECT (list->add_button), "clicked", G_CALLBACK (add_connection_cb), list);
|
||||
+ gtk_widget_set_sensitive (list->add_button, FALSE);
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/nm-connection-list.c.disable-stuff NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/nm-connection-list.c
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/nm-connection-list.c.disable-stuff 2008-02-14 12:23:13.000000000 -0500
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/nm-connection-list.c 2008-02-14 14:47:23.000000000 -0500
|
||||
@@ -218,6 +218,8 @@ list_selection_changed_cb (GtkTreeSelect
|
||||
GtkTreeIter iter;
|
||||
GtkTreeModel *model;
|
||||
|
||||
list->edit_button = glade_xml_get_widget (list->gui, "edit_connection_button");
|
||||
g_signal_connect (G_OBJECT (list->edit_button), "clicked", G_CALLBACK (edit_connection_cb), list);
|
||||
+ gtk_widget_set_sensitive (list->edit_button, FALSE);
|
||||
+return;
|
||||
+
|
||||
if (gtk_tree_selection_get_selected (selection, &model, &iter))
|
||||
gtk_widget_set_sensitive (GTK_WIDGET (button), TRUE);
|
||||
else
|
||||
@@ -413,9 +415,11 @@ new_connection_list (NMConnectionList *l
|
||||
COL_TIMESTAMP, GTK_SORT_DESCENDING);
|
||||
gtk_tree_view_set_model (GTK_TREE_VIEW (clist), GTK_TREE_MODEL (sort_model));
|
||||
|
||||
list->delete_button = glade_xml_get_widget (list->gui, "delete_connection_button");
|
||||
g_signal_connect (G_OBJECT (list->delete_button), "clicked", G_CALLBACK (delete_connection_cb), list);
|
||||
+if (0) {
|
||||
g_signal_connect (G_OBJECT (clist),
|
||||
"row-activated", G_CALLBACK (connection_double_clicked_cb),
|
||||
NULL);
|
||||
+}
|
||||
|
||||
gtk_tree_view_insert_column_with_attributes (GTK_TREE_VIEW (clist),
|
||||
-1, "Name", gtk_cell_renderer_text_new (),
|
||||
@@ -440,6 +444,7 @@ new_connection_list (NMConnectionList *l
|
||||
g_object_set_data (G_OBJECT (button), "nm-connection-list", list);
|
||||
g_signal_connect (G_OBJECT (button), "clicked", G_CALLBACK (add_connection_cb), clist);
|
||||
g_free (name);
|
||||
+ gtk_widget_set_sensitive (button, FALSE);
|
||||
|
||||
name = g_strdup_printf ("%s_edit", prefix);
|
||||
button = glade_xml_get_widget (list->gui, name);
|
||||
@@ -449,6 +454,7 @@ new_connection_list (NMConnectionList *l
|
||||
"changed", G_CALLBACK (list_selection_changed_cb),
|
||||
button);
|
||||
g_free (name);
|
||||
+ gtk_widget_set_sensitive (button, FALSE);
|
||||
|
||||
name = g_strdup_printf ("%s_delete", prefix);
|
||||
button = glade_xml_get_widget (list->gui, name);
|
||||
@@ -458,6 +464,7 @@ new_connection_list (NMConnectionList *l
|
||||
"changed", G_CALLBACK (list_selection_changed_cb),
|
||||
button);
|
||||
g_free (name);
|
||||
+ gtk_widget_set_sensitive (button, FALSE);
|
||||
|
||||
return clist;
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user