- Update to SVN snapshot of 0.7
This commit is contained in:
parent
339c2fc7d2
commit
a03c871792
@ -1,2 +1,4 @@
|
|||||||
network-manager-applet-0.6.5.tar.bz2
|
network-manager-applet-0.6.5.tar.bz2
|
||||||
NetworkManager-0.6.5.tar.bz2
|
NetworkManager-0.6.5.tar.bz2
|
||||||
|
NetworkManager-0.7.0.svn2736.tar.gz
|
||||||
|
nm-applet-0.7.0.svn129.tar.gz
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
--- NetworkManager-0.6.2/initscript/RedHat/NetworkManager.in.dhcdbd 2006-03-30 12:42:28.000000000 -0500
|
|
||||||
+++ NetworkManager-0.6.2/initscript/RedHat/NetworkManager.in 2006-03-30 12:43:25.000000000 -0500
|
|
||||||
@@ -36,6 +36,11 @@
|
|
||||||
{
|
|
||||||
echo $"Setting network parameters... "
|
|
||||||
sysctl -e -p /etc/sysctl.conf >/dev/null 2>&1
|
|
||||||
+
|
|
||||||
+ if [ ! -e /var/lock/subsys/dhcdbd ]; then
|
|
||||||
+ service dhcdbd start
|
|
||||||
+ fi
|
|
||||||
+
|
|
||||||
echo -n $"Starting NetworkManager daemon: "
|
|
||||||
daemon --check $servicename $processname --pid-file=$pidfile
|
|
||||||
RETVAL=$?
|
|
@ -1,35 +1,6 @@
|
|||||||
--- NetworkManager-0.6.5/nm-applet-0.6.5/src/Makefile.am.buildfix 2007-02-02 10:53:26.000000000 -0500
|
--- NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix 2007-08-30 15:04:50.000000000 -0400
|
||||||
+++ NetworkManager-0.6.5/nm-applet-0.6.5/src/Makefile.am 2007-03-15 14:20:32.000000000 -0400
|
+++ NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac 2007-08-30 15:19:48.000000000 -0400
|
||||||
@@ -2,6 +2,9 @@
|
@@ -18,10 +18,10 @@ dnl
|
||||||
|
|
||||||
bin_PROGRAMS = nm-applet
|
|
||||||
|
|
||||||
+INCLUDES = -I${top_srcdir}/../include \
|
|
||||||
+ -I${top_srcdir}/../libnm-util
|
|
||||||
+
|
|
||||||
nm_applet_CPPFLAGS = \
|
|
||||||
$(DBUS_CFLAGS) \
|
|
||||||
$(GTHREAD_CFLAGS) \
|
|
||||||
@@ -12,7 +15,6 @@
|
|
||||||
$(GCONF_CFLAGS) \
|
|
||||||
$(LIBGNOMEUI_CFLAGS) \
|
|
||||||
$(GNOME_KEYRING_CFLAGS) \
|
|
||||||
- $(NM_CFLAGS) \
|
|
||||||
-DICONDIR=\""$(datadir)/icons"\" \
|
|
||||||
-DGLADEDIR=\""$(gladedir)"\" \
|
|
||||||
-DBINDIR=\""$(bindir)"\" \
|
|
||||||
@@ -112,7 +114,7 @@
|
|
||||||
$(GCONF_LIBS) \
|
|
||||||
$(LIBGNOMEUI_LIBS) \
|
|
||||||
$(GNOME_KEYRING_LIBS) \
|
|
||||||
- $(NM_LIBS) \
|
|
||||||
+ -L${top_srcdir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
|
||||||
$(NULL)
|
|
||||||
|
|
||||||
if WITH_NOTIFY
|
|
||||||
--- NetworkManager-0.6.5/nm-applet-0.6.5/configure.ac.buildfix 2007-03-15 11:51:49.000000000 -0400
|
|
||||||
+++ NetworkManager-0.6.5/nm-applet-0.6.5/configure.ac 2007-03-15 16:33:34.000000000 -0400
|
|
||||||
@@ -18,10 +18,10 @@
|
|
||||||
dnl This doesn't depend on gnome support, only on gnome-common, autogen already
|
dnl This doesn't depend on gnome support, only on gnome-common, autogen already
|
||||||
dnl uses gnome-autogen
|
dnl uses gnome-autogen
|
||||||
dnl
|
dnl
|
||||||
@ -44,14 +15,35 @@
|
|||||||
|
|
||||||
dnl
|
dnl
|
||||||
dnl Required headers
|
dnl Required headers
|
||||||
@@ -112,10 +112,6 @@
|
@@ -62,7 +62,6 @@ AC_CHECK_LIB(nm-util, ieee_802_11_cipher
|
||||||
AC_SUBST(GOBJECT_CFLAGS)
|
PKG_CHECK_MODULES(NMA,
|
||||||
AC_SUBST(GOBJECT_LIBS)
|
[dbus-glib-1 >= 0.72
|
||||||
|
glib-2.0 >= 2.10
|
||||||
|
- NetworkManager >= 0.7.0
|
||||||
|
libnm_glib
|
||||||
|
gtk+-2.0 >= 2.6
|
||||||
|
libglade-2.0
|
||||||
|
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix 2007-08-30 15:02:27.000000000 -0400
|
||||||
|
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am 2007-08-30 15:24:08.000000000 -0400
|
||||||
|
@@ -4,6 +4,10 @@ NULL=
|
||||||
|
|
||||||
-PKG_CHECK_MODULES(NM, NetworkManager)
|
bin_PROGRAMS = nm-applet
|
||||||
-AC_SUBST(NM_CFLAGS)
|
|
||||||
-AC_SUBST(NM_LIBS)
|
|
||||||
-
|
|
||||||
AC_ARG_WITH(notify, AC_HELP_STRING([--with-notify], [Use libnotify]), enable_notify=$withval, enable_notify=auto)
|
|
||||||
|
|
||||||
PKG_CHECK_MODULES(GTK, gtk+-2.0)
|
+INCLUDES = -I${top_srcdir}/../include \
|
||||||
|
+ -I${top_srcdir}/../libnm-util \
|
||||||
|
+ -I${top_srcdir}/../libnm-glib
|
||||||
|
+
|
||||||
|
nm_applet_CPPFLAGS = \
|
||||||
|
$(NMA_CFLAGS) \
|
||||||
|
-DICONDIR=\""$(datadir)/icons"\" \
|
||||||
|
@@ -89,7 +93,9 @@ if WITH_NOTIFY
|
||||||
|
nm_applet_SOURCES += applet-notifications.c applet-notifications.h
|
||||||
|
endif
|
||||||
|
|
||||||
|
-nm_applet_LDADD = $(NMA_LIBS)
|
||||||
|
+nm_applet_LDADD = $(NMA_LIBS) \
|
||||||
|
+ -L${top_srcdir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||||
|
+ -L${top_srcdir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la
|
||||||
|
|
||||||
|
if WITH_NOTIFY
|
||||||
|
nm_applet_LDADD += $(NOTIFY_LIBS)
|
||||||
|
@ -1,15 +0,0 @@
|
|||||||
Index: NetworkManager-0.6.5/src/NetworkManager.c
|
|
||||||
===================================================================
|
|
||||||
--- NetworkManager-0.6.5/src/NetworkManager.c (revision 2617)
|
|
||||||
+++ NetworkManager-0.6.5/src/NetworkManager.c (working copy)
|
|
||||||
@@ -825,6 +825,10 @@
|
|
||||||
nm_add_initial_killswitch_devices (data);
|
|
||||||
nm_add_initial_devices (data);
|
|
||||||
}
|
|
||||||
+
|
|
||||||
+ /* If there weren't any killswitches, mark hardware RF to on */
|
|
||||||
+ if (g_slist_length (data->killswitch_list) == 0)
|
|
||||||
+ data->hw_rf_enabled = TRUE;
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
@ -1,26 +1,25 @@
|
|||||||
ExcludeArch: s390 s390x
|
ExcludeArch: s390 s390x
|
||||||
|
|
||||||
%define dbus_version 0.90
|
%define dbus_version 1.0.2
|
||||||
%define dbus_glib_version 0.70
|
%define dbus_glib_version 0.73
|
||||||
%define hal_version 0.5.0
|
%define hal_version 0.5.0
|
||||||
|
|
||||||
%define gtk2_version 2.6.0
|
%define gtk2_version 2.10.0
|
||||||
%define wireless_tools_version 1:28-0pre9
|
%define wireless_tools_version 1:28-0pre9
|
||||||
|
|
||||||
|
%define snapshot svn2736
|
||||||
|
|
||||||
Name: NetworkManager
|
Name: NetworkManager
|
||||||
Summary: Network connection manager and user applications
|
Summary: Network connection manager and user applications
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 0.6.5
|
Version: 0.7.0
|
||||||
Release: 9%{?dist}
|
Release: 0.1.%{snapshot}%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.gnome.org/projects/NetworkManager/
|
URL: http://www.gnome.org/projects/NetworkManager/
|
||||||
Source: %{name}-%{version}.tar.bz2
|
Source: %{name}-%{version}.%{snapshot}.tar.gz
|
||||||
Source1: nm-applet-%{version}.tar.bz2
|
Source1: nm-applet-%{version}.svn129.tar.gz
|
||||||
Patch0: NetworkManager-0.6.4-startup-dhcdbd.patch
|
|
||||||
Patch1: NetworkManager-0.6.5-fixup-internal-applet-build.patch
|
Patch1: NetworkManager-0.6.5-fixup-internal-applet-build.patch
|
||||||
Patch2: linkdebug.patch
|
|
||||||
Patch3: NetworkManager-0.6.5-no-killswitch-fix.patch
|
|
||||||
Patch4: NetworkManager-0.6.5-deprecated.patch
|
Patch4: NetworkManager-0.6.5-deprecated.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -28,11 +27,10 @@ PreReq: chkconfig
|
|||||||
Requires: wireless-tools >= %{wireless_tools_version}
|
Requires: wireless-tools >= %{wireless_tools_version}
|
||||||
Requires: dbus >= %{dbus_version}
|
Requires: dbus >= %{dbus_version}
|
||||||
Requires: dbus-glib >= %{dbus_glib_version}
|
Requires: dbus-glib >= %{dbus_glib_version}
|
||||||
Requires: hal >= 0.5.0
|
Requires: hal >= %{hal_version}
|
||||||
Requires: iproute openssl
|
Requires: iproute openssl
|
||||||
Requires: dhcdbd
|
|
||||||
Requires: dhclient >= 3.0.2-12
|
Requires: dhclient >= 3.0.2-12
|
||||||
Requires: wpa_supplicant
|
Requires: wpa_supplicant >= 0.5.7-7
|
||||||
|
|
||||||
BuildRequires: dbus-devel >= %{dbus_version}
|
BuildRequires: dbus-devel >= %{dbus_version}
|
||||||
BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
|
BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
|
||||||
@ -119,13 +117,10 @@ NetworkManager functionality from applications that use glib.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .startup-dhcdbd
|
#%patch4 -p1 -b .deprecated
|
||||||
%patch2 -p1 -b .linkdebug
|
|
||||||
%patch3 -p1 -b .no-killswitch-fix
|
|
||||||
%patch4 -p1 -b .deprecated
|
|
||||||
|
|
||||||
# unpack the applet
|
# unpack the applet
|
||||||
tar -xjf %{SOURCE1}
|
tar -xzf %{SOURCE1}
|
||||||
%patch1 -p1 -b .buildfix
|
%patch1 -p1 -b .buildfix
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -139,7 +134,7 @@ tar -xjf %{SOURCE1}
|
|||||||
make
|
make
|
||||||
|
|
||||||
# build the applet
|
# build the applet
|
||||||
pushd nm-applet-0.6.5
|
pushd nm-applet-0.7.0
|
||||||
autoreconf -i
|
autoreconf -i
|
||||||
intltoolize --force
|
intltoolize --force
|
||||||
%configure \
|
%configure \
|
||||||
@ -158,7 +153,7 @@ popd
|
|||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
|
||||||
# install the applet
|
# install the applet
|
||||||
pushd nm-applet-0.6.5
|
pushd nm-applet-0.7.0
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
popd
|
popd
|
||||||
|
|
||||||
@ -208,7 +203,8 @@ fi
|
|||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root,0755)
|
%defattr(-,root,root,0755)
|
||||||
%doc COPYING ChangeLog NEWS AUTHORS README CONTRIBUTING TODO
|
%doc COPYING ChangeLog NEWS AUTHORS README CONTRIBUTING TODO
|
||||||
%config %{_sysconfdir}/dbus-1/system.d/NetworkManager.conf
|
%{_sysconfdir}/dbus-1/system.d/NetworkManager.conf
|
||||||
|
%{_sysconfdir}/dbus-1/system.d/nm-dhcp-client.conf
|
||||||
%config %{_sysconfdir}/rc.d/init.d/NetworkManager
|
%config %{_sysconfdir}/rc.d/init.d/NetworkManager
|
||||||
%config %{_sysconfdir}/rc.d/init.d/NetworkManagerDispatcher
|
%config %{_sysconfdir}/rc.d/init.d/NetworkManagerDispatcher
|
||||||
%{_sbindir}/%{name}
|
%{_sbindir}/%{name}
|
||||||
@ -217,10 +213,11 @@ fi
|
|||||||
%dir %{_sysconfdir}/NetworkManager/dispatcher.d
|
%dir %{_sysconfdir}/NetworkManager/dispatcher.d
|
||||||
%dir %{_sysconfdir}/NetworkManager/VPN
|
%dir %{_sysconfdir}/NetworkManager/VPN
|
||||||
%{_bindir}/nm-tool
|
%{_bindir}/nm-tool
|
||||||
|
%{_libexecdir}/nm-dhcp-client.action
|
||||||
%{_libdir}/libnm-util.so*
|
%{_libdir}/libnm-util.so*
|
||||||
%{_mandir}/man1/NetworkManager.1.gz
|
%{_libdir}/nm-pppd-plugin.so
|
||||||
%{_mandir}/man1/NetworkManagerDispatcher.1.gz
|
%{_mandir}/man1/*
|
||||||
%{_mandir}/man1/nm-tool.1.gz
|
%{_mandir}/man8/*
|
||||||
%dir %{_localstatedir}/run/NetworkManager
|
%dir %{_localstatedir}/run/NetworkManager
|
||||||
%{_prefix}/libexec/nm-crash-logger
|
%{_prefix}/libexec/nm-crash-logger
|
||||||
%dir %{_datadir}/NetworkManager
|
%dir %{_datadir}/NetworkManager
|
||||||
@ -250,12 +247,15 @@ fi
|
|||||||
%{_libdir}/libnm_glib.so.*
|
%{_libdir}/libnm_glib.so.*
|
||||||
|
|
||||||
%files glib-devel
|
%files glib-devel
|
||||||
%{_includedir}/%{name}/libnm_glib.h
|
%{_includedir}/libnm-glib/*.h
|
||||||
%{_libdir}/pkgconfig/libnm_glib.pc
|
%{_libdir}/pkgconfig/libnm_glib.pc
|
||||||
%{_libdir}/libnm_glib.so
|
%{_libdir}/libnm_glib.so
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 30 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.1.svn2736
|
||||||
|
- Update to SVN snapshot of 0.7
|
||||||
|
|
||||||
* Mon Aug 13 2007 Christopher Aillon <caillon@redhat.com> 1:0.6.5-9
|
* Mon Aug 13 2007 Christopher Aillon <caillon@redhat.com> 1:0.6.5-9
|
||||||
- Update the license tag
|
- Update the license tag
|
||||||
|
|
||||||
|
@ -1,53 +0,0 @@
|
|||||||
--- NetworkManager-0.6.5/src/nm-netlink-monitor.c.linkdebug 2007-06-10 13:07:22.000000000 -0400
|
|
||||||
+++ NetworkManager-0.6.5/src/nm-netlink-monitor.c 2007-06-10 13:12:07.000000000 -0400
|
|
||||||
@@ -721,6 +721,7 @@
|
|
||||||
|
|
||||||
if ((dev = nm_get_device_by_iface_locked (monitor->priv->app_data, iface)))
|
|
||||||
{
|
|
||||||
+nm_info ("%s - %s (%d) netlink reports device %s link now %d", __FILE__, __func__, __LINE__, iface, is_connected);
|
|
||||||
if (is_connected) {
|
|
||||||
g_signal_emit (G_OBJECT (monitor),
|
|
||||||
nm_netlink_monitor_signals[INTERFACE_CONNECTED],
|
|
||||||
--- NetworkManager-0.6.5/src/nm-device.c.linkdebug 2007-06-10 13:07:29.000000000 -0400
|
|
||||||
+++ NetworkManager-0.6.5/src/nm-device.c 2007-06-10 13:12:34.000000000 -0400
|
|
||||||
@@ -593,6 +593,7 @@
|
|
||||||
return;
|
|
||||||
|
|
||||||
self->priv->link_active = link_active;
|
|
||||||
+nm_info ("%s - %s (%d) device %s link state set to %d", __FILE__, __func__, __LINE__, nm_device_get_iface (self), self->priv->link_active);
|
|
||||||
|
|
||||||
/* Deactivate a currently active device */
|
|
||||||
if (!link_active && req)
|
|
||||||
--- NetworkManager-0.6.5/src/nm-device-802-3-ethernet.c.linkdebug 2007-06-10 13:07:37.000000000 -0400
|
|
||||||
+++ NetworkManager-0.6.5/src/nm-device-802-3-ethernet.c 2007-06-10 13:11:29.000000000 -0400
|
|
||||||
@@ -99,6 +99,7 @@
|
|
||||||
static gboolean
|
|
||||||
link_activated_helper (NMDevice8023Ethernet *self)
|
|
||||||
{
|
|
||||||
+nm_info ("%s - %s (%d) device %s will set active link to TRUE", __FILE__, __func__, __LINE__, nm_device_get_iface (NM_DEVICE (self)));
|
|
||||||
nm_device_set_active_link (NM_DEVICE (self), TRUE);
|
|
||||||
return FALSE;
|
|
||||||
}
|
|
||||||
@@ -118,12 +119,14 @@
|
|
||||||
g_source_set_callback (source, (GSourceFunc) link_activated_helper, self, NULL);
|
|
||||||
g_source_attach (source, nm_device_get_main_context (NM_DEVICE (self)));
|
|
||||||
g_source_unref (source);
|
|
||||||
+nm_info ("%s - %s (%d) device %s scheduled link_activated_helper", __FILE__, __func__, __LINE__, nm_device_get_iface (NM_DEVICE (self)));
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
||||||
static gboolean
|
|
||||||
link_deactivated_helper (NMDevice8023Ethernet *self)
|
|
||||||
{
|
|
||||||
+nm_info ("%s - %s (%d) device %s will set active link to FALSE", __FILE__, __func__, __LINE__, nm_device_get_iface (NM_DEVICE (self)));
|
|
||||||
nm_device_set_active_link (NM_DEVICE (self), FALSE);
|
|
||||||
return FALSE;
|
|
||||||
}
|
|
||||||
@@ -143,6 +146,7 @@
|
|
||||||
g_source_set_callback (source, (GSourceFunc) link_deactivated_helper, self, NULL);
|
|
||||||
g_source_attach (source, nm_device_get_main_context (NM_DEVICE (self)));
|
|
||||||
g_source_unref (source);
|
|
||||||
+nm_info ("%s - %s (%d) device %s scheduled link_deactivated_helper", __FILE__, __func__, __LINE__, nm_device_get_iface (NM_DEVICE (self)));
|
|
||||||
}
|
|
||||||
|
|
||||||
static void
|
|
Loading…
Reference in New Issue
Block a user