Update to latest from F-8 branch
This commit is contained in:
parent
6e15902460
commit
798fed64c7
@ -1,6 +1,6 @@
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix 2007-10-13 20:48:35.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac 2007-10-16 13:14:57.000000000 -0400
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix 2007-11-13 09:53:39.000000000 -0500
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac 2007-11-13 15:14:13.000000000 -0500
|
||||
@@ -18,10 +18,10 @@ dnl
|
||||
dnl This doesn't depend on gnome support, only on gnome-common, autogen already
|
||||
dnl uses gnome-autogen
|
||||
@ -16,18 +16,19 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix NetworkManag
|
||||
|
||||
dnl
|
||||
dnl Required headers
|
||||
@@ -60,8 +60,6 @@ AC_C_BIGENDIAN
|
||||
@@ -60,9 +60,6 @@ AC_C_BIGENDIAN
|
||||
PKG_CHECK_MODULES(NMA,
|
||||
[dbus-glib-1 >= 0.72
|
||||
glib-2.0 >= 2.10
|
||||
- NetworkManager >= 0.7.0
|
||||
- libnm_glib
|
||||
- libnm-util
|
||||
gtk+-2.0 >= 2.6
|
||||
libglade-2.0
|
||||
gconf-2.0
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am.buildfix 2007-09-22 22:54:27.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am 2007-10-16 13:14:57.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am 2007-11-13 15:14:13.000000000 -0500
|
||||
@@ -1,6 +1,10 @@
|
||||
|
||||
bin_PROGRAMS = nm-vpn-properties
|
||||
@ -51,16 +52,17 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am.bui
|
||||
CLEANFILES = $(server_DATA) *.bak *.gladep *~
|
||||
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am.buildfix 2007-09-19 22:53:14.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am 2007-10-16 13:14:57.000000000 -0400
|
||||
@@ -1,8 +1,15 @@
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am.buildfix 2007-10-27 18:23:56.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am 2007-11-13 15:14:13.000000000 -0500
|
||||
@@ -1,3 +1,7 @@
|
||||
+INCLUDES = -I${top_srcdir}/../include \
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
+ -I${top_srcdir}/../libnm-glib
|
||||
+
|
||||
noinst_LTLIBRARIES = libgconf-helpers.la
|
||||
|
||||
libgconf_helpers_la_SOURCES = gconf-helpers.h gconf-helpers.c
|
||||
libgconf_helpers_la_SOURCES = \
|
||||
@@ -8,5 +12,8 @@ libgconf_helpers_la_SOURCES = \
|
||||
|
||||
libgconf_helpers_la_CPPFLAGS = $(NMA_CFLAGS)
|
||||
|
||||
@ -70,9 +72,40 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am.buil
|
||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la
|
||||
+
|
||||
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/utils/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/utils/Makefile.am
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/utils/Makefile.am.buildfix 2007-11-13 15:41:01.000000000 -0500
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/utils/Makefile.am 2007-11-13 15:42:30.000000000 -0500
|
||||
@@ -1,3 +1,7 @@
|
||||
+INCLUDES = -I${top_srcdir}/../include \
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
+ -I${top_srcdir}/../libnm-glib
|
||||
+
|
||||
noinst_LTLIBRARIES = libutils.la
|
||||
|
||||
libutils_la_SOURCES = \
|
||||
@@ -10,7 +14,9 @@ libutils_la_SOURCES = \
|
||||
|
||||
libutils_la_CPPFLAGS = $(NMA_CFLAGS)
|
||||
|
||||
-libutils_la_LIBADD = $(NMA_LIBS)
|
||||
+libutils_la_LIBADD = $(NMA_LIBS) \
|
||||
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la
|
||||
|
||||
if WITH_GNUTLS
|
||||
libutils_la_SOURCES += crypto_gnutls.c
|
||||
@@ -28,4 +34,7 @@ noinst_PROGRAMS = test-crypto
|
||||
|
||||
test_crypto_SOURCES = test-crypto.c
|
||||
test_crypto_CPPFLAGS = $(NMA_CFLAGS) -D_GNU_SOURCE
|
||||
-test_crypto_LDADD = $(NMA_LIBS) ${top_builddir}/src/utils/libutils.la
|
||||
+test_crypto_LDADD = $(NMA_LIBS) ${top_builddir}/src/utils/libutils.la \
|
||||
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la
|
||||
+
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/wireless-security/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/wireless-security/Makefile.am
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/wireless-security/Makefile.am.buildfix 2007-10-16 13:25:35.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/wireless-security/Makefile.am 2007-10-16 13:26:07.000000000 -0400
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/wireless-security/Makefile.am.buildfix 2007-11-07 12:12:16.000000000 -0500
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/wireless-security/Makefile.am 2007-11-13 15:14:13.000000000 -0500
|
||||
@@ -1,5 +1,9 @@
|
||||
noinst_LTLIBRARIES = libwireless-security.la
|
||||
|
||||
@ -83,7 +116,7 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/wireless-security/Makefile.am.
|
||||
libwireless_security_la_SOURCES = \
|
||||
wireless-security.h \
|
||||
wireless-security.c \
|
||||
@@ -28,5 +32,7 @@ libwireless_security_la_CPPFLAGS = \
|
||||
@@ -35,5 +39,7 @@ libwireless_security_la_CPPFLAGS = \
|
||||
|
||||
libwireless_security_la_LIBADD = \
|
||||
$(NMA_LIBS) \
|
||||
@ -94,7 +127,7 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/wireless-security/Makefile.am.
|
||||
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.buildfix 2007-09-20 07:40:37.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am 2007-10-16 13:14:57.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am 2007-11-13 15:14:13.000000000 -0500
|
||||
@@ -2,6 +2,10 @@ NULL=
|
||||
|
||||
bin_PROGRAMS = nm-connection-editor
|
||||
@ -118,8 +151,8 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.
|
||||
gladedir = $(datadir)/nm-applet
|
||||
glade_DATA = nm-connection-editor.glade
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix 2007-10-13 22:01:15.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am 2007-10-16 13:14:57.000000000 -0400
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix 2007-10-27 18:11:31.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am 2007-11-13 15:14:13.000000000 -0500
|
||||
@@ -4,6 +4,10 @@ NULL=
|
||||
|
||||
bin_PROGRAMS = nm-applet
|
||||
@ -131,7 +164,7 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix NetworkMa
|
||||
nm_applet_CPPFLAGS = \
|
||||
$(NMA_CFLAGS) \
|
||||
-DICONDIR=\""$(datadir)/icons"\" \
|
||||
@@ -60,7 +64,9 @@ nm_applet_LDADD = \
|
||||
@@ -58,7 +62,9 @@ nm_applet_LDADD = \
|
||||
$(NMA_LIBS) \
|
||||
${top_builddir}/src/utils/libutils.la \
|
||||
${top_builddir}/src/gconf-helpers/libgconf-helpers.la \
|
||||
|
@ -7,21 +7,20 @@ ExcludeArch: s390 s390x
|
||||
%define gtk2_version 2.10.0
|
||||
%define wireless_tools_version 1:28-0pre9
|
||||
|
||||
%define snapshot svn3030
|
||||
%define snapshot svn3096
|
||||
|
||||
Name: NetworkManager
|
||||
Summary: Network connection manager and user applications
|
||||
Epoch: 1
|
||||
Version: 0.7.0
|
||||
Release: 0.7.%{snapshot}%{?dist}
|
||||
Release: 0.6.3.%{snapshot}%{?dist}
|
||||
Group: System Environment/Base
|
||||
License: GPLv2+
|
||||
URL: http://www.gnome.org/projects/NetworkManager/
|
||||
Source: %{name}-%{version}.%{snapshot}.tar.gz
|
||||
Source1: nm-applet-%{version}.svn302.tar.gz
|
||||
Source1: nm-applet-%{version}.svn360.tar.gz
|
||||
Patch1: NetworkManager-0.6.5-fixup-internal-applet-build.patch
|
||||
Patch2: nm-applet-0.7.0-disable-stuff.patch
|
||||
Patch3: nm-applet-0.7.0-applet-usb-vendor-fix.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
PreReq: chkconfig
|
||||
@ -31,7 +30,7 @@ Requires: dbus-glib >= %{dbus_glib_version}
|
||||
Requires: hal >= %{hal_version}
|
||||
Requires: iproute openssl
|
||||
Requires: dhclient >= 3.0.2-12
|
||||
Requires: wpa_supplicant >= 0.5.7-13
|
||||
Requires: wpa_supplicant >= 0.5.7-16
|
||||
Requires: %{name}-glib = %{epoch}:%{version}-%{release}
|
||||
Obsoletes: dhcdbd
|
||||
|
||||
@ -55,6 +54,7 @@ BuildRequires: perl(XML::Parser)
|
||||
BuildRequires: automake autoconf intltool libtool
|
||||
BuildRequires: ppp >= 2.4.4
|
||||
BuildRequires: gnome-common
|
||||
BuildRequires: nss-devel >= 3.11.7
|
||||
|
||||
%description
|
||||
NetworkManager attempts to keep an active network connection available at all
|
||||
@ -77,6 +77,7 @@ Requires: hal >= %{hal_version}
|
||||
Requires: libnotify >= 0.3
|
||||
PreReq: gtk2 >= %{gtk2_version}
|
||||
Requires: gnome-keyring
|
||||
Requires: nss >= 3.11.7
|
||||
|
||||
%description gnome
|
||||
This package contains GNOME utilities and applications for use with
|
||||
@ -127,7 +128,6 @@ NetworkManager functionality from applications that use glib.
|
||||
tar -xzf %{SOURCE1}
|
||||
%patch1 -p1 -b .buildfix
|
||||
%patch2 -p1 -b .disable-stuff
|
||||
%patch3 -p1 -b .applet-usb-vendor-fix
|
||||
|
||||
%build
|
||||
# Even though we don't require named, we still build with it
|
||||
@ -147,9 +147,8 @@ pushd nm-applet-0.7.0
|
||||
%configure \
|
||||
--disable-static \
|
||||
--with-notify \
|
||||
--with-named=/usr/sbin/named \
|
||||
--with-named-dir=/var/named/data \
|
||||
--with-named-user=named
|
||||
--with-nss=yes \
|
||||
--with-gnutls=no
|
||||
make
|
||||
popd
|
||||
|
||||
@ -262,8 +261,20 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Nov 13 2007 Jeremy Katz <katzj@redhat.com> - 1:0.7.0-0.7.svn3030
|
||||
- sync with what was in F-8; rebuild against new dbus-glib
|
||||
* Mon Nov 19 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.6.3.svn3096
|
||||
- Fix connections when picking a WPA Enterprise AP from the menu
|
||||
- Fix issue where applet would provide multiple same connections to NM
|
||||
|
||||
* Thu Nov 15 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.6.3.svn3094
|
||||
- Add support for EAP-PEAP (rh #362251)
|
||||
- Fix EAP-TLS private key handling
|
||||
|
||||
* Tue Nov 13 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.6.2.svn3080
|
||||
- Clarify naming of WPA & WPA2 Personal encryption options (rh #374861, rh #373831)
|
||||
- Don't require a CA certificate for applicable EAP methods (rh #359001)
|
||||
- Fix certificate and private key handling for EAP-TTLS and EAP-TLS (rh #323371)
|
||||
- Fix applet crash with USB devices (rh #337191)
|
||||
- Support upgrades from NM 0.6.x GConf settings
|
||||
|
||||
* Thu Nov 1 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.6.1.svn3030
|
||||
- Fix applet crash with USB devices that don't advertise a product or vendor
|
||||
|
@ -1,20 +0,0 @@
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/applet.c.usb-vendor-fix NetworkManager-0.7.0/nm-applet-0.7.0/src/applet.c
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/applet.c.usb-vendor-fix 2007-11-01 06:49:55.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/applet.c 2007-11-01 06:50:57.000000000 -0400
|
||||
@@ -1515,6 +1515,16 @@ sort_devices (gconstpointer a, gconstpoi
|
||||
char *bb_desc = nm_device_get_description (bb);
|
||||
gint ret;
|
||||
|
||||
+ if (!aa_desc && bb_desc) {
|
||||
+ g_free (bb_desc);
|
||||
+ return -1;
|
||||
+ } else if (aa_desc && !bb_desc) {
|
||||
+ g_free (aa_desc);
|
||||
+ return 1;
|
||||
+ } else if (!aa_desc && !bb_desc) {
|
||||
+ return 0;
|
||||
+ }
|
||||
+
|
||||
ret = strcmp (aa_desc, bb_desc);
|
||||
|
||||
g_free (aa_desc);
|
Loading…
Reference in New Issue
Block a user