Update to 0.8.2
This commit is contained in:
parent
8945c4bc19
commit
73253af956
2
.gitignore
vendored
2
.gitignore
vendored
@ -216,3 +216,5 @@ NetworkManager-0.8.1.tar.bz2
|
||||
network-manager-applet-0.8.1.tar.bz2
|
||||
/NetworkManager-0.8.2.tar.bz2
|
||||
/network-manager-applet-0.8.2.tar.bz2
|
||||
/NetworkManager-0.8.2.git20101117.tar.bz2
|
||||
/network-manager-applet-0.8.2.git20101117.tar.bz2
|
||||
|
@ -1,14 +1,14 @@
|
||||
%define dbus_version 1.1
|
||||
%define dbus_glib_version 0.86-4
|
||||
|
||||
%define gtk2_version 2.14.0
|
||||
%define gtk2_version 2.18.0
|
||||
%define glib2_version 2.16.0
|
||||
%define wireless_tools_version 1:28-0pre9
|
||||
%define libnl_version 1.1
|
||||
%define ppp_version 2.4.5
|
||||
|
||||
%define snapshot %{nil}
|
||||
%define applet_snapshot %{nil}
|
||||
%define snapshot .git20101117
|
||||
%define applet_snapshot .git20101117
|
||||
%define realversion 0.8.2
|
||||
|
||||
%define use_systemd 0
|
||||
@ -32,7 +32,12 @@ Patch1: nm-applet-internal-buildfixes.patch
|
||||
Patch2: explain-dns1-dns2.patch
|
||||
Patch3: nm-applet-no-notifications.patch
|
||||
Patch10: Port-to-libnotify-070.patch
|
||||
Patch11: gtk-build.patch
|
||||
Patch11: gtk3-1.patch
|
||||
Patch12: gtk3-2.patch
|
||||
Patch13: gtk3-3.patch
|
||||
Patch14: gtk3-4.patch
|
||||
Patch15: gtk3-5.patch
|
||||
Patch16: gtk3-6.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Requires(post): chkconfig
|
||||
@ -165,8 +170,13 @@ tar -xjf %{SOURCE1}
|
||||
%patch3 -p1 -b .no-notifications
|
||||
pushd network-manager-applet-%{realversion}
|
||||
%patch10 -p1 -b .libnotify-070
|
||||
%patch11 -p1 -b .gtk3-1
|
||||
%patch12 -p1 -b .gtk3-2
|
||||
%patch13 -p1 -b .gtk3-3
|
||||
%patch14 -p1 -b .gtk3-4
|
||||
%patch15 -p1 -b .gtk3-5
|
||||
%patch16 -p1 -b .gtk3-6
|
||||
popd
|
||||
%patch11 -p1 -b .gtk-build
|
||||
|
||||
%build
|
||||
|
||||
@ -196,6 +206,7 @@ pushd network-manager-applet-%{realversion}
|
||||
intltoolize --force
|
||||
%configure \
|
||||
--disable-static \
|
||||
--with-gtk2=yes \
|
||||
--with-bluetooth \
|
||||
--enable-more-warnings=yes
|
||||
make %{?_smp_mflags}
|
||||
@ -425,7 +436,7 @@ fi
|
||||
%{_datadir}/gtk-doc/html/libnm-util/*
|
||||
|
||||
%changelog
|
||||
* Wed Nov 3 2010 Dan Williams <dcbw@redhat.com> - 0.8.2-1
|
||||
* Wed Nov 27 2010 Dan Williams <dcbw@redhat.com> - 0.8.2-1.git20101117
|
||||
- Update to 0.8.2
|
||||
|
||||
* Wed Nov 3 2010 Matthias Clasen <mclasen@redhat.com> - 0.8.1-10.1
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- NetworkManager-0.8.2/network-manager-applet-0.8.2/src/applet.c 2010-11-02 21:28:16.850180001 -0400
|
||||
+++ NetworkManager-0.8.2.hacked/network-manager-applet-0.8.2/src/applet.c 2010-11-02 20:58:40.797180001 -0400
|
||||
@@ -2736,7 +2736,7 @@
|
||||
return *icon;
|
||||
}
|
||||
|
||||
-#define FALLBACK_ICON_NAME "gtk-dialog-error"
|
||||
+#define FALLBACK_ICON_NAME "dialog-error"
|
||||
|
||||
static gboolean
|
||||
nma_icons_reload (NMApplet *applet)
|
11
gtk3-1.patch
Normal file
11
gtk3-1.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/src/applet.c 2010-11-02 21:28:16.850180001 -0400
|
||||
+++ b/src/applet.c 2010-11-02 20:58:40.797180001 -0400
|
||||
@@ -2736,7 +2736,7 @@
|
||||
return *icon;
|
||||
}
|
||||
|
||||
-#define FALLBACK_ICON_NAME "gtk-dialog-error"
|
||||
+#define FALLBACK_ICON_NAME "dialog-error"
|
||||
|
||||
static gboolean
|
||||
nma_icons_reload (NMApplet *applet)
|
34
gtk3-2.patch
Normal file
34
gtk3-2.patch
Normal file
@ -0,0 +1,34 @@
|
||||
commit f53171cc0f0e38c16a6d7b0f50ed2e545b9ec1df
|
||||
Author: Dan Williams <dcbw@redhat.com>
|
||||
Date: Fri Nov 5 14:58:51 2010 -0500
|
||||
|
||||
trivial: fix for GTK 3.0 (bgo #632328)
|
||||
|
||||
diff --git a/src/applet.c b/src/applet.c
|
||||
index 90f606c..7e13e2a 100644
|
||||
--- a/src/applet.c
|
||||
+++ b/src/applet.c
|
||||
@@ -2936,7 +2936,11 @@ applet_pre_keyring_callback (gpointer user_data)
|
||||
if (applet->menu)
|
||||
window = gtk_widget_get_window (applet->menu);
|
||||
if (window) {
|
||||
+#if GTK_CHECK_VERSION(2,23,0)
|
||||
+ screen = gdk_window_get_screen (window);
|
||||
+#else
|
||||
screen = gdk_drawable_get_screen (window);
|
||||
+#endif
|
||||
display = gdk_screen_get_display (screen);
|
||||
g_object_ref (display);
|
||||
|
||||
@@ -2957,7 +2961,11 @@ applet_pre_keyring_callback (gpointer user_data)
|
||||
if (applet->context_menu)
|
||||
window = gtk_widget_get_window (applet->context_menu);
|
||||
if (window) {
|
||||
+#if GTK_CHECK_VERSION(2,23,0)
|
||||
+ screen = gdk_window_get_screen (window);
|
||||
+#else
|
||||
screen = gdk_drawable_get_screen (window);
|
||||
+#endif
|
||||
display = gdk_screen_get_display (screen);
|
||||
g_object_ref (display);
|
||||
|
155
gtk3-3.patch
Normal file
155
gtk3-3.patch
Normal file
@ -0,0 +1,155 @@
|
||||
commit d48d0db2e22c6ca31f5cb709e063db8b99401b25
|
||||
Author: Dan Williams <dcbw@redhat.com>
|
||||
Date: Fri Nov 5 15:12:42 2010 -0500
|
||||
|
||||
core: clean up about dialog (bgo #632328)
|
||||
|
||||
First, GTK 3.0 removed gdk_spawn_command_line_on_screen().
|
||||
|
||||
Second, everyone listed in the Credits gets monthly emails from
|
||||
users with random questions; these should go to the list instead.
|
||||
So remove credits entirely and mention contributions in the
|
||||
copyright message.
|
||||
|
||||
diff --git a/src/applet-dialogs.c b/src/applet-dialogs.c
|
||||
index 58ad88b..046f378 100644
|
||||
--- a/src/applet-dialogs.c
|
||||
+++ b/src/applet-dialogs.c
|
||||
@@ -568,123 +568,46 @@ applet_info_dialog_show (NMApplet *applet)
|
||||
gdk_x11_get_server_time (gtk_widget_get_window (dialog)));
|
||||
}
|
||||
|
||||
+#if !GTK_CHECK_VERSION(2,23,0)
|
||||
static void
|
||||
about_dialog_handle_url_cb (GtkAboutDialog *about, const gchar *url, gpointer data)
|
||||
{
|
||||
- GError *error = NULL;
|
||||
gboolean ret;
|
||||
char *cmdline;
|
||||
- GdkScreen *gscreen;
|
||||
- GtkWidget *error_dialog;
|
||||
+ GdkScreen *screen;
|
||||
|
||||
- gscreen = gtk_window_get_screen (GTK_WINDOW (about));
|
||||
+ screen = gtk_window_get_screen (GTK_WINDOW (about));
|
||||
|
||||
cmdline = g_strconcat ("gnome-open ", url, NULL);
|
||||
- ret = gdk_spawn_command_line_on_screen (gscreen, cmdline, &error);
|
||||
+ ret = gdk_spawn_command_line_on_screen (screen, cmdline, NULL);
|
||||
g_free (cmdline);
|
||||
|
||||
- if (ret == TRUE)
|
||||
- return;
|
||||
-
|
||||
- g_error_free (error);
|
||||
- error = NULL;
|
||||
-
|
||||
- cmdline = g_strconcat ("xdg-open ", url, NULL);
|
||||
- ret = gdk_spawn_command_line_on_screen (gscreen, cmdline, &error);
|
||||
- g_free (cmdline);
|
||||
-
|
||||
- if (ret == FALSE) {
|
||||
- error_dialog = gtk_message_dialog_new ( NULL, GTK_DIALOG_MODAL, GTK_MESSAGE_INFO, GTK_BUTTONS_OK, "Failed to show url %s", error->message);
|
||||
- gtk_dialog_run (GTK_DIALOG (error_dialog));
|
||||
- g_error_free (error);
|
||||
- }
|
||||
-
|
||||
-}
|
||||
-
|
||||
-/* Make email in about dialog clickable */
|
||||
-static void
|
||||
-about_dialog_handle_email_cb (GtkAboutDialog *about, const char *email_address, gpointer data)
|
||||
-{
|
||||
- GError *error = NULL;
|
||||
- gboolean ret;
|
||||
- char *cmdline;
|
||||
- GdkScreen *gscreen;
|
||||
- GtkWidget *error_dialog;
|
||||
-
|
||||
- gscreen = gtk_window_get_screen (GTK_WINDOW (about));
|
||||
-
|
||||
- cmdline = g_strconcat ("gnome-open mailto:", email_address, NULL);
|
||||
- ret = gdk_spawn_command_line_on_screen (gscreen, cmdline, &error);
|
||||
- g_free (cmdline);
|
||||
-
|
||||
- if (ret == TRUE)
|
||||
- return;
|
||||
-
|
||||
- g_error_free (error);
|
||||
- error = NULL;
|
||||
-
|
||||
- cmdline = g_strconcat ("xdg-open mailto:", email_address, NULL);
|
||||
- ret = gdk_spawn_command_line_on_screen (gscreen, cmdline, &error);
|
||||
- g_free (cmdline);
|
||||
-
|
||||
if (ret == FALSE) {
|
||||
- error_dialog = gtk_message_dialog_new ( NULL, GTK_DIALOG_MODAL, GTK_MESSAGE_INFO, GTK_BUTTONS_OK, "Failed to show url %s", error->message);
|
||||
- gtk_dialog_run (GTK_DIALOG (error_dialog));
|
||||
- g_error_free (error);
|
||||
+ cmdline = g_strconcat ("xdg-open ", url, NULL);
|
||||
+ ret = gdk_spawn_command_line_on_screen (screen, cmdline, NULL);
|
||||
+ g_free (cmdline);
|
||||
}
|
||||
}
|
||||
+#endif
|
||||
|
||||
void
|
||||
applet_about_dialog_show (NMApplet *applet)
|
||||
{
|
||||
- static const gchar *authors[] = {
|
||||
- "The Red Hat Desktop Team, including:\n",
|
||||
- "Christopher Aillon <caillon@redhat.com>",
|
||||
- "Jonathan Blandford <jrb@redhat.com>",
|
||||
- "John Palmieri <johnp@redhat.com>",
|
||||
- "Ray Strode <rstrode@redhat.com>",
|
||||
- "Colin Walters <walters@redhat.com>",
|
||||
- "Dan Williams <dcbw@redhat.com>",
|
||||
- "David Zeuthen <davidz@redhat.com>",
|
||||
- "\nAnd others, including:\n",
|
||||
- "Bill Moss <bmoss@clemson.edu>",
|
||||
- "Tom Parker",
|
||||
- "j@bootlab.org",
|
||||
- "Peter Jones <pjones@redhat.com>",
|
||||
- "Robert Love <rml@novell.com>",
|
||||
- "Tim Niemueller (http://www.niemueller.de)",
|
||||
- NULL
|
||||
- };
|
||||
-
|
||||
- static const gchar *artists[] = {
|
||||
- "Diana Fong <dfong@redhat.com>",
|
||||
- NULL
|
||||
- };
|
||||
-
|
||||
-
|
||||
- /* FIXME: unnecessary with libgnomeui >= 2.16.0 */
|
||||
- static gboolean been_here = FALSE;
|
||||
- if (!been_here) {
|
||||
- been_here = TRUE;
|
||||
- gtk_about_dialog_set_url_hook (about_dialog_handle_url_cb, NULL, NULL);
|
||||
- gtk_about_dialog_set_email_hook (about_dialog_handle_email_cb, NULL, NULL);
|
||||
- }
|
||||
-
|
||||
+#if !GTK_CHECK_VERSION(2,23,0)
|
||||
+ gtk_about_dialog_set_url_hook (about_dialog_handle_url_cb, NULL, NULL);
|
||||
+#endif
|
||||
gtk_show_about_dialog (NULL,
|
||||
"version", VERSION,
|
||||
- "copyright", _("Copyright \xc2\xa9 2004-2008 Red Hat, Inc.\n"
|
||||
- "Copyright \xc2\xa9 2005-2008 Novell, Inc."),
|
||||
+ "copyright", _("Copyright \xc2\xa9 2004-2010 Red Hat, Inc.\n"
|
||||
+ "Copyright \xc2\xa9 2005-2008 Novell, Inc.\n"
|
||||
+ "and many other community contributors and translators"),
|
||||
"comments", _("Notification area applet for managing your network devices and connections."),
|
||||
"website", "http://www.gnome.org/projects/NetworkManager/",
|
||||
"website-label", _("NetworkManager Website"),
|
||||
- "authors", authors,
|
||||
- "artists", artists,
|
||||
- "translator-credits", _("translator-credits"),
|
||||
"logo-icon-name", GTK_STOCK_NETWORK,
|
||||
NULL);
|
||||
}
|
||||
|
||||
-
|
||||
GtkWidget *
|
||||
applet_warning_dialog_show (const char *message)
|
||||
{
|
34
gtk3-4.patch
Normal file
34
gtk3-4.patch
Normal file
@ -0,0 +1,34 @@
|
||||
commit 06c7c14a5e3c6eaf9975c97e15f56bf7ca5f5c75
|
||||
Author: Dan Williams <dcbw@redhat.com>
|
||||
Date: Sat Nov 6 13:31:13 2010 -0500
|
||||
|
||||
mobile: more gtk3 fixes (bgo #632652)
|
||||
|
||||
diff --git a/src/utils/mobile-wizard.c b/src/utils/mobile-wizard.c
|
||||
index 8445132..d562fc5 100644
|
||||
--- a/src/utils/mobile-wizard.c
|
||||
+++ b/src/utils/mobile-wizard.c
|
||||
@@ -747,11 +747,23 @@ providers_setup (MobileWizard *self)
|
||||
gtk_table_attach (GTK_TABLE (unlisted_table), alignment,
|
||||
1, 2, 0, 1, GTK_EXPAND | GTK_FILL, 0, 6, 6);
|
||||
|
||||
+#if GTK_CHECK_VERSION(2,23,0)
|
||||
+ self->provider_unlisted_type_combo = gtk_combo_box_text_new ();
|
||||
+#else
|
||||
self->provider_unlisted_type_combo = gtk_combo_box_new_text ();
|
||||
+#endif
|
||||
gtk_label_set_mnemonic_widget (GTK_LABEL (label), self->provider_unlisted_type_combo);
|
||||
+#if GTK_CHECK_VERSION(2,23,0)
|
||||
+ gtk_combo_box_text_append_text (GTK_COMBO_BOX_TEXT (self->provider_unlisted_type_combo),
|
||||
+#else
|
||||
gtk_combo_box_append_text (GTK_COMBO_BOX (self->provider_unlisted_type_combo),
|
||||
+#endif
|
||||
_("My provider uses GSM technology (GPRS, EDGE, UMTS, HSPA)"));
|
||||
+#if GTK_CHECK_VERSION(2,23,0)
|
||||
+ gtk_combo_box_text_append_text (GTK_COMBO_BOX_TEXT (self->provider_unlisted_type_combo),
|
||||
+#else
|
||||
gtk_combo_box_append_text (GTK_COMBO_BOX (self->provider_unlisted_type_combo),
|
||||
+#endif
|
||||
_("My provider uses CDMA technology (1xRTT, EVDO)"));
|
||||
gtk_combo_box_set_active (GTK_COMBO_BOX (self->provider_unlisted_type_combo), 0);
|
||||
|
215
gtk3-5.patch
Normal file
215
gtk3-5.patch
Normal file
@ -0,0 +1,215 @@
|
||||
commit 546ae3141a987b3efa350b1a31c0579f1fa88c73
|
||||
Author: Dan Williams <dcbw@redhat.com>
|
||||
Date: Sat Nov 6 14:25:56 2010 -0500
|
||||
|
||||
core: more fixes for GTK3
|
||||
|
||||
It'll actually build now. GTK3 is the default, pass:
|
||||
|
||||
--with-gtk2=yes
|
||||
|
||||
to still use GTK2.
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f8d6819..cbfa4cf 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -73,13 +73,24 @@ PKG_CHECK_MODULES(NMA,
|
||||
PKG_CHECK_MODULES(NMA,
|
||||
[dbus-glib-1 >= 0.74
|
||||
glib-2.0 >= 2.16
|
||||
- gtk+-2.0 >= 2.14
|
||||
libglade-2.0
|
||||
gmodule-export-2.0
|
||||
gconf-2.0
|
||||
gnome-keyring-1
|
||||
libnotify >= 0.7.0])
|
||||
|
||||
+AC_ARG_WITH([gtk2], AS_HELP_STRING([--with-gtk2], [Use GTK+ 2.x instead of GTK+ 3.x]),
|
||||
+ with_gtk2="$withval",with_gtk2=no)
|
||||
+gtkver=3
|
||||
+case "${with_gtk2}" in
|
||||
+ yes) PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.18)
|
||||
+ gtkver=2
|
||||
+ ;;
|
||||
+ *) PKG_CHECK_MODULES(GTK, gtk+-3.0 >= 2.90)
|
||||
+ ;;
|
||||
+esac
|
||||
+AM_CONDITIONAL(USE_GTK2, test x"$gtkver" = "x2")
|
||||
+
|
||||
# Check for dbus-1.2.6 or later for deny-by-default rules
|
||||
PKG_CHECK_MODULES(DBUS_126, [dbus-1 >= 1.2.6], [have_dbus_126=yes],[have_dbus_126=no])
|
||||
AM_CONDITIONAL(HAVE_DBUS_126, test x"$have_dbus_126" = "xyes")
|
||||
@@ -156,3 +167,6 @@ icons/scalable/Makefile
|
||||
po/Makefile.in
|
||||
])
|
||||
AC_OUTPUT
|
||||
+
|
||||
+echo Building for GTK+ version: ${gtkver}
|
||||
+
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index ec786d8..2da5ee2 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -3,6 +3,7 @@ SUBDIRS = marshallers utils gconf-helpers wireless-security connection-editor gn
|
||||
-I${top_srcdir}/../libnm-glib
|
||||
|
||||
nm_applet_CPPFLAGS = \
|
||||
+ $(GTK_CFLAGS) \
|
||||
$(NMA_CFLAGS) \
|
||||
$(NOTIFY_CFLAGS) \
|
||||
-DICONDIR=\""$(datadir)/icons"\" \
|
||||
@@ -53,6 +54,7 @@ nm_applet_SOURCES = \
|
||||
|
||||
nm_applet_LDADD = \
|
||||
-lm \
|
||||
+ $(GTK_LIBS) \
|
||||
$(NMA_LIBS) \
|
||||
$(NOTIFY_LIBS) \
|
||||
${top_builddir}/src/marshallers/libmarshallers.la \
|
||||
diff --git a/src/applet-dialogs.c b/src/applet-dialogs.c
|
||||
index 046f378..132cec2 100644
|
||||
--- a/src/applet-dialogs.c
|
||||
+++ b/src/applet-dialogs.c
|
||||
@@ -1031,13 +1031,21 @@ applet_mobile_pin_dialog_start_spinner (GtkWidget *dialog, const char *text)
|
||||
xml = g_object_get_data (G_OBJECT (dialog), "xml");
|
||||
g_return_if_fail (xml != NULL);
|
||||
|
||||
+#if GTK_CHECK_VERSION(2,90,0)
|
||||
+ spinner = gtk_spinner_new ();
|
||||
+#else
|
||||
spinner = nma_bling_spinner_new ();
|
||||
+#endif
|
||||
g_return_if_fail (spinner != NULL);
|
||||
g_object_set_data (G_OBJECT (dialog), "spinner", spinner);
|
||||
|
||||
align = glade_xml_get_widget (xml, "spinner_alignment");
|
||||
gtk_container_add (GTK_CONTAINER (align), spinner);
|
||||
+#if GTK_CHECK_VERSION(2,90,0)
|
||||
+ gtk_spinner_start (GTK_SPINNER (spinner));
|
||||
+#else
|
||||
nma_bling_spinner_start (NMA_BLING_SPINNER (spinner));
|
||||
+#endif
|
||||
|
||||
widget = glade_xml_get_widget (xml, "progress_label");
|
||||
gtk_label_set_text (GTK_LABEL (widget), text);
|
||||
@@ -1075,7 +1083,11 @@ applet_mobile_pin_dialog_stop_spinner (GtkWidget *dialog, const char *text)
|
||||
|
||||
spinner = g_object_get_data (G_OBJECT (dialog), "spinner");
|
||||
g_return_if_fail (spinner != NULL);
|
||||
+#if GTK_CHECK_VERSION(2,90,0)
|
||||
+ gtk_spinner_stop (GTK_SPINNER (spinner));
|
||||
+#else
|
||||
nma_bling_spinner_stop (NMA_BLING_SPINNER (spinner));
|
||||
+#endif
|
||||
g_object_set_data (G_OBJECT (dialog), "spinner", NULL);
|
||||
|
||||
/* Remove it from the alignment */
|
||||
diff --git a/src/connection-editor/Makefile.am b/src/connection-editor/Makefile.am
|
||||
index 326c642..a4d04a7 100644
|
||||
--- a/src/connection-editor/Makefile.am
|
||||
+++ b/src/connection-editor/Makefile.am
|
||||
@@ -1,6 +1,7 @@
|
||||
-I${top_srcdir}/../libnm-glib
|
||||
|
||||
nm_connection_editor_CPPFLAGS = \
|
||||
+ $(GTK_CFLAGS) \
|
||||
$(NMA_CFLAGS) \
|
||||
-DICONDIR=\""$(datadir)/icons"\" \
|
||||
-DGLADEDIR=\""$(gladedir)"\" \
|
||||
@@ -63,6 +64,7 @@ nm_connection_editor_LDADD = \
|
||||
${top_builddir}/src/wireless-security/libwireless-security.la \
|
||||
${top_builddir}/src/utils/libutils.la \
|
||||
${top_builddir}/src/marshallers/libmarshallers.la \
|
||||
+ $(GTK_LIBS) \
|
||||
$(NMA_LIBS) \
|
||||
-lm \
|
||||
-L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
diff --git a/src/gconf-helpers/Makefile.am b/src/gconf-helpers/Makefile.am
|
||||
index 873fc90..3ec3489 100644
|
||||
--- a/src/gconf-helpers/Makefile.am
|
||||
+++ b/src/gconf-helpers/Makefile.am
|
||||
@@ -11,6 +11,7 @@ libgconf_helpers_la_SOURCES = \
|
||||
nma-gconf-settings.c
|
||||
|
||||
libgconf_helpers_la_CPPFLAGS = \
|
||||
+ $(GTK_CFLAGS) \
|
||||
$(NMA_CFLAGS) \
|
||||
$(DISABLE_DEPRECATED) \
|
||||
-I${top_srcdir}/src \
|
||||
@@ -18,6 +19,7 @@ libgconf_helpers_la_CPPFLAGS = \
|
||||
-I${top_srcdir}/src/utils
|
||||
|
||||
libgconf_helpers_la_LIBADD = \
|
||||
+ $(GTK_LIBS) \
|
||||
$(NMA_LIBS) \
|
||||
${top_builddir}/src/marshallers/libmarshallers.la \
|
||||
${top_builddir}/src/utils/libutils.la \
|
||||
diff --git a/src/utils/Makefile.am b/src/utils/Makefile.am
|
||||
index 0794db5..d9a9c8e 100644
|
||||
--- a/src/utils/Makefile.am
|
||||
+++ b/src/utils/Makefile.am
|
||||
@@ -8,11 +8,16 @@ libutils_la_SOURCES = \
|
||||
nmn-mobile-providers.h \
|
||||
nmn-mobile-providers.c \
|
||||
mobile-wizard.h \
|
||||
- mobile-wizard.c \
|
||||
+ mobile-wizard.c
|
||||
+
|
||||
+if USE_GTK2
|
||||
+libutils_la_SOURCES += \
|
||||
nma-bling-spinner.h \
|
||||
nma-bling-spinner.c
|
||||
+endif
|
||||
|
||||
libutils_la_CPPFLAGS = \
|
||||
+ $(GTK_CFLAGS) \
|
||||
$(NMA_CFLAGS) \
|
||||
-DGLADEDIR=\""$(gladedir)"\" \
|
||||
-DDATADIR=\""$(datadir)"\" \
|
||||
@@ -20,7 +25,7 @@ libutils_la_CPPFLAGS = \
|
||||
-I${top_srcdir}/src/gconf-helpers \
|
||||
-I${top_srcdir}/src
|
||||
|
||||
-libutils_la_LIBADD = $(NMA_LIBS) \
|
||||
+libutils_la_LIBADD = $(GTK_LIBS) $(NMA_LIBS) \
|
||||
-L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
-L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm-glib.la
|
||||
|
||||
diff --git a/src/utils/tests/Makefile.am b/src/utils/tests/Makefile.am
|
||||
index 72169d6..213829f 100644
|
||||
--- a/src/utils/tests/Makefile.am
|
||||
+++ b/src/utils/tests/Makefile.am
|
||||
@@ -4,10 +4,11 @@ noinst_PROGRAMS = test-utils
|
||||
|
||||
test_utils_SOURCES = test-utils.c
|
||||
|
||||
-test_utils_CPPFLAGS = $(NMA_CFLAGS)
|
||||
+test_utils_CPPFLAGS = $(GTK_CFLAGS) $(NMA_CFLAGS)
|
||||
|
||||
test_utils_LDADD = \
|
||||
${top_builddir}/src/utils/libutils.la \
|
||||
+ $(GTK_LIBS) \
|
||||
$(NMA_LIBS)
|
||||
|
||||
check-local: test-utils
|
||||
diff --git a/src/wireless-security/Makefile.am b/src/wireless-security/Makefile.am
|
||||
index 3f4088f..986d60d 100644
|
||||
--- a/src/wireless-security/Makefile.am
|
||||
+++ b/src/wireless-security/Makefile.am
|
||||
@@ -29,12 +29,14 @@ libwireless_security_la_SOURCES = \
|
||||
helpers.c
|
||||
|
||||
libwireless_security_la_CPPFLAGS = \
|
||||
+ $(GTK_CFLAGS) \
|
||||
$(NMA_CFLAGS) \
|
||||
$(DISABLE_DEPRECATED) \
|
||||
-I${top_srcdir}/src/utils \
|
||||
-I${top_srcdir}/src/gconf-helpers
|
||||
|
||||
libwireless_security_la_LIBADD = \
|
||||
+ $(GTK_LIBS) \
|
||||
$(NMA_LIBS) \
|
||||
${top_builddir}/src/utils/libutils.la \
|
||||
${top_builddir}/src/gconf-helpers/libgconf-helpers.la \
|
||||
|
12
gtk3-6.patch
Normal file
12
gtk3-6.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up a/src/applet.c.gtk3-6 b/src/applet.c
|
||||
--- a/src/applet.c.gtk3-6 2010-11-17 18:57:59.150709005 -0600
|
||||
+++ b/src/applet.c 2010-11-17 18:58:03.384709001 -0600
|
||||
@@ -515,7 +515,7 @@ menu_title_item_expose (GtkWidget *widge
|
||||
#else
|
||||
allocation = widget->allocation;
|
||||
#endif
|
||||
- cairo_translate (cr, widget->allocation.x, widget->allocation.y);
|
||||
+ cairo_translate (cr, allocation.x, allocation.y);
|
||||
|
||||
text = gtk_label_get_text (GTK_LABEL (label));
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
dc9e73fcf67d3897af878ef2ba5c7aff NetworkManager-0.8.2.tar.bz2
|
||||
021de95fc1e943346ceea28fbaddf45f network-manager-applet-0.8.2.tar.bz2
|
||||
b31e441cdae725192cb98924d91c989e NetworkManager-0.8.2.git20101117.tar.bz2
|
||||
021de95fc1e943346ceea28fbaddf45f network-manager-applet-0.8.2.git20101117.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user