build against libnotify 0.7.0
This commit is contained in:
parent
86ef1e5f8f
commit
58750a040f
@ -20,7 +20,7 @@ Name: NetworkManager
|
|||||||
Summary: Network connection manager and user applications
|
Summary: Network connection manager and user applications
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 0.8.1
|
Version: 0.8.1
|
||||||
Release: 10%{snapshot}%{?dist}
|
Release: 10.1%{snapshot}%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.gnome.org/projects/NetworkManager/
|
URL: http://www.gnome.org/projects/NetworkManager/
|
||||||
@ -37,6 +37,9 @@ Patch6: nm-prevent-hostname-dup.patch
|
|||||||
Patch7: nm-sleep-wake-no-auth.patch
|
Patch7: nm-sleep-wake-no-auth.patch
|
||||||
Patch8: nm-libnm-glib-prop-set-delay.patch
|
Patch8: nm-libnm-glib-prop-set-delay.patch
|
||||||
Patch9: nm-preserve-wifi-state.patch
|
Patch9: nm-preserve-wifi-state.patch
|
||||||
|
Patch10: Port-to-libnotify-070.patch
|
||||||
|
Patch11: pkauth.patch
|
||||||
|
Patch12: gtk-build.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Requires(post): chkconfig
|
Requires(post): chkconfig
|
||||||
@ -122,7 +125,7 @@ Requires: %{name} = %{epoch}:%{version}-%{release}
|
|||||||
Requires: %{name}-glib = %{epoch}:%{version}-%{release}
|
Requires: %{name}-glib = %{epoch}:%{version}-%{release}
|
||||||
Requires: dbus >= %{dbus_version}
|
Requires: dbus >= %{dbus_version}
|
||||||
Requires: dbus-glib >= %{dbus_glib_version}
|
Requires: dbus-glib >= %{dbus_glib_version}
|
||||||
Requires: libnotify >= 0.4.3
|
Requires: libnotify >= 0.7.0
|
||||||
Requires: gnome-keyring
|
Requires: gnome-keyring
|
||||||
Requires: nss >= 3.11.7
|
Requires: nss >= 3.11.7
|
||||||
Requires: gnome-icon-theme
|
Requires: gnome-icon-theme
|
||||||
@ -173,6 +176,11 @@ tar -xjf %{SOURCE1}
|
|||||||
%patch7 -p1 -b .sleep-wake
|
%patch7 -p1 -b .sleep-wake
|
||||||
%patch8 -p1 -b .prop-set-delay
|
%patch8 -p1 -b .prop-set-delay
|
||||||
%patch9 -p1 -b .wifi-state-preserve
|
%patch9 -p1 -b .wifi-state-preserve
|
||||||
|
pushd network-manager-applet-%{realversion}
|
||||||
|
%patch10 -p1 -b .libnotify-070
|
||||||
|
popd
|
||||||
|
%patch11 -p1 -b .pkauth
|
||||||
|
%patch12 -p1 -b .gtk-build
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -431,6 +439,10 @@ fi
|
|||||||
%{_datadir}/gtk-doc/html/libnm-util/*
|
%{_datadir}/gtk-doc/html/libnm-util/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 3 2010 Matthias Clasen <mclasen@redhat.com> - 0.8.1-10.1
|
||||||
|
- Rebuild against libnotify 0.7
|
||||||
|
- misc gtk build fixes
|
||||||
|
|
||||||
* Mon Nov 1 2010 Dan Williams <dcbw@redhat.com> - 0.8.1-10
|
* Mon Nov 1 2010 Dan Williams <dcbw@redhat.com> - 0.8.1-10
|
||||||
- core: preserve WiFi Enabled state across reboot and suspend/resume
|
- core: preserve WiFi Enabled state across reboot and suspend/resume
|
||||||
|
|
||||||
|
44
Port-to-libnotify-070.patch
Normal file
44
Port-to-libnotify-070.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
From 9ac43601950dfd568cc9f64cf9a20c11af6fa627 Mon Sep 17 00:00:00 2001
|
||||||
|
From: William Jon McCann <jmccann@redhat.com>
|
||||||
|
Date: Sat, 16 Oct 2010 22:01:00 -0400
|
||||||
|
Subject: [PATCH] Port to libnotify 0.7.0
|
||||||
|
|
||||||
|
https://bugzilla.gnome.org/show_bug.cgi?id=632327
|
||||||
|
---
|
||||||
|
configure.ac | 2 +-
|
||||||
|
src/applet.c | 4 +---
|
||||||
|
2 files changed, 2 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index acb39a2..8fb0a66 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -78,7 +78,7 @@ PKG_CHECK_MODULES(NMA,
|
||||||
|
gmodule-export-2.0
|
||||||
|
gconf-2.0
|
||||||
|
gnome-keyring-1
|
||||||
|
- libnotify >= 0.4.3])
|
||||||
|
+ libnotify >= 0.7.0])
|
||||||
|
|
||||||
|
# Check for dbus-1.2.6 or later for deny-by-default rules
|
||||||
|
PKG_CHECK_MODULES(DBUS_126, [dbus-1 >= 1.2.6], [have_dbus_126=yes],[have_dbus_126=no])
|
||||||
|
diff --git a/src/applet.c b/src/applet.c
|
||||||
|
index e451f75..8164501 100644
|
||||||
|
--- a/src/applet.c
|
||||||
|
+++ b/src/applet.c
|
||||||
|
@@ -622,12 +622,10 @@ applet_do_notify (NMApplet *applet,
|
||||||
|
escaped = utils_escape_notify_message (message);
|
||||||
|
notify = notify_notification_new (summary,
|
||||||
|
escaped,
|
||||||
|
- icon ? icon : GTK_STOCK_NETWORK,
|
||||||
|
- NULL);
|
||||||
|
+ icon ? icon : GTK_STOCK_NETWORK);
|
||||||
|
g_free (escaped);
|
||||||
|
applet->notification = notify;
|
||||||
|
|
||||||
|
- notify_notification_attach_to_status_icon (notify, applet->status_icon);
|
||||||
|
notify_notification_set_urgency (notify, urgency);
|
||||||
|
notify_notification_set_timeout (notify, NOTIFY_EXPIRES_DEFAULT);
|
||||||
|
|
||||||
|
--
|
||||||
|
1.7.2.3
|
32
gtk-build.patch
Normal file
32
gtk-build.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
--- NetworkManager-0.8.1/network-manager-applet-0.8.1/src/utils/nma-bling-spinner.c 2010-06-25 21:46:38.000000000 -0400
|
||||||
|
+++ NetworkManager-0.8.1.hacked/network-manager-applet-0.8.1/src/utils/nma-bling-spinner.c 2010-11-02 21:18:06.858180000 -0400
|
||||||
|
@@ -154,7 +154,7 @@
|
||||||
|
priv->current = 0;
|
||||||
|
priv->timeout = 0;
|
||||||
|
|
||||||
|
- GTK_WIDGET_SET_FLAGS (GTK_WIDGET (spinner), GTK_NO_WINDOW);
|
||||||
|
+ gtk_widget_set_has_window (GTK_WIDGET (spinner), FALSE);
|
||||||
|
}
|
||||||
|
|
||||||
|
static gboolean
|
||||||
|
--- NetworkManager-0.8.1/network-manager-applet-0.8.1/src/wireless-dialog.c 2010-07-21 19:01:21.000000000 -0400
|
||||||
|
+++ NetworkManager-0.8.1.hacked/network-manager-applet-0.8.1/src/wireless-dialog.c 2010-11-02 21:19:46.531180001 -0400
|
||||||
|
@@ -1069,7 +1069,6 @@
|
||||||
|
gtk_container_set_border_width (GTK_CONTAINER (self), 6);
|
||||||
|
gtk_window_set_default_size (GTK_WINDOW (self), 488, -1);
|
||||||
|
gtk_window_set_resizable (GTK_WINDOW (self), FALSE);
|
||||||
|
- gtk_dialog_set_has_separator (GTK_DIALOG (self), FALSE);
|
||||||
|
|
||||||
|
priv->auth_only = auth_only;
|
||||||
|
if (auth_only)
|
||||||
|
--- NetworkManager-0.8.1/network-manager-applet-0.8.1/src/applet.c 2010-11-02 21:28:16.850180001 -0400
|
||||||
|
+++ NetworkManager-0.8.1.hacked/network-manager-applet-0.8.1/src/applet.c 2010-11-02 20:58:40.797180001 -0400
|
||||||
|
@@ -2736,7 +2736,7 @@
|
||||||
|
return *icon;
|
||||||
|
}
|
||||||
|
|
||||||
|
-#define FALLBACK_ICON_NAME "gtk-dialog-error"
|
||||||
|
+#define FALLBACK_ICON_NAME "dialog-error"
|
||||||
|
|
||||||
|
static gboolean
|
||||||
|
nma_icons_reload (NMApplet *applet)
|
22
pkauth.patch
Normal file
22
pkauth.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- NetworkManager-0.8.1/src/system-settings/nm-sysconfig-settings.c 2010-06-30 14:55:33.000000000 -0400
|
||||||
|
+++ NetworkManager-0.8.1.hacked/src/system-settings/nm-sysconfig-settings.c 2010-11-02 14:58:13.141180011 -0400
|
||||||
|
@@ -1508,7 +1508,7 @@
|
||||||
|
|
||||||
|
priv->connections = g_hash_table_new_full (g_direct_hash, g_direct_equal, g_object_unref, NULL);
|
||||||
|
|
||||||
|
- priv->authority = polkit_authority_get ();
|
||||||
|
+ priv->authority = polkit_authority_get_sync (NULL, NULL);
|
||||||
|
if (priv->authority) {
|
||||||
|
priv->auth_changed_id = g_signal_connect (priv->authority,
|
||||||
|
"changed",
|
||||||
|
--- NetworkManager-0.8.1/src/system-settings/nm-sysconfig-connection.c 2010-07-21 19:01:08.000000000 -0400
|
||||||
|
+++ NetworkManager-0.8.1.hacked/src/system-settings/nm-sysconfig-connection.c 2010-11-02 14:58:35.397180077 -0400
|
||||||
|
@@ -613,7 +613,7 @@
|
||||||
|
{
|
||||||
|
NMSysconfigConnectionPrivate *priv = NM_SYSCONFIG_CONNECTION_GET_PRIVATE (self);
|
||||||
|
|
||||||
|
- priv->authority = polkit_authority_get ();
|
||||||
|
+ priv->authority = polkit_authority_get_sync (NULL, NULL);
|
||||||
|
if (!priv->authority) {
|
||||||
|
nm_log_err (LOGD_SYS_SET, "%s: error creating PolicyKit authority");
|
||||||
|
}
|
Loading…
Reference in New Issue
Block a user