- Fix WPA/WPA2 Enterprise Phase2 connections (rh #388471)
This commit is contained in:
parent
9e37500280
commit
334212aba8
@ -57,3 +57,5 @@ nm-applet-0.7.0.svn363.tar.gz
|
|||||||
NetworkManager-0.7.0.svn3109.tar.gz
|
NetworkManager-0.7.0.svn3109.tar.gz
|
||||||
nm-applet-0.7.0.svn367.tar.gz
|
nm-applet-0.7.0.svn367.tar.gz
|
||||||
nm-applet-0.7.0.svn368.tar.gz
|
nm-applet-0.7.0.svn368.tar.gz
|
||||||
|
NetworkManager-0.7.0.svn3180.tar.gz
|
||||||
|
nm-applet-0.7.0.svn405.tar.gz
|
||||||
|
@ -139,17 +139,17 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.
|
|||||||
nm_connection_editor_CPPFLAGS = \
|
nm_connection_editor_CPPFLAGS = \
|
||||||
$(NMA_CFLAGS) \
|
$(NMA_CFLAGS) \
|
||||||
-DICONDIR=\""$(datadir)/icons"\" \
|
-DICONDIR=\""$(datadir)/icons"\" \
|
||||||
@@ -25,7 +29,9 @@ nm_connection_editor_SOURCES = \
|
@@ -24,7 +28,9 @@ nm_connection_editor_SOURCES = \
|
||||||
|
main.c
|
||||||
|
|
||||||
nm_connection_editor_LDADD = \
|
nm_connection_editor_LDADD = \
|
||||||
$(NMA_LIBS) \
|
- $(top_builddir)/src/gconf-helpers/libgconf-helpers.la \
|
||||||
- ${top_builddir}/src/gconf-helpers/libgconf-helpers.la
|
|
||||||
+ ${top_builddir}/src/gconf-helpers/libgconf-helpers.la \
|
+ ${top_builddir}/src/gconf-helpers/libgconf-helpers.la \
|
||||||
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la
|
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la \
|
||||||
|
$(NMA_LIBS)
|
||||||
|
|
||||||
gladedir = $(datadir)/nm-applet
|
gladedir = $(datadir)/nm-applet
|
||||||
glade_DATA = nm-connection-editor.glade
|
|
||||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am
|
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am
|
||||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix 2007-10-27 18:11:31.000000000 -0400
|
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix 2007-10-27 18:11:31.000000000 -0400
|
||||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am 2007-11-13 15:14:13.000000000 -0500
|
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am 2007-11-13 15:14:13.000000000 -0500
|
||||||
|
@ -7,7 +7,7 @@ ExcludeArch: s390 s390x
|
|||||||
%define gtk2_version 2.12.0
|
%define gtk2_version 2.12.0
|
||||||
%define wireless_tools_version 1:28-0pre9
|
%define wireless_tools_version 1:28-0pre9
|
||||||
|
|
||||||
%define snapshot svn3138
|
%define snapshot svn3180
|
||||||
|
|
||||||
Name: NetworkManager
|
Name: NetworkManager
|
||||||
Summary: Network connection manager and user applications
|
Summary: Network connection manager and user applications
|
||||||
@ -18,7 +18,7 @@ Group: System Environment/Base
|
|||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.gnome.org/projects/NetworkManager/
|
URL: http://www.gnome.org/projects/NetworkManager/
|
||||||
Source: %{name}-%{version}.%{snapshot}.tar.gz
|
Source: %{name}-%{version}.%{snapshot}.tar.gz
|
||||||
Source1: nm-applet-%{version}.svn383.tar.gz
|
Source1: nm-applet-%{version}.svn405.tar.gz
|
||||||
Patch1: NetworkManager-0.6.5-fixup-internal-applet-build.patch
|
Patch1: NetworkManager-0.6.5-fixup-internal-applet-build.patch
|
||||||
Patch2: nm-applet-0.7.0-disable-stuff.patch
|
Patch2: nm-applet-0.7.0-disable-stuff.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -32,6 +32,7 @@ Requires: iproute openssl
|
|||||||
Requires: dhclient >= 3.0.2-12
|
Requires: dhclient >= 3.0.2-12
|
||||||
Requires: wpa_supplicant >= 0.5.7-16
|
Requires: wpa_supplicant >= 0.5.7-16
|
||||||
Requires: %{name}-glib = %{epoch}:%{version}-%{release}
|
Requires: %{name}-glib = %{epoch}:%{version}-%{release}
|
||||||
|
Requires: libnl >= 1.0-0.13.pre8.git20071217
|
||||||
Obsoletes: dhcdbd
|
Obsoletes: dhcdbd
|
||||||
|
|
||||||
BuildRequires: dbus-devel >= %{dbus_version}
|
BuildRequires: dbus-devel >= %{dbus_version}
|
||||||
@ -170,9 +171,8 @@ popd
|
|||||||
%find_lang nm-applet
|
%find_lang nm-applet
|
||||||
cat nm-applet.lang >> %{name}.lang
|
cat nm-applet.lang >> %{name}.lang
|
||||||
|
|
||||||
%{__mv} $RPM_BUILD_ROOT%{_libdir}/NetworkManager/nm-pppd-plugin.* $RPM_BUILD_ROOT%{_libdir}/
|
|
||||||
|
|
||||||
%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||||
|
%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.4.4/*.la
|
||||||
|
|
||||||
# Remove system settings daemon for now
|
# Remove system settings daemon for now
|
||||||
%{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/nm-system-settings.conf
|
%{__rm} -f $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/nm-system-settings.conf
|
||||||
@ -228,7 +228,7 @@ fi
|
|||||||
%{_bindir}/nm-tool
|
%{_bindir}/nm-tool
|
||||||
%{_libexecdir}/nm-dhcp-client.action
|
%{_libexecdir}/nm-dhcp-client.action
|
||||||
%{_libdir}/libnm-util.so*
|
%{_libdir}/libnm-util.so*
|
||||||
%{_libdir}/nm-pppd-plugin.so
|
%{_libdir}/pppd/2.4.4/nm-pppd-plugin.so
|
||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
%{_mandir}/man8/*
|
%{_mandir}/man8/*
|
||||||
%dir %{_localstatedir}/run/NetworkManager
|
%dir %{_localstatedir}/run/NetworkManager
|
||||||
@ -269,6 +269,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 18 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.8.svn3180
|
||||||
|
- Fix WPA/WPA2 Enterprise Phase2 connections (rh #388471)
|
||||||
|
|
||||||
* Wed Dec 5 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.8.svn3138
|
* Wed Dec 5 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.8.svn3138
|
||||||
- Fix applet connection comparison which failed to send connection updated
|
- Fix applet connection comparison which failed to send connection updated
|
||||||
signals to NM in some cases
|
signals to NM in some cases
|
||||||
|
Loading…
Reference in New Issue
Block a user