- Add CDMA mobile broadband support (if supported by HAL)
- Rework applet connection and icon handling - Enable connection editor (only for deleting connections)
This commit is contained in:
parent
bb9d6e9560
commit
30562d58f1
@ -67,3 +67,5 @@ NetworkManager-0.7.0.svn3204.tar.gz
|
||||
nm-applet-0.7.0.svn429.tar.gz
|
||||
NetworkManager-0.7.0.svn3235.tar.gz
|
||||
nm-applet-0.7.0.svn438.tar.gz
|
||||
NetworkManager-0.7.0.svn3261.tar.gz
|
||||
nm-applet-0.7.0.svn468.tar.gz
|
||||
|
@ -23,9 +23,9 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix NetworkManag
|
||||
- NetworkManager >= 0.7.0
|
||||
- libnm_glib
|
||||
- libnm-util
|
||||
gtk+-2.0 >= 2.6
|
||||
gtk+-2.0 >= 2.10
|
||||
libglade-2.0
|
||||
gconf-2.0
|
||||
gmodule-export-2.0
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am.buildfix 2007-09-22 22:54:27.000000000 -0400
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am 2007-11-13 15:14:13.000000000 -0500
|
||||
@ -160,11 +160,11 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
+ -I${top_srcdir}/../libnm-glib
|
||||
+
|
||||
nm_applet_CPPFLAGS = \
|
||||
$(NMA_CFLAGS) \
|
||||
-DICONDIR=\""$(datadir)/icons"\" \
|
||||
nm_applet_CPPFLAGS = \
|
||||
$(NMA_CFLAGS) \
|
||||
-DICONDIR=\""$(datadir)/icons"\" \
|
||||
@@ -58,7 +62,9 @@ nm_applet_LDADD = \
|
||||
$(NMA_LIBS) \
|
||||
$(NOTIFY_LIBS) \
|
||||
${top_builddir}/src/utils/libutils.la \
|
||||
${top_builddir}/src/gconf-helpers/libgconf-helpers.la \
|
||||
- ${top_builddir}/src/wireless-security/libwireless-security.la
|
||||
@ -172,5 +172,6 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.
|
||||
+ -L${top_srcdir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
+ -L${top_srcdir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la
|
||||
|
||||
if WITH_NOTIFY
|
||||
nm_applet_LDADD += $(NOTIFY_LIBS)
|
||||
applet-marshal.h: Makefile.am applet-marshal.list
|
||||
$(GLIB_GENMARSHAL) --prefix=applet_marshal $(srcdir)/applet-marshal.list --header > \
|
||||
|
||||
|
@ -8,8 +8,8 @@ ExcludeArch: s390 s390x
|
||||
%define wireless_tools_version 1:28-0pre9
|
||||
%define libnl_version 1.0-0.15.pre8.git20071218
|
||||
|
||||
%define snapshot svn3235
|
||||
%define applet_snapshot svn438
|
||||
%define snapshot svn3261
|
||||
%define applet_snapshot svn468
|
||||
|
||||
Name: NetworkManager
|
||||
Summary: Network connection manager and user applications
|
||||
@ -22,7 +22,7 @@ URL: http://www.gnome.org/projects/NetworkManager/
|
||||
Source: %{name}-%{version}.%{snapshot}.tar.gz
|
||||
Source1: nm-applet-%{version}.%{applet_snapshot}.tar.gz
|
||||
Patch1: NetworkManager-0.6.5-fixup-internal-applet-build.patch
|
||||
Patch2: nm-applet-0.7.0-disable-stuff.patch
|
||||
Patch2: nm-applet-0.7.0-disable-connection-editor-changes.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
PreReq: chkconfig
|
||||
@ -130,7 +130,7 @@ NetworkManager functionality from applications that use glib.
|
||||
# unpack the applet
|
||||
tar -xzf %{SOURCE1}
|
||||
%patch1 -p1 -b .buildfix
|
||||
%patch2 -p1 -b .disable-stuff
|
||||
%patch2 -p1 -b .nochange
|
||||
|
||||
%build
|
||||
# Even though we don't require named, we still build with it
|
||||
@ -271,6 +271,11 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 21 2008 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.8.svn3261
|
||||
- Add CDMA mobile broadband support (if supported by HAL)
|
||||
- Rework applet connection and icon handling
|
||||
- Enable connection editor (only for deleting connections)
|
||||
|
||||
* Fri Jan 11 2008 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.8.svn3235
|
||||
- Fix crash when activating a mobile broadband connection
|
||||
- Better handling of non-SSID-broadcasting APs on kernels that support it
|
||||
|
24
nm-applet-0.7.0-disable-connection-editor-changes.patch
Normal file
24
nm-applet-0.7.0-disable-connection-editor-changes.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/nm-connection-list.c.nochange NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/nm-connection-list.c
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/nm-connection-list.c.nochange 2008-01-21 22:46:28.000000000 -0500
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/nm-connection-list.c 2008-01-21 22:48:00.000000000 -0500
|
||||
@@ -229,7 +229,7 @@ list_selection_changed_cb (GtkTreeSelect
|
||||
GtkTreeModel *model;
|
||||
|
||||
if (gtk_tree_selection_get_selected (selection, &model, &iter)) {
|
||||
- gtk_widget_set_sensitive (GTK_WIDGET (list->edit_button), TRUE);
|
||||
+ gtk_widget_set_sensitive (GTK_WIDGET (list->edit_button), FALSE);
|
||||
gtk_widget_set_sensitive (GTK_WIDGET (list->delete_button), TRUE);
|
||||
} else {
|
||||
gtk_widget_set_sensitive (GTK_WIDGET (list->edit_button), FALSE);
|
||||
@@ -280,9 +280,11 @@ nm_connection_list_init (NMConnectionLis
|
||||
/* buttons */
|
||||
list->add_button = glade_xml_get_widget (list->gui, "add_connection_button");
|
||||
g_signal_connect (G_OBJECT (list->add_button), "clicked", G_CALLBACK (add_connection_cb), list);
|
||||
+ gtk_widget_set_sensitive (list->add_button, FALSE);
|
||||
|
||||
list->edit_button = glade_xml_get_widget (list->gui, "edit_connection_button");
|
||||
g_signal_connect (G_OBJECT (list->edit_button), "clicked", G_CALLBACK (edit_connection_cb), list);
|
||||
+ gtk_widget_set_sensitive (list->edit_button, FALSE);
|
||||
|
||||
list->delete_button = glade_xml_get_widget (list->gui, "delete_connection_button");
|
||||
g_signal_connect (G_OBJECT (list->delete_button), "clicked", G_CALLBACK (delete_connection_cb), list);
|
@ -1,43 +0,0 @@
|
||||
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/applet.c.disable-stuff NetworkManager-0.7.0/nm-applet-0.7.0/src/applet.c
|
||||
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/applet.c.disable-stuff 2007-12-04 14:03:14.000000000 -0500
|
||||
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/applet.c 2007-12-04 14:45:32.000000000 -0500
|
||||
@@ -315,6 +315,7 @@ nma_show_info_cb (GtkMenuItem *mi, NMApp
|
||||
gtk_window_present (GTK_WINDOW (dialog));
|
||||
}
|
||||
|
||||
+#if 0
|
||||
static void
|
||||
nma_edit_connections_cb (GtkMenuItem *mi, NMApplet *applet)
|
||||
{
|
||||
@@ -325,6 +326,7 @@ nma_edit_connections_cb (GtkMenuItem *mi
|
||||
|
||||
g_object_unref (connection_list);
|
||||
}
|
||||
+#endif
|
||||
|
||||
static void about_dialog_activate_link_cb (GtkAboutDialog *about,
|
||||
const gchar *url,
|
||||
@@ -1442,6 +1444,7 @@ nma_menu_add_create_network_item (GtkWid
|
||||
label = gtk_label_new_with_mnemonic (_("Create _New Wireless Network..."));
|
||||
gtk_misc_set_alignment (GTK_MISC (label), 0.0, 0.5);
|
||||
gtk_container_add (GTK_CONTAINER (menu_item), label);
|
||||
+ gtk_widget_set_sensitive (menu_item, FALSE);
|
||||
gtk_widget_show_all (menu_item);
|
||||
gtk_menu_shell_append (GTK_MENU_SHELL (menu), menu_item);
|
||||
g_signal_connect (menu_item, "activate", G_CALLBACK (new_network_item_selected), applet);
|
||||
@@ -2060,6 +2063,7 @@ static GtkWidget *nma_context_menu_creat
|
||||
gtk_image_menu_item_set_image (GTK_IMAGE_MENU_ITEM (applet->info_menu_item), image);
|
||||
gtk_menu_shell_append (menu, applet->info_menu_item);
|
||||
|
||||
+#if 0
|
||||
/* 'Edit Connections...' item */
|
||||
applet->connections_menu_item = gtk_menu_item_new_with_mnemonic (_("Edit Connections..."));
|
||||
g_signal_connect (applet->connections_menu_item,
|
||||
@@ -2067,6 +2071,7 @@ static GtkWidget *nma_context_menu_creat
|
||||
G_CALLBACK (nma_edit_connections_cb),
|
||||
applet);
|
||||
gtk_menu_shell_append (menu, applet->connections_menu_item);
|
||||
+#endif
|
||||
|
||||
/* Separator */
|
||||
nma_menu_add_separator_item (menu);
|
Loading…
Reference in New Issue
Block a user