Update to 1.42.0 release

Related: #2134897
This commit is contained in:
Thomas Haller 2023-02-10 10:42:35 +01:00
parent 1aa10acfaf
commit 1e7c882747
No known key found for this signature in database
GPG Key ID: 29C2366E4DFC5728
7 changed files with 141 additions and 307 deletions

1
.gitignore vendored
View File

@ -426,3 +426,4 @@ network-manager-applet-0.8.1.tar.bz2
/NetworkManager-1.41.8.tar.xz
/NetworkManager-1.41.90.tar.xz
/NetworkManager-1.41.91.tar.xz
/NetworkManager-1.42.0.tar.xz

View File

@ -1,29 +0,0 @@
From e2246cb54b35604c6b203e3398fa8d5735b60567 Mon Sep 17 00:00:00 2001
From: Lubomir Rintel <lkundrak@v3.sk>
Date: Mon, 12 Sep 2022 13:17:34 +0200
Subject: [PATCH 1/3] dns-manager: style fix
(cherry picked from commit f2f806f77d96b2094a23ef1c67a9f07bd8ae6fff)
---
src/core/dns/nm-dns-manager.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/core/dns/nm-dns-manager.c b/src/core/dns/nm-dns-manager.c
index ea02d4f7c8..457b82a098 100644
--- a/src/core/dns/nm-dns-manager.c
+++ b/src/core/dns/nm-dns-manager.c
@@ -1311,9 +1311,9 @@ _collect_resolv_conf_data(NMDnsManager *self,
priv = NM_DNS_MANAGER_GET_PRIVATE(self);
- if (global_config)
+ if (global_config) {
merge_global_dns_config(&rc, global_config);
- else {
+ } else {
nm_auto_str_buf NMStrBuf tmp_strbuf = NM_STR_BUF_INIT(0, FALSE);
int first_prio = 0;
const NMDnsConfigIPData *ip_data;
--
2.39.1

View File

@ -1,35 +0,0 @@
From 164cc81569283e3c27478e39a3a8ec65e2ff34ca Mon Sep 17 00:00:00 2001
From: Lubomir Rintel <lkundrak@v3.sk>
Date: Mon, 12 Sep 2022 13:47:35 +0200
Subject: [PATCH 2/3] config-data: style fix
(cherry picked from commit 051819a78e6d2c4b4a5a158f78a50e1ff524fe9c)
---
src/core/nm-config-data.c | 11 +++++++----
1 file changed, 7 insertions(+), 4 deletions(-)
diff --git a/src/core/nm-config-data.c b/src/core/nm-config-data.c
index 61cf111894..1504b15659 100644
--- a/src/core/nm-config-data.c
+++ b/src/core/nm-config-data.c
@@ -1125,10 +1125,13 @@ load_global_dns(GKeyFile *keyfile, gboolean internal)
gboolean default_found = FALSE;
char **strv;
- group =
- internal ? NM_CONFIG_KEYFILE_GROUP_INTERN_GLOBAL_DNS : NM_CONFIG_KEYFILE_GROUP_GLOBAL_DNS;
- domain_prefix = internal ? NM_CONFIG_KEYFILE_GROUPPREFIX_INTERN_GLOBAL_DNS_DOMAIN
- : NM_CONFIG_KEYFILE_GROUPPREFIX_GLOBAL_DNS_DOMAIN;
+ if (internal) {
+ group = NM_CONFIG_KEYFILE_GROUP_INTERN_GLOBAL_DNS;
+ domain_prefix = NM_CONFIG_KEYFILE_GROUPPREFIX_INTERN_GLOBAL_DNS_DOMAIN;
+ } else {
+ group = NM_CONFIG_KEYFILE_GROUP_GLOBAL_DNS;
+ domain_prefix = NM_CONFIG_KEYFILE_GROUPPREFIX_GLOBAL_DNS_DOMAIN;
+ }
domain_prefix_len = strlen(domain_prefix);
if (!nm_config_keyfile_has_global_dns_config(keyfile, internal))
--
2.39.1

View File

@ -1,231 +0,0 @@
From 4d75c43f1a12840b940bf0a327d5664db84b9c1c Mon Sep 17 00:00:00 2001
From: Lubomir Rintel <lkundrak@v3.sk>
Date: Mon, 12 Sep 2022 13:21:51 +0200
Subject: [PATCH 3/3] dns-manager: always apply options from [global-dns]
Currently, the use of [global-dns] section for setting DNS options is
conditioned on presence of a nameserver in a [global-dns-domain-*] section.
Attempt to use the section for options alone results in an error:
[global-dns]
options=timeout:1
Or via D-Bus API:
# busctl set-property org.freedesktop.NetworkManager \
/org/freedesktop/NetworkManager org.freedesktop.NetworkManager \
GlobalDnsConfiguration 'a{sv}' 2 \
"options" as 1 "timeout:1" \
"domains" a{sv} 0
...
Nov 24 13:15:21 zmok.local NetworkManager[501184]: <debug> [1669292121.3904]
manager: set global DNS failed with error: Global
DNS configuration is missing the default domain
The insistence on existence of [global-dns-domain-*] would make sense if
other [global-dns-domain-...] sections were present.
However, the user might only want to set the options in resolv.conf and
still use connection-provide nameservers for the actual resolving.
Lift the limitation by allowing the [global-dns] to be used alone, while
still insist on [global-dns-domain-*] being there in presence of other
domain-specific options.
https://bugzilla.redhat.com/show_bug.cgi?id=2019306
(cherry picked from commit 1f0d1d78d2a28ef82764a801c344e22816b06f67)
---
Makefile.am | 2 +
src/core/dns/nm-dns-manager.c | 41 +++++++++----------
src/core/nm-config-data.c | 2 +-
src/core/tests/config/global-dns-good.conf | 13 ++++++
src/core/tests/config/global-dns-options.conf | 5 +++
src/core/tests/config/test-config.c | 16 +++++++-
6 files changed, 55 insertions(+), 24 deletions(-)
create mode 100644 src/core/tests/config/global-dns-good.conf
create mode 100644 src/core/tests/config/global-dns-options.conf
diff --git a/Makefile.am b/Makefile.am
index aa79967e1b..3d43c010a7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4497,7 +4497,9 @@ EXTRA_DIST += \
src/core/tests/config/NetworkManager-warn.conf \
src/core/tests/config/NetworkManager.state \
src/core/tests/config/bad.conf \
+ src/core/tests/config/global-dns-good.conf \
src/core/tests/config/global-dns-invalid.conf \
+ src/core/tests/config/global-dns-options.conf \
src/core/tests/config/conf.d/00-overrides.conf \
src/core/tests/config/conf.d/10-more.conf \
src/core/tests/config/conf.d/20-config-enable-1.conf \
diff --git a/src/core/dns/nm-dns-manager.c b/src/core/dns/nm-dns-manager.c
index 457b82a098..42519e64fe 100644
--- a/src/core/dns/nm-dns-manager.c
+++ b/src/core/dns/nm-dns-manager.c
@@ -1201,7 +1201,8 @@ compute_hash(NMDnsManager *self, const NMGlobalDnsConfig *global, guint8 buffer[
if (global)
nm_global_dns_config_update_checksum(global, sum);
- else {
+
+ if (!global || !nm_global_dns_config_lookup_domain(global, "*")) {
const CList *head;
/* FIXME(ip-config-checksum): this relies on the fact that an IP
@@ -1244,13 +1245,15 @@ merge_global_dns_config(NMResolvConfData *rc, NMGlobalDnsConfig *global_conf)
}
default_domain = nm_global_dns_config_lookup_domain(global_conf, "*");
- nm_assert(default_domain);
+ if (!default_domain)
+ return TRUE;
servers = nm_global_dns_domain_get_servers(default_domain);
- if (servers) {
- for (i = 0; servers[i]; i++)
- add_string_item(rc->nameservers, servers[i], TRUE);
- }
+ if (!servers)
+ return TRUE;
+
+ for (i = 0; servers[i]; i++)
+ add_string_item(rc->nameservers, servers[i], TRUE);
return TRUE;
}
@@ -1311,9 +1314,10 @@ _collect_resolv_conf_data(NMDnsManager *self,
priv = NM_DNS_MANAGER_GET_PRIVATE(self);
- if (global_config) {
+ if (global_config)
merge_global_dns_config(&rc, global_config);
- } else {
+
+ if (!global_config || !nm_global_dns_config_lookup_domain(global_config, "*")) {
nm_auto_str_buf NMStrBuf tmp_strbuf = NM_STR_BUF_INIT(0, FALSE);
int first_prio = 0;
const NMDnsConfigIPData *ip_data;
@@ -2556,14 +2560,12 @@ config_changed_cb(NMConfig *config,
}
}
-static GVariant *
-_get_global_config_variant(NMGlobalDnsConfig *global)
+static void
+_get_global_config_variant(GVariantBuilder *builder, NMGlobalDnsConfig *global)
{
NMGlobalDnsDomain *domain;
- GVariantBuilder builder;
guint i, num;
- g_variant_builder_init(&builder, G_VARIANT_TYPE("aa{sv}"));
num = nm_global_dns_config_get_num_domains(global);
for (i = 0; i < num; i++) {
GVariantBuilder conf_builder;
@@ -2599,10 +2601,8 @@ _get_global_config_variant(NMGlobalDnsConfig *global)
"priority",
g_variant_new_int32(NM_DNS_PRIORITY_DEFAULT_NORMAL));
- g_variant_builder_add(&builder, "a{sv}", &conf_builder);
+ g_variant_builder_add(builder, "a{sv}", &conf_builder);
}
-
- return g_variant_ref_sink(g_variant_builder_end(&builder));
}
static GVariant *
@@ -2619,15 +2619,12 @@ _get_config_variant(NMDnsManager *self)
if (priv->config_variant)
return priv->config_variant;
- global_config = nm_config_data_get_global_dns_config(nm_config_get_data(priv->config));
- if (global_config) {
- priv->config_variant = _get_global_config_variant(global_config);
- _LOGT("current configuration: %s", (str = g_variant_print(priv->config_variant, TRUE)));
- return priv->config_variant;
- }
-
g_variant_builder_init(&builder, G_VARIANT_TYPE("aa{sv}"));
+ global_config = nm_config_data_get_global_dns_config(nm_config_get_data(priv->config));
+ if (global_config)
+ _get_global_config_variant(&builder, global_config);
+
head = _mgr_get_ip_data_lst_head(self);
c_list_for_each_entry (ip_data, head, ip_data_lst) {
GVariantBuilder entry_builder;
diff --git a/src/core/nm-config-data.c b/src/core/nm-config-data.c
index 1504b15659..c6ab998f94 100644
--- a/src/core/nm-config-data.c
+++ b/src/core/nm-config-data.c
@@ -1233,7 +1233,7 @@ load_global_dns(GKeyFile *keyfile, gboolean internal)
default_found = TRUE;
}
- if (!default_found) {
+ if (!default_found && g_hash_table_size(dns_config->domains)) {
nm_log_dbg(LOGD_CORE,
"%s global DNS configuration is missing default domain, ignore it",
internal ? "internal" : "user");
diff --git a/src/core/tests/config/global-dns-good.conf b/src/core/tests/config/global-dns-good.conf
new file mode 100644
index 0000000000..6265a611cf
--- /dev/null
+++ b/src/core/tests/config/global-dns-good.conf
@@ -0,0 +1,13 @@
+# Good configuration, since there is a default domain section
+
+[global-dns]
+searches=foo.com
+options=timeout:5
+
+[global-dns-domain-*]
+servers=4.5.6.7
+options=myoption1
+
+[global-dns-domain-test.com]
+servers=1.2.3.4
+options=myoption2
diff --git a/src/core/tests/config/global-dns-options.conf b/src/core/tests/config/global-dns-options.conf
new file mode 100644
index 0000000000..0be1773525
--- /dev/null
+++ b/src/core/tests/config/global-dns-options.conf
@@ -0,0 +1,5 @@
+# Good configuration, since there is no domain section
+
+[global-dns]
+searches=foo.com
+options=timeout:5
diff --git a/src/core/tests/config/test-config.c b/src/core/tests/config/test-config.c
index fa7fae0757..054b9003f4 100644
--- a/src/core/tests/config/test-config.c
+++ b/src/core/tests/config/test-config.c
@@ -370,7 +370,21 @@ test_config_global_dns(void)
g_object_unref(config);
- /* Check that a file without a default domain section gives a NULL configuration */
+ /* Check that a file with a default domain section gives a good configuration */
+ config =
+ setup_config(NULL, TEST_DIR "/global-dns-good.conf", "", NULL, "/no/such/dir", "", NULL);
+ dns = nm_config_data_get_global_dns_config(nm_config_get_data_orig(config));
+ g_assert(dns);
+ g_object_unref(config);
+
+ /* Check that a file with options but no domains gives a good configuration */
+ config =
+ setup_config(NULL, TEST_DIR "/global-dns-options.conf", "", NULL, "/no/such/dir", "", NULL);
+ dns = nm_config_data_get_global_dns_config(nm_config_get_data_orig(config));
+ g_assert(dns);
+ g_object_unref(config);
+
+ /* Check that a file with a domain domain, but without a default one gives a NULL configuration */
config =
setup_config(NULL, TEST_DIR "/global-dns-invalid.conf", "", NULL, "/no/such/dir", "", NULL);
dns = nm_config_data_get_global_dns_config(nm_config_get_data_orig(config));
--
2.39.1

View File

@ -0,0 +1,104 @@
From 25efc7198de6283c7d62f991cd76d1b4ec7c1eb4 Mon Sep 17 00:00:00 2001
From: Thomas Haller <thaller@redhat.com>
Date: Fri, 10 Feb 2023 16:31:50 +0100
Subject: [PATCH 1/1] libnm/docs: fix gtk-doc generation for settings
Marking "nm-core-types.h" as to be ignored by gtk-doc, causes many files
to have the wrong names:
/docs/libnm/html/{NMConnection.html => libnm-NMConnection.html}
/docs/libnm/html/{NMSetting.html => libnm-NMSetting.html}
/docs/libnm/html/{NMSetting6Lowpan.html => libnm-NMSetting6Lowpan.html}
/docs/libnm/html/{NMSetting8021x.html => libnm-NMSetting8021x.html}
/docs/libnm/html/{NMSettingAdsl.html => libnm-NMSettingAdsl.html}
/docs/libnm/html/{NMSettingBluetooth.html => libnm-NMSettingBluetooth.html}
/docs/libnm/html/{NMSettingBond.html => libnm-NMSettingBond.html}
/docs/libnm/html/{NMSettingBondPort.html => libnm-NMSettingBondPort.html}
/docs/libnm/html/{NMSettingBridge.html => libnm-NMSettingBridge.html}
/docs/libnm/html/{NMSettingBridgePort.html => libnm-NMSettingBridgePort.html}
/docs/libnm/html/{NMSettingCdma.html => libnm-NMSettingCdma.html}
/docs/libnm/html/{NMSettingConnection.html => libnm-NMSettingConnection.html}
/docs/libnm/html/{NMSettingDcb.html => libnm-NMSettingDcb.html}
/docs/libnm/html/{NMSettingDummy.html => libnm-NMSettingDummy.html}
/docs/libnm/html/{NMSettingEthtool.html => libnm-NMSettingEthtool.html}
/docs/libnm/html/{NMSettingGeneric.html => libnm-NMSettingGeneric.html}
/docs/libnm/html/{NMSettingGsm.html => libnm-NMSettingGsm.html}
/docs/libnm/html/{NMSettingHostname.html => libnm-NMSettingHostname.html}
/docs/libnm/html/{NMSettingIP4Config.html => libnm-NMSettingIP4Config.html}
/docs/libnm/html/{NMSettingIP6Config.html => libnm-NMSettingIP6Config.html}
/docs/libnm/html/{NMSettingIPConfig.html => libnm-NMSettingIPConfig.html}
/docs/libnm/html/{NMSettingIPTunnel.html => libnm-NMSettingIPTunnel.html}
/docs/libnm/html/{NMSettingInfiniband.html => libnm-NMSettingInfiniband.html}
/docs/libnm/html/{NMSettingMacsec.html => libnm-NMSettingMacsec.html}
/docs/libnm/html/{NMSettingMacvlan.html => libnm-NMSettingMacvlan.html}
/docs/libnm/html/{NMSettingMatch.html => libnm-NMSettingMatch.html}
/docs/libnm/html/{NMSettingOlpcMesh.html => libnm-NMSettingOlpcMesh.html}
/docs/libnm/html/{NMSettingOvsBridge.html => libnm-NMSettingOvsBridge.html}
/docs/libnm/html/{NMSettingOvsDpdk.html => libnm-NMSettingOvsDpdk.html}
/docs/libnm/html/{NMSettingOvsExternalIDs.html => libnm-NMSettingOvsExternalIDs.html}
/docs/libnm/html/{NMSettingOvsInterface.html => libnm-NMSettingOvsInterface.html}
/docs/libnm/html/{NMSettingOvsPatch.html => libnm-NMSettingOvsPatch.html}
/docs/libnm/html/{NMSettingOvsPort.html => libnm-NMSettingOvsPort.html}
/docs/libnm/html/{NMSettingPpp.html => libnm-NMSettingPpp.html}
/docs/libnm/html/{NMSettingPppoe.html => libnm-NMSettingPppoe.html}
/docs/libnm/html/{NMSettingProxy.html => libnm-NMSettingProxy.html}
/docs/libnm/html/{NMSettingSerial.html => libnm-NMSettingSerial.html}
/docs/libnm/html/{NMSettingSriov.html => libnm-NMSettingSriov.html}
/docs/libnm/html/{NMSettingTCConfig.html => libnm-NMSettingTCConfig.html}
/docs/libnm/html/{NMSettingTeam.html => libnm-NMSettingTeam.html}
/docs/libnm/html/{NMSettingTeamPort.html => libnm-NMSettingTeamPort.html}
/docs/libnm/html/{NMSettingTun.html => libnm-NMSettingTun.html}
/docs/libnm/html/{NMSettingUser.html => libnm-NMSettingUser.html}
/docs/libnm/html/{NMSettingVeth.html => libnm-NMSettingVeth.html}
/docs/libnm/html/{NMSettingVlan.html => libnm-NMSettingVlan.html}
/docs/libnm/html/{NMSettingVpn.html => libnm-NMSettingVpn.html}
/docs/libnm/html/{NMSettingVrf.html => libnm-NMSettingVrf.html}
/docs/libnm/html/{NMSettingVxlan.html => libnm-NMSettingVxlan.html}
/docs/libnm/html/{NMSettingWifiP2P.html => libnm-NMSettingWifiP2P.html}
/docs/libnm/html/{NMSettingWimax.html => libnm-NMSettingWimax.html}
/docs/libnm/html/{NMSettingWireGuard.html => libnm-NMSettingWireGuard.html}
/docs/libnm/html/{NMSettingWired.html => libnm-NMSettingWired.html}
/docs/libnm/html/{NMSettingWireless.html => libnm-NMSettingWireless.html}
/docs/libnm/html/{NMSettingWirelessSecurity.html => libnm-NMSettingWirelessSecurity.html}
/docs/libnm/html/{NMSettingWpan.html => libnm-NMSettingWpan.html}
/docs/libnm/html/{NMSimpleConnection.html => libnm-NMSimpleConnection.html}
Revert that part of the change. Even if this regresses other problems.
Fixes: 1330292d057c ('docs/libnm: fix gtkdoc-scan ignore lists')
(cherry picked from commit f0e3ca09c9d3a3196bee232307e42f008eb4baf2)
(cherry picked from commit 51b67d43275af5d7ab50d9b293b60d425925ac9b)
---
docs/libnm/Makefile.am | 2 --
docs/libnm/meson.build | 2 --
2 files changed, 4 deletions(-)
diff --git a/docs/libnm/Makefile.am b/docs/libnm/Makefile.am
index 928ea5ee1d5e..7a10848f0ab3 100644
--- a/docs/libnm/Makefile.am
+++ b/docs/libnm/Makefile.am
@@ -38,8 +38,6 @@ CFILE_GLOB=$(top_srcdir)/src/libnm-core-impl/*.c $(top_srcdir)/src/libnm-client-
# Header files to ignore when scanning.
IGNORE_HFILES= \
- nm-core-types.h \
- \
nm-dbus-helpers.h \
nm-default-libnm.h \
nm-device-private.h \
diff --git a/docs/libnm/meson.build b/docs/libnm/meson.build
index 5e742b6c3eab..01c9b6695963 100644
--- a/docs/libnm/meson.build
+++ b/docs/libnm/meson.build
@@ -1,8 +1,6 @@
# SPDX-License-Identifier: LGPL-2.1-or-later
private_headers = [
- 'nm-core-types.h',
-
'nm-dbus-helpers.h',
'nm-default-libnm.h',
'nm-device-private.h',
--
2.39.1

View File

@ -4,12 +4,13 @@
%global glib2_version %(pkg-config --modversion glib-2.0 2>/dev/null || echo bad)
%global epoch_version 1
%global real_version 1.41.91
%global real_version 1.42.0
%global rpm_version %{real_version}
%global release_version 1
%global snapshot %{nil}
%global git_sha %{nil}
%global bcond_default_debug 0
%global bcond_default_lto %{nil}
%global bcond_default_test 0
%global obsoletes_device_plugins 1:0.9.9.95-1
@ -60,11 +61,19 @@
%else
%bcond_with test
%endif
%if "%{?bcond_default_lto}" == ""
%if 0%{?fedora} >= 33 || 0%{?rhel} >= 9
%bcond_without lto
%else
%bcond_with lto
%endif
%else
%if %{bcond_default_lto}
%bcond_without lto
%else
%bcond_with lto
%endif
%endif
%bcond_with sanitizer
%if 0%{?fedora}
%bcond_without connectivity_fedora
@ -194,9 +203,7 @@ Source7: readme-ifcfg-rh.txt
# Bugfixes that are only relevant until next rebase of the package.
# Patch1001: 1001-some.patch
Patch1: 0001-dns-manager-style-fix.patch
Patch2: 0002-config-data-style-fix.patch
Patch3: 0003-dns-manager-always-apply-options-from-global-dns.patch
Patch1000: 1000-libnm-docs-fix-gtk-doc-generation-for-settings.patch
Requires(post): systemd
%if 0%{?fedora} || 0%{?rhel} >= 8
@ -296,6 +303,10 @@ BuildRequires: python2
BuildRequires: pygobject3-base
BuildRequires: dbus-python
BuildRequires: pexpect
%if 0%{?rhel} >= 7 && %{with meson}
BuildRequires: python36-dbus
BuildRequires: python36-gobject
%endif
%endif
BuildRequires: libselinux-devel
BuildRequires: polkit-devel
@ -679,6 +690,7 @@ Preferably use nmcli instead.
%else
-Ddocs=false \
%endif
-Dqt=false \
%if %{with team}
-Dteamdctl=true \
%else
@ -706,6 +718,7 @@ Preferably use nmcli instead.
%endif
-Dsession_tracking=systemd \
-Dsuspend_resume=systemd \
-Dsystemdsystemunitdir=%{_unitdir} \
-Dsystem_ca_path=/etc/pki/tls/cert.pem \
-Ddbus_conf_dir=%{dbus_sys_dir} \
-Dtests=yes \
@ -713,8 +726,11 @@ Preferably use nmcli instead.
-Difcfg_rh=true \
-Difupdown=false \
%if %{with ppp}
-Dpppd_plugin_dir=%{_libdir}/pppd/%{ppp_version} \
-Dpppd_plugin_dir="%{_libdir}/pppd/%{ppp_version}" \
-Dpppd="%{_sbindir}/pppd" \
-Dppp=true \
%else
-Dppp=false \
%endif
%if %{with firewalld_zone}
-Dfirewalld_zone=true \
@ -842,6 +858,7 @@ autoreconf --install --force
--with-ebpf=%{ebpf_enabled} \
--with-session-tracking=systemd \
--with-suspend-resume=systemd \
--with-systemdsystemunitdir=%{_unitdir} \
--with-system-ca-path=/etc/pki/tls/cert.pem \
--with-dbus-sys-dir=%{dbus_sys_dir} \
--with-tests=yes \
@ -854,8 +871,11 @@ autoreconf --install --force
--enable-ifcfg-rh=yes \
--enable-ifupdown=no \
%if %{with ppp}
--with-pppd-plugin-dir=%{_libdir}/pppd/%{ppp_version} \
--enable-ppp=yes \
--with-pppd="%{_sbindir}/pppd" \
--with-pppd-plugin-dir="%{_libdir}/pppd/%{ppp_version}" \
%else
--enable-ppp=no \
%endif
%if %{with firewalld_zone}
--enable-firewalld-zone=yes \
@ -913,7 +933,7 @@ rm -f %{buildroot}%{nmplugindir}/*.la
# Ensure the documentation timestamps are constant to avoid multilib conflicts
find %{buildroot}%{_datadir}/gtk-doc -exec touch --reference configure.ac '{}' \+
%if 0%{?__debug_package}
%if 0%{?__debug_package} && ! 0%{?flatpak}
mkdir -p %{buildroot}%{_prefix}/src/debug/NetworkManager-%{real_version}
cp valgrind.suppressions %{buildroot}%{_prefix}/src/debug/NetworkManager-%{real_version}
%endif
@ -1070,10 +1090,10 @@ fi
%{_mandir}/man1/*
%{_mandir}/man5/*
%{_mandir}/man7/nmcli-examples.7*
%{_mandir}/man8/nm-initrd-generator.8.gz
%{_mandir}/man8/NetworkManager.8.gz
%{_mandir}/man8/NetworkManager-dispatcher.8.gz
%{_mandir}/man8/NetworkManager-wait-online.service.8.gz
%{_mandir}/man8/nm-initrd-generator.8*
%{_mandir}/man8/NetworkManager.8*
%{_mandir}/man8/NetworkManager-dispatcher.8*
%{_mandir}/man8/NetworkManager-wait-online.service.8*
%dir %{_localstatedir}/lib/NetworkManager
%dir %{_sysconfdir}/sysconfig/network-scripts
%{_datadir}/dbus-1/system-services/org.freedesktop.nm_dispatcher.service
@ -1232,6 +1252,9 @@ fi
%changelog
* Fri Feb 10 2023 Thomas Haller <thaller@redhat.com> - 1:1.42.0-1
- Update to 1.42.0 release
* Thu Jan 26 2023 Lubomir Rintel <lkundrak@v3.sk> - - 1:1.41.91-1
- Update to 1.41.91 release (release candidate)
- core: retry if a rtnetlink socket runs out of buffer space (rh #2154350)
@ -1241,6 +1264,7 @@ fi
- Update to 1.41.90 release (release candidate)
- l3cfg: schedule an update after every commit-type/config-data register/unregister (rh #2158394)
- all: add support for ovs-dpdk n-rxq-desc and n-txq-desc (rh #2156385)
- core: fix consistency for internal cache for IPv6 routes (rh #2060684)
* Wed Jan 11 2023 Beniamino Galvani <bgalvani@redhat.com> - 1:1.41.8-1
- Update to 1.41.8 release (development)

View File

@ -1 +1 @@
SHA512 (NetworkManager-1.41.91.tar.xz) = 178b29e73c0490139dee9b07f36ed03e8970558613d6309f9e0de57b992cf2f0263b460a423d632ca99d6d0ff6cbc48442ce366a9bcbcba1d44cc2a571b3d550
SHA512 (NetworkManager-1.42.0.tar.xz) = d6c57f79e1de669537501855545d0861044f07780fde61cbb643a955e84a3ca4e417cfb1978c277a1bca9002778dafda5387c28da1b4a58f9f320adaa553210c