Add upstream fix for AP list hash function (#1288867)
This commit is contained in:
parent
b880770c84
commit
13724a4562
@ -9,7 +9,7 @@
|
|||||||
|
|
||||||
%global snapshot .20151112gitec4d653
|
%global snapshot .20151112gitec4d653
|
||||||
%global realversion 1.2.0
|
%global realversion 1.2.0
|
||||||
%global release_version 0.3
|
%global release_version 0.4
|
||||||
%global epoch_version 1
|
%global epoch_version 1
|
||||||
|
|
||||||
%global obsoletes_nmver 1:0.9.9.95-1
|
%global obsoletes_nmver 1:0.9.9.95-1
|
||||||
@ -63,6 +63,9 @@ Source1: NetworkManager.conf
|
|||||||
Source2: 00-server.conf
|
Source2: 00-server.conf
|
||||||
Source3: 10-ibft-plugin.conf
|
Source3: 10-ibft-plugin.conf
|
||||||
Source4: 20-connectivity-fedora.conf
|
Source4: 20-connectivity-fedora.conf
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1288867
|
||||||
|
Patch0: soup-deprecation-fix.patch
|
||||||
|
Patch1: fix-ap-list-hash-function.patch
|
||||||
|
|
||||||
Requires(post): systemd
|
Requires(post): systemd
|
||||||
Requires(preun): systemd
|
Requires(preun): systemd
|
||||||
@ -300,6 +303,8 @@ by nm-connection-editor and nm-applet in a non-graphical environment.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n NetworkManager-%{realversion}
|
%setup -q -n NetworkManager-%{realversion}
|
||||||
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -598,6 +603,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 08 2016 David King <amigadave@amigadave.com> - 1:1.2.0-0.4.20151007gite73e55c
|
||||||
|
- Add upstream fix for AP list hash function (#1288867)
|
||||||
|
|
||||||
* Thu Nov 12 2015 Lubomir Rintel <lkundrak@v3.sk> - 1:1.2.0-0.3.20151112gitec4d653
|
* Thu Nov 12 2015 Lubomir Rintel <lkundrak@v3.sk> - 1:1.2.0-0.3.20151112gitec4d653
|
||||||
- Update to a later snapshot
|
- Update to a later snapshot
|
||||||
- Enables RFC7217 addressing for new IPv6 connections
|
- Enables RFC7217 addressing for new IPv6 connections
|
||||||
|
29
fix-ap-list-hash-function.patch
Normal file
29
fix-ap-list-hash-function.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From 914d875dc2ea2e410c422cf9d027d33e47396cdf Mon Sep 17 00:00:00 2001
|
||||||
|
From: Thomas Haller <thaller@redhat.com>
|
||||||
|
Date: Mon, 16 Nov 2015 16:51:54 +0100
|
||||||
|
Subject: wifi: fix handling APs list using string-hashing
|
||||||
|
|
||||||
|
Commit d51827801128564c31dc5f9cc31db18f1bf7ae79 changed
|
||||||
|
the hashing for the APs to use direct-hashing.
|
||||||
|
|
||||||
|
That was wrong because get_ap_by_path() needs a full
|
||||||
|
string-comparison.
|
||||||
|
|
||||||
|
Fixes: d51827801128564c31dc5f9cc31db18f1bf7ae79
|
||||||
|
|
||||||
|
diff --git a/src/devices/wifi/nm-device-wifi.c b/src/devices/wifi/nm-device-wifi.c
|
||||||
|
index a9fb6c8..0eeb845 100644
|
||||||
|
--- a/src/devices/wifi/nm-device-wifi.c
|
||||||
|
+++ b/src/devices/wifi/nm-device-wifi.c
|
||||||
|
@@ -2881,7 +2881,7 @@ nm_device_wifi_init (NMDeviceWifi *self)
|
||||||
|
NMDeviceWifiPrivate *priv = NM_DEVICE_WIFI_GET_PRIVATE (self);
|
||||||
|
|
||||||
|
priv->mode = NM_802_11_MODE_INFRA;
|
||||||
|
- priv->aps = g_hash_table_new (g_direct_hash, g_direct_equal);
|
||||||
|
+ priv->aps = g_hash_table_new (g_str_hash, g_str_equal);
|
||||||
|
}
|
||||||
|
|
||||||
|
static void
|
||||||
|
--
|
||||||
|
cgit v0.10.2
|
||||||
|
|
64
soup-deprecation-fix.patch
Normal file
64
soup-deprecation-fix.patch
Normal file
@ -0,0 +1,64 @@
|
|||||||
|
From 15f1cd09d92bdb4e8001e1cf781db305569e2068 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||||
|
Date: Thu, 10 Dec 2015 18:53:49 +0100
|
||||||
|
Subject: build: use soup 2.32
|
||||||
|
|
||||||
|
We already use 2.32 API and also use API that was replaced with new one after
|
||||||
|
2.42 and deprecated in 2.53.
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index a29602b..715b605 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -827,7 +827,7 @@ fi
|
||||||
|
AC_DEFINE_UNQUOTED(KERNEL_FIRMWARE_DIR, "$KERNEL_FIRMWARE_DIR", [Define to path of the kernel firmware directory])
|
||||||
|
AC_SUBST(KERNEL_FIRMWARE_DIR)
|
||||||
|
|
||||||
|
-PKG_CHECK_MODULES(LIBSOUP, [libsoup-2.4 >= 2.26], [have_libsoup=yes],[have_libsoup=no])
|
||||||
|
+PKG_CHECK_MODULES(LIBSOUP, [libsoup-2.4 >= 2.32], [have_libsoup=yes],[have_libsoup=no])
|
||||||
|
AC_ARG_WITH(libsoup, AS_HELP_STRING([--with-libsoup=yes|no], [Link against libsoup]), [], [with_libsoup=${have_libsoup}])
|
||||||
|
if test "$with_libsoup" != "no"; then
|
||||||
|
if test "$have_libsoup" != "yes"; then
|
||||||
|
@@ -839,6 +839,7 @@ else
|
||||||
|
AC_DEFINE(WITH_LIBSOUP, 0, [Define if you have libsoup])
|
||||||
|
fi
|
||||||
|
AM_CONDITIONAL(WITH_LIBSOUP, test "$with_libsoup" != "no")
|
||||||
|
+LIBSOUP_CFLAGS="$LIBSOUP_CFLAGS -DSOUP_VERSION_MIN_REQUIRED=SOUP_VERSION_2_32 -DSOUP_VERSION_MAX_ALLOWED=SOUP_VERSION_2_32"
|
||||||
|
|
||||||
|
AC_ARG_ENABLE(concheck, AS_HELP_STRING([--enable-concheck], [enable connectivity checking support]),
|
||||||
|
[enable_concheck=${enableval}], [enable_concheck=${with_libsoup}])
|
||||||
|
--
|
||||||
|
cgit v0.10.2
|
||||||
|
|
||||||
|
From 7873b1761de362a66e3b09eacf470ce6e3360068 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||||
|
Date: Thu, 10 Dec 2015 19:17:56 +0100
|
||||||
|
Subject: build: bump soup requirement to 2.40
|
||||||
|
|
||||||
|
The dns-manager uses some newer API.
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 715b605..c2c48d2 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -827,7 +827,7 @@ fi
|
||||||
|
AC_DEFINE_UNQUOTED(KERNEL_FIRMWARE_DIR, "$KERNEL_FIRMWARE_DIR", [Define to path of the kernel firmware directory])
|
||||||
|
AC_SUBST(KERNEL_FIRMWARE_DIR)
|
||||||
|
|
||||||
|
-PKG_CHECK_MODULES(LIBSOUP, [libsoup-2.4 >= 2.32], [have_libsoup=yes],[have_libsoup=no])
|
||||||
|
+PKG_CHECK_MODULES(LIBSOUP, [libsoup-2.4 >= 2.40], [have_libsoup=yes],[have_libsoup=no])
|
||||||
|
AC_ARG_WITH(libsoup, AS_HELP_STRING([--with-libsoup=yes|no], [Link against libsoup]), [], [with_libsoup=${have_libsoup}])
|
||||||
|
if test "$with_libsoup" != "no"; then
|
||||||
|
if test "$have_libsoup" != "yes"; then
|
||||||
|
@@ -839,7 +839,7 @@ else
|
||||||
|
AC_DEFINE(WITH_LIBSOUP, 0, [Define if you have libsoup])
|
||||||
|
fi
|
||||||
|
AM_CONDITIONAL(WITH_LIBSOUP, test "$with_libsoup" != "no")
|
||||||
|
-LIBSOUP_CFLAGS="$LIBSOUP_CFLAGS -DSOUP_VERSION_MIN_REQUIRED=SOUP_VERSION_2_32 -DSOUP_VERSION_MAX_ALLOWED=SOUP_VERSION_2_32"
|
||||||
|
+LIBSOUP_CFLAGS="$LIBSOUP_CFLAGS -DSOUP_VERSION_MIN_REQUIRED=SOUP_VERSION_2_40 -DSOUP_VERSION_MAX_ALLOWED=SOUP_VERSION_2_40"
|
||||||
|
|
||||||
|
AC_ARG_ENABLE(concheck, AS_HELP_STRING([--enable-concheck], [enable connectivity checking support]),
|
||||||
|
[enable_concheck=${enableval}], [enable_concheck=${with_libsoup}])
|
||||||
|
--
|
||||||
|
cgit v0.10.2
|
||||||
|
|
Loading…
Reference in New Issue
Block a user