diff --git a/0001-settings-fix-a-reversed-conditional-in-have_connecti.patch b/0001-settings-fix-a-reversed-conditional-in-have_connecti.patch
new file mode 100644
index 0000000..1bdfb14
--- /dev/null
+++ b/0001-settings-fix-a-reversed-conditional-in-have_connecti.patch
@@ -0,0 +1,29 @@
+From c6106672861f9a188469f7e490cc38af60943a10 Mon Sep 17 00:00:00 2001
+From: Lubomir Rintel <lkundrak@v3.sk>
+Date: Mon, 8 Jul 2019 18:02:22 +0200
+Subject: [PATCH] settings: fix a reversed conditional in
+ have_connection_for_device()
+
+https://bugzilla.redhat.com/show_bug.cgi?id=1727411
+
+Fixes: be0018382d4d ('settings: in have_connection_for_device() first skip over irrelevant connection types')
+---
+ src/settings/nm-settings.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/settings/nm-settings.c b/src/settings/nm-settings.c
+index 6fbda5274..47866a442 100644
+--- a/src/settings/nm-settings.c
++++ b/src/settings/nm-settings.c
+@@ -1505,7 +1505,7 @@ have_connection_for_device (NMSettings *self, NMDevice *device)
+ 			continue;
+ 
+ 		iface = nm_setting_connection_get_interface_name (s_con);
+-		if (nm_streq0 (iface, nm_device_get_iface (device)))
++		if (!nm_streq0 (iface, nm_device_get_iface (device)))
+ 			continue;
+ 
+ 		s_wired = nm_connection_get_setting_wired (connection);
+-- 
+2.21.0
+
diff --git a/NetworkManager.spec b/NetworkManager.spec
index a653abd..1fe64c5 100644
--- a/NetworkManager.spec
+++ b/NetworkManager.spec
@@ -10,7 +10,7 @@
 %global epoch_version 1
 %global rpm_version 1.20.0
 %global real_version 1.19.5
-%global release_version 0.3
+%global release_version 0.4
 %global snapshot %{nil}
 %global git_sha %{nil}
 
@@ -131,6 +131,9 @@ Source5: 20-connectivity-redhat.conf
 
 #Patch1: 0001-some.patch
 
+# https://bugzilla.redhat.com/show_bug.cgi?id=1727411
+Patch1: https://gitlab.freedesktop.org/NetworkManager/NetworkManager/commit/c61066728.patch#/0001-settings-fix-a-reversed-conditional-in-have_connecti.patch
+
 Requires(post): systemd
 Requires(post): /usr/sbin/update-alternatives
 Requires(preun): systemd
@@ -942,6 +945,9 @@ fi
 
 
 %changelog
+* Mon Jul 08 2019 Lubomir Rintel <lkundrak@v3.sk> - 1:1.20.0-0.4
+- settings: fix a reversed conditional in have_connection_for_device() (rh #1727411)
+
 * Wed Jul 03 2019 Lubomir Rintel <lkundrak@v3.sk> - 1:1.20.0-0.3
 - Update the 1.20.0 snapshot
 - initrd: skip ethernet hwtype in BOOTIF (rh #1726240)