Fix ppc64le compilation crashes

They (probably) crash due to high memory usage. The build argument
-flto-partition=none is known to increase memory usage, so remove it.

Related: RHEL-70420
This commit is contained in:
Íñigo Huguet 2025-02-10 16:28:11 +01:00
parent 3d2b516f94
commit 06f85cc351
2 changed files with 34 additions and 7 deletions

View File

@ -0,0 +1,28 @@
diff --git a/meson.build b/meson.build
index 4f6d14da9a..335a7348ee 100644
--- a/meson.build
+++ b/meson.build
@@ -172,18 +172,10 @@ if enable_ld_gc
endif
enable_lto = get_option('b_lto')
-if enable_lto
- if cc.get_id() == 'clang'
- clang_version = cc.version()
- if clang_version <= '18.0.0'
- error('Clang version should be greater then 18.0.0 got : ' + clang_version)
- endif
- else
- # Meson already adds '-flto'
- lto_flag = '-flto-partition=none'
- assert(cc.has_argument(lto_flag), '-flto-partition=none not supported. Disable link-time optimization with -Db_lto=false.')
- common_flags += lto_flag
- common_ldflags += lto_flag
+if enable_lto and cc.get_id() == 'clang'
+ clang_version = cc.version()
+ if clang_version <= '18.0.0'
+ error('Clang version should be greater then 18.0.0 got : ' + clang_version)
endif
endif

View File

@ -7,7 +7,7 @@
%global real_version 1.51.7
%global git_tag_version_suffix -dev
%global rpm_version %{real_version}
%global release_version 1
%global release_version 2
%global snapshot %{nil}
%global git_sha %{nil}
%global bcond_default_debug 0
@ -156,11 +156,6 @@
%global ebpf_enabled "no"
%endif
# Fedora 33 enables LTO by default by setting CFLAGS="-flto -ffat-lto-objects".
# However, we also require "-flto -flto-partition=none", so disable Fedora's
# default and use our configure option --with-lto instead.
%define _lto_cflags %{nil}
###############################################################################
Name: NetworkManager
@ -189,7 +184,7 @@ Source9: readme-ifcfg-rh-migrated.txt
Patch0001: 0001-revert-change-default-value-for-ipv4.dad-timeout-from-0-to-200ms.patch
# Bugfixes that are only relevant until next rebase of the package.
# Patch1001: 1001-some.patch
Patch1001: 1001-disable-lto-partition-none.patch
Requires(post): systemd
Requires(post): systemd-udev
@ -1074,6 +1069,10 @@ fi
%changelog
* Mon Feb 10 2025 Íñigo Huguet <ihuguet@redhat.com> - 1:1:51.7-2
- Remove the build argument -flto-partition to avoid compilation crashes due
to high memory usage.
* Fri Feb 07 2025 Vladimír Beneš <vbenes@redhat.com> - 1:1.51.7-1
- Update to 1.51.7 (dev)
- Add support in initramfs generator for parsing NM eDNS configuration (RHEL-70420)