NetworkManager-libreswan/0018-Fixed-various-debug-messages.patch
Avesh Agarwal 08f137fc11 New upstream release 0.9.8.4
- Fixed 926225
- Fixed dependency to libreswan.
- Created a new sub package NetworkManager-openswan-gnome
- Various other spec file fixes.
- Additional code changes are as follows:
- Fixed an issue where proper network stack is not loaded unless
  _stackmanager is run before starting pluto daemon service.
- Fixed the termination operation of pluto daemon to comply with
  libreswan changes.
- Fixed various debug messages.
- Fixed initiation of pluto daemon by this plugin to reflect the
  changes in libreaswan.
- Fixed defaults values for more parameters to help the VPN
  connection stay more reliable.
- Rewrote pluto watch API which watches the pluto process for its status.
  Fixed memory leak issues as not all child processes were reaped correctly.
  Also g_spwan_close_pid was not being called after children were reaped.
  Also modified debugs and added more to help with debugging in the future.
- Fixed an issue where nm-openswan service is searching for ipsec binary in
  both /sbin and /usr/sbin leading to same operation twice, as /sbin is just
  symlink to /usr/sbin, so removed /sbin from the search paths.
- Fixed some libreswan related macro changes.
- Fixed netmask issue when sending IP information to the nm openswan
  plugin service.
- Fixed the current code as it does not set the default route field
  NM_VPN_PLUGIN_IP4_CONFIG_NEVER_DEFAULT when sending VPN information
  to nm-openswan plugin. This fix sets the field to TRUE.
- Fixed some issues found by coverity scan.
- Fixed an issue where writing configuration on stdin should not end with
  \n as it gives error. It used to work previously, but not with latest
  NetworkManager versions.
- libreswan related fixes, as some macros have been modified after forking
  to libreswan from openswan.
- openswan/libreswan does not provide tun0 interface, so fixed the code
  where it sends tun0 interface.
- Fix prcoessing of nm-openswan-dialog.ui file and added more error notifications.
- Fixed dead code based on coverity scan.
- Fixed gnomekeyring lib dependencies.
- Fixed Networkmanager and related lib dependencies.
- Fixed gtk label max width issue by setting it to 35.
- NM-openswan was missing support for nm-openswan-auth-dialog.desktop.in.in.
  So added a new nm-openswan-auth-dialog.desktop.in.in, and modified related
  Makefile and configure.ac files.
2013-12-10 17:51:36 -05:00

104 lines
3.6 KiB
Diff

From 9ef10efa0905b22395987d99b26b8d5cbebd03ba Mon Sep 17 00:00:00 2001
From: Avesh Agarwal <avagarwa@redhat.com>
Date: Tue, 10 Dec 2013 15:23:59 -0500
Subject: [PATCH 18/20] Fixed various debug messages.
---
src/nm-openswan-service.c | 25 +++++++++++++------------
1 file changed, 13 insertions(+), 12 deletions(-)
diff --git a/src/nm-openswan-service.c b/src/nm-openswan-service.c
index f205c1d..fffd020 100644
--- a/src/nm-openswan-service.c
+++ b/src/nm-openswan-service.c
@@ -305,12 +305,12 @@ nm_openswan_start_openswan_binary (NMOPENSWANPlugin *plugin, GError **error)
if (!g_spawn_async (NULL, (char **) openswan_argv->pdata, NULL,
G_SPAWN_DO_NOT_REAP_CHILD, NULL, NULL, &pid, error)) {
g_ptr_array_free (openswan_argv, TRUE);
- g_warning ("openswan ipsec failed to start. error: '%s'", (*error)->message);
+ g_printf ("pluto failed to start. error: '%s'\n", (*error)->message);
return -1;
}
g_ptr_array_free (openswan_argv, TRUE);
- g_message ("openswan: ipsec started with pid %d", pid);
+ g_printf ("ipsec/pluto started with pid %d\n", pid);
NM_OPENSWAN_PLUGIN_GET_PRIVATE (plugin)->pid = pid;
g_child_watch_add(pid, (GChildWatchFunc) pluto_watch_cb, plugin);
@@ -331,20 +331,19 @@ nm_openswan_start_openswan_binary (NMOPENSWANPlugin *plugin, GError **error)
NULL, NULL, error)) {
g_ptr_array_free (openswan_argv, TRUE);
- g_warning ("openswan: ipsec auto failed to start. error: '%s'", (*error)->message);
+ g_printf ("ipsec auto add failed with error: '%s'\n", (*error)->message);
return -1;
}
g_ptr_array_free (openswan_argv, TRUE);
- g_message ("openswan: ipsec auto started with pid %d", pid_auto);
+ if(debug)
+ g_printf ("pluto auto started with pid %d\n", pid_auto);
g_child_watch_add(pid_auto, (GChildWatchFunc) pluto_watch_cb, plugin);
return stdin_fd;
}
-
-
static gint
nm_openswan_start_openswan_connection (NMOPENSWANPlugin *plugin, GError **error)
{
@@ -382,15 +381,17 @@ nm_openswan_start_openswan_connection (NMOPENSWANPlugin *plugin, GError **error)
NULL, NULL, error)) {
g_ptr_array_free (openswan_argv, TRUE);
- g_warning ("openswan: ipsec auto connection failed to start. error: '%s'", (*error)->message);
+ g_printf ("ipsec/pluto auto connection failed to start. error: '%s'\n", (*error)->message);
return -1;
}
g_ptr_array_free (openswan_argv, TRUE);
- sleep(3);
+ if(debug)
+ g_printf ("pluto up started with pid %d\n", pid);
+
g_child_watch_add(pid, (GChildWatchFunc) pluto_watch_cb, plugin);
- g_message ("openswan: ipsec auto connection started with pid %d", pid);
+ //sleep(3);
return stdin_fd;
}
@@ -408,7 +409,7 @@ write_config_option (int fd, const char *format, ...)
g_print ("Config: %s", string);
if ( write (fd, string, strlen (string)) == -1) {
- g_warning ("nm-openswan: error in write_config_option");
+ g_printf ("nm-openswan: error in write_config_option\n");
}
g_free (string);
@@ -521,7 +522,7 @@ write_one_property (const char *key, const char *value, gpointer user_data)
/* ignored */
} else {
/* Just ignore unknown properties */
- g_warning ("Don't know how to write property '%s' with type %s",
+ g_printf ("Don't know how to write property '%s' with type %s\n",
(char *) key, g_type_name (type));
}
}
@@ -676,7 +677,7 @@ real_connect (NMVPNPlugin *plugin,
if (openswan_fd < 0)
goto out;
- write_config_option (openswan_fd, "%s", nm_setting_vpn_get_secret (s_vpn, NM_OPENSWAN_XAUTH_PASSWORD));
+ write_config_option (openswan_fd, "%s", nm_setting_vpn_get_secret (s_vpn, NM_OPENSWAN_XAUTH_PASSWORD));
close(openswan_fd);
openswan_fd=-1;
--
1.8.3.1