08f137fc11
- Fixed 926225 - Fixed dependency to libreswan. - Created a new sub package NetworkManager-openswan-gnome - Various other spec file fixes. - Additional code changes are as follows: - Fixed an issue where proper network stack is not loaded unless _stackmanager is run before starting pluto daemon service. - Fixed the termination operation of pluto daemon to comply with libreswan changes. - Fixed various debug messages. - Fixed initiation of pluto daemon by this plugin to reflect the changes in libreaswan. - Fixed defaults values for more parameters to help the VPN connection stay more reliable. - Rewrote pluto watch API which watches the pluto process for its status. Fixed memory leak issues as not all child processes were reaped correctly. Also g_spwan_close_pid was not being called after children were reaped. Also modified debugs and added more to help with debugging in the future. - Fixed an issue where nm-openswan service is searching for ipsec binary in both /sbin and /usr/sbin leading to same operation twice, as /sbin is just symlink to /usr/sbin, so removed /sbin from the search paths. - Fixed some libreswan related macro changes. - Fixed netmask issue when sending IP information to the nm openswan plugin service. - Fixed the current code as it does not set the default route field NM_VPN_PLUGIN_IP4_CONFIG_NEVER_DEFAULT when sending VPN information to nm-openswan plugin. This fix sets the field to TRUE. - Fixed some issues found by coverity scan. - Fixed an issue where writing configuration on stdin should not end with \n as it gives error. It used to work previously, but not with latest NetworkManager versions. - libreswan related fixes, as some macros have been modified after forking to libreswan from openswan. - openswan/libreswan does not provide tun0 interface, so fixed the code where it sends tun0 interface. - Fix prcoessing of nm-openswan-dialog.ui file and added more error notifications. - Fixed dead code based on coverity scan. - Fixed gnomekeyring lib dependencies. - Fixed Networkmanager and related lib dependencies. - Fixed gtk label max width issue by setting it to 35. - NM-openswan was missing support for nm-openswan-auth-dialog.desktop.in.in. So added a new nm-openswan-auth-dialog.desktop.in.in, and modified related Makefile and configure.ac files.
28 lines
792 B
Diff
28 lines
792 B
Diff
From fdd136923c77b71080f2ccb2c0fe0a5234e73c1c Mon Sep 17 00:00:00 2001
|
|
From: Avesh Agarwal <avagarwa@redhat.com>
|
|
Date: Tue, 10 Dec 2013 14:47:14 -0500
|
|
Subject: [PATCH 14/20] Fixed an issue where nm-openswan service is searching
|
|
for ipsec binary in both /sbin and /usr/sbin leading to same operation twice,
|
|
as /sbin is just symlink to /usr/sbin, so removed /sbin from the search
|
|
paths.
|
|
|
|
---
|
|
src/nm-openswan-service.c | 1 -
|
|
1 file changed, 1 deletion(-)
|
|
|
|
diff --git a/src/nm-openswan-service.c b/src/nm-openswan-service.c
|
|
index d59c58f..7f1a9c9 100644
|
|
--- a/src/nm-openswan-service.c
|
|
+++ b/src/nm-openswan-service.c
|
|
@@ -57,7 +57,6 @@ typedef struct {
|
|
static const char *openswan_binary_paths[] =
|
|
{
|
|
"/usr/sbin/ipsec",
|
|
- "/sbin/ipsec",
|
|
"/usr/local/sbin/ipsec",
|
|
NULL
|
|
};
|
|
--
|
|
1.8.3.1
|
|
|