08f137fc11
- Fixed 926225 - Fixed dependency to libreswan. - Created a new sub package NetworkManager-openswan-gnome - Various other spec file fixes. - Additional code changes are as follows: - Fixed an issue where proper network stack is not loaded unless _stackmanager is run before starting pluto daemon service. - Fixed the termination operation of pluto daemon to comply with libreswan changes. - Fixed various debug messages. - Fixed initiation of pluto daemon by this plugin to reflect the changes in libreaswan. - Fixed defaults values for more parameters to help the VPN connection stay more reliable. - Rewrote pluto watch API which watches the pluto process for its status. Fixed memory leak issues as not all child processes were reaped correctly. Also g_spwan_close_pid was not being called after children were reaped. Also modified debugs and added more to help with debugging in the future. - Fixed an issue where nm-openswan service is searching for ipsec binary in both /sbin and /usr/sbin leading to same operation twice, as /sbin is just symlink to /usr/sbin, so removed /sbin from the search paths. - Fixed some libreswan related macro changes. - Fixed netmask issue when sending IP information to the nm openswan plugin service. - Fixed the current code as it does not set the default route field NM_VPN_PLUGIN_IP4_CONFIG_NEVER_DEFAULT when sending VPN information to nm-openswan plugin. This fix sets the field to TRUE. - Fixed some issues found by coverity scan. - Fixed an issue where writing configuration on stdin should not end with \n as it gives error. It used to work previously, but not with latest NetworkManager versions. - libreswan related fixes, as some macros have been modified after forking to libreswan from openswan. - openswan/libreswan does not provide tun0 interface, so fixed the code where it sends tun0 interface. - Fix prcoessing of nm-openswan-dialog.ui file and added more error notifications. - Fixed dead code based on coverity scan. - Fixed gnomekeyring lib dependencies. - Fixed Networkmanager and related lib dependencies. - Fixed gtk label max width issue by setting it to 35. - NM-openswan was missing support for nm-openswan-auth-dialog.desktop.in.in. So added a new nm-openswan-auth-dialog.desktop.in.in, and modified related Makefile and configure.ac files.
56 lines
1.7 KiB
Diff
56 lines
1.7 KiB
Diff
From 9a5e803eac0f3bd30517a4e615271f0f1d97ca02 Mon Sep 17 00:00:00 2001
|
|
From: Avesh Agarwal <avagarwa@redhat.com>
|
|
Date: Tue, 10 Dec 2013 14:37:22 -0500
|
|
Subject: [PATCH 11/20] Fixed the current code as it does not set the default
|
|
route field NM_VPN_PLUGIN_IP4_CONFIG_NEVER_DEFAULT when sending VPN
|
|
information to nm-openswan plugin. This fix sets the field to TRUE.
|
|
|
|
---
|
|
src/nm-openswan-service-helper.c | 16 ++++++++++++++++
|
|
1 file changed, 16 insertions(+)
|
|
|
|
diff --git a/src/nm-openswan-service-helper.c b/src/nm-openswan-service-helper.c
|
|
index e148b26..59d79f9 100644
|
|
--- a/src/nm-openswan-service-helper.c
|
|
+++ b/src/nm-openswan-service-helper.c
|
|
@@ -121,6 +121,17 @@ str_to_gvalue (const char *str, gboolean try_convert)
|
|
}
|
|
|
|
static GValue *
|
|
+bool_to_gvalue (gboolean b)
|
|
+{
|
|
+ GValue *val;
|
|
+
|
|
+ val = g_slice_new0 (GValue);
|
|
+ g_value_init (val, G_TYPE_BOOLEAN);
|
|
+ g_value_set_boolean (val, b);
|
|
+ return val;
|
|
+}
|
|
+
|
|
+static GValue *
|
|
uint_to_gvalue (guint32 num)
|
|
{
|
|
GValue *val;
|
|
@@ -252,6 +263,7 @@ main (int argc, char *argv[])
|
|
/* Tunnel device */
|
|
//val = str_to_gvalue (getenv ("TUNDEV"), FALSE);
|
|
//val = str_to_gvalue ("tun0", FALSE);
|
|
+ val = str_to_gvalue ("lo", FALSE);
|
|
if (val)
|
|
g_hash_table_insert (config, NM_VPN_PLUGIN_IP4_CONFIG_TUNDEV, val);
|
|
else
|
|
@@ -302,6 +314,10 @@ main (int argc, char *argv[])
|
|
if (val)
|
|
g_hash_table_insert (config, NM_VPN_PLUGIN_IP4_CONFIG_BANNER, val);
|
|
|
|
+ /* Routes */
|
|
+ /* No default route*/
|
|
+ g_hash_table_insert (config, NM_VPN_PLUGIN_IP4_CONFIG_NEVER_DEFAULT,
|
|
+ bool_to_gvalue (TRUE));
|
|
|
|
/* Send the config info to nm-openswan-service */
|
|
send_ip4_config (connection, config);
|
|
--
|
|
1.8.3.1
|
|
|