08f137fc11
- Fixed 926225 - Fixed dependency to libreswan. - Created a new sub package NetworkManager-openswan-gnome - Various other spec file fixes. - Additional code changes are as follows: - Fixed an issue where proper network stack is not loaded unless _stackmanager is run before starting pluto daemon service. - Fixed the termination operation of pluto daemon to comply with libreswan changes. - Fixed various debug messages. - Fixed initiation of pluto daemon by this plugin to reflect the changes in libreaswan. - Fixed defaults values for more parameters to help the VPN connection stay more reliable. - Rewrote pluto watch API which watches the pluto process for its status. Fixed memory leak issues as not all child processes were reaped correctly. Also g_spwan_close_pid was not being called after children were reaped. Also modified debugs and added more to help with debugging in the future. - Fixed an issue where nm-openswan service is searching for ipsec binary in both /sbin and /usr/sbin leading to same operation twice, as /sbin is just symlink to /usr/sbin, so removed /sbin from the search paths. - Fixed some libreswan related macro changes. - Fixed netmask issue when sending IP information to the nm openswan plugin service. - Fixed the current code as it does not set the default route field NM_VPN_PLUGIN_IP4_CONFIG_NEVER_DEFAULT when sending VPN information to nm-openswan plugin. This fix sets the field to TRUE. - Fixed some issues found by coverity scan. - Fixed an issue where writing configuration on stdin should not end with \n as it gives error. It used to work previously, but not with latest NetworkManager versions. - libreswan related fixes, as some macros have been modified after forking to libreswan from openswan. - openswan/libreswan does not provide tun0 interface, so fixed the code where it sends tun0 interface. - Fix prcoessing of nm-openswan-dialog.ui file and added more error notifications. - Fixed dead code based on coverity scan. - Fixed gnomekeyring lib dependencies. - Fixed Networkmanager and related lib dependencies. - Fixed gtk label max width issue by setting it to 35. - NM-openswan was missing support for nm-openswan-auth-dialog.desktop.in.in. So added a new nm-openswan-auth-dialog.desktop.in.in, and modified related Makefile and configure.ac files.
53 lines
1.6 KiB
Diff
53 lines
1.6 KiB
Diff
From 571c3af579c5753b82aab522486b6af45b27d7d8 Mon Sep 17 00:00:00 2001
|
|
From: Avesh Agarwal <avagarwa@redhat.com>
|
|
Date: Tue, 10 Dec 2013 14:01:00 -0500
|
|
Subject: [PATCH 08/20] libreswan related fixes, as some macros have been
|
|
modified after forking to libreswan from openswan.
|
|
|
|
---
|
|
src/nm-openswan-service-helper.c | 7 ++++---
|
|
1 file changed, 4 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/src/nm-openswan-service-helper.c b/src/nm-openswan-service-helper.c
|
|
index 35cd9d9..07bc576 100644
|
|
--- a/src/nm-openswan-service-helper.c
|
|
+++ b/src/nm-openswan-service-helper.c
|
|
@@ -210,6 +210,7 @@ main (int argc, char *argv[])
|
|
//long int mtu = 1412;
|
|
char nmask[16]="255.255.255.255";
|
|
|
|
+
|
|
#if !GLIB_CHECK_VERSION (2, 35, 0)
|
|
g_type_init ();
|
|
#endif
|
|
@@ -217,7 +218,7 @@ main (int argc, char *argv[])
|
|
/* openswan gives us a "reason" code. If we are given one,
|
|
* don't proceed unless its "connect".
|
|
*/
|
|
- tmp = getenv ("openswan_reason");
|
|
+ tmp = getenv ("libreswan_reason");
|
|
if (tmp && strcmp (tmp, "connect") != 0)
|
|
exit (0);
|
|
|
|
@@ -287,7 +288,7 @@ main (int argc, char *argv[])
|
|
//#endif
|
|
|
|
/* DNS */
|
|
- val = addr_list_to_gvalue (getenv ("PLUTO_CISCO_DNS_INFO"));
|
|
+ val = addr_list_to_gvalue (getenv ("PLUTO_PEER_DNS_INFO"));
|
|
if (val)
|
|
g_hash_table_insert (config, NM_VPN_PLUGIN_IP4_CONFIG_DNS, val);
|
|
|
|
@@ -299,7 +300,7 @@ main (int argc, char *argv[])
|
|
#endif
|
|
|
|
/* Default domain */
|
|
- val = str_to_gvalue (getenv ("PLUTO_CISCO_DOMAIN_INFO"), TRUE);
|
|
+ val = str_to_gvalue (getenv ("PLUTO_PEER_DOMAIN_INFO"), TRUE);
|
|
if (val)
|
|
g_hash_table_insert (config, NM_VPN_PLUGIN_IP4_CONFIG_DOMAIN, val);
|
|
|
|
--
|
|
1.8.3.1
|
|
|