08f137fc11
- Fixed 926225 - Fixed dependency to libreswan. - Created a new sub package NetworkManager-openswan-gnome - Various other spec file fixes. - Additional code changes are as follows: - Fixed an issue where proper network stack is not loaded unless _stackmanager is run before starting pluto daemon service. - Fixed the termination operation of pluto daemon to comply with libreswan changes. - Fixed various debug messages. - Fixed initiation of pluto daemon by this plugin to reflect the changes in libreaswan. - Fixed defaults values for more parameters to help the VPN connection stay more reliable. - Rewrote pluto watch API which watches the pluto process for its status. Fixed memory leak issues as not all child processes were reaped correctly. Also g_spwan_close_pid was not being called after children were reaped. Also modified debugs and added more to help with debugging in the future. - Fixed an issue where nm-openswan service is searching for ipsec binary in both /sbin and /usr/sbin leading to same operation twice, as /sbin is just symlink to /usr/sbin, so removed /sbin from the search paths. - Fixed some libreswan related macro changes. - Fixed netmask issue when sending IP information to the nm openswan plugin service. - Fixed the current code as it does not set the default route field NM_VPN_PLUGIN_IP4_CONFIG_NEVER_DEFAULT when sending VPN information to nm-openswan plugin. This fix sets the field to TRUE. - Fixed some issues found by coverity scan. - Fixed an issue where writing configuration on stdin should not end with \n as it gives error. It used to work previously, but not with latest NetworkManager versions. - libreswan related fixes, as some macros have been modified after forking to libreswan from openswan. - openswan/libreswan does not provide tun0 interface, so fixed the code where it sends tun0 interface. - Fix prcoessing of nm-openswan-dialog.ui file and added more error notifications. - Fixed dead code based on coverity scan. - Fixed gnomekeyring lib dependencies. - Fixed Networkmanager and related lib dependencies. - Fixed gtk label max width issue by setting it to 35. - NM-openswan was missing support for nm-openswan-auth-dialog.desktop.in.in. So added a new nm-openswan-auth-dialog.desktop.in.in, and modified related Makefile and configure.ac files.
68 lines
2.0 KiB
Diff
68 lines
2.0 KiB
Diff
From ce807219123614d8496b29b591b8147dc190db54 Mon Sep 17 00:00:00 2001
|
|
From: Avesh Agarwal <avagarwa@redhat.com>
|
|
Date: Tue, 10 Dec 2013 13:38:23 -0500
|
|
Subject: [PATCH 01/20] NM-openswan was missing support for
|
|
nm-openswan-auth-dialog.desktop.in.in. So added a new
|
|
nm-openswan-auth-dialog.desktop.in.in, and modified related Makefile and
|
|
configure.ac files.
|
|
|
|
---
|
|
auth-dialog/Makefile.am | 15 ++++++++++++++-
|
|
auth-dialog/nm-openswan-auth-dialog.desktop.in.in | 7 +++++++
|
|
configure.ac | 1 +
|
|
3 files changed, 22 insertions(+), 1 deletion(-)
|
|
create mode 100644 auth-dialog/nm-openswan-auth-dialog.desktop.in.in
|
|
|
|
diff --git a/auth-dialog/Makefile.am b/auth-dialog/Makefile.am
|
|
index 4b5a01d..d1e8711 100644
|
|
--- a/auth-dialog/Makefile.am
|
|
+++ b/auth-dialog/Makefile.am
|
|
@@ -22,5 +22,18 @@ nm_openswan_auth_dialog_LDADD = \
|
|
$(GTK_LIBS) \
|
|
$(GNOMEKEYRING_LIBS)
|
|
|
|
-CLEANFILES = *~
|
|
+@INTLTOOL_DESKTOP_RULE@
|
|
+desktopdir = $(datadir)/applications
|
|
+desktop_in_in_files = nm-openswan-auth-dialog.desktop.in.in
|
|
+desktop_in_files = nm-openswan-auth-dialog.desktop.in
|
|
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
|
|
|
|
+EXTRA_DIST = \
|
|
+ $(desktop_in_in_files)
|
|
+
|
|
+CLEANFILES = \
|
|
+ *~ \
|
|
+ $(desktop_DATA)
|
|
+
|
|
+DISTCLEANFILES = \
|
|
+ $(desktop_in_files)
|
|
diff --git a/auth-dialog/nm-openswan-auth-dialog.desktop.in.in b/auth-dialog/nm-openswan-auth-dialog.desktop.in.in
|
|
new file mode 100644
|
|
index 0000000..9c91b6b
|
|
--- /dev/null
|
|
+++ b/auth-dialog/nm-openswan-auth-dialog.desktop.in.in
|
|
@@ -0,0 +1,7 @@
|
|
+[Desktop Entry]
|
|
+_Name=Network
|
|
+_Comment=Request VPN authentication
|
|
+Exec=@LIBEXECDIR@/nm-openswan-auth-dialog
|
|
+Terminal=false
|
|
+Type=Application
|
|
+NoDisplay=true
|
|
diff --git a/configure.ac b/configure.ac
|
|
index b214ef7..10af655 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -114,6 +114,7 @@ AC_CONFIG_FILES([
|
|
Makefile
|
|
src/Makefile
|
|
auth-dialog/Makefile
|
|
+auth-dialog/nm-openswan-auth-dialog.desktop.in
|
|
properties/Makefile
|
|
po/Makefile.in
|
|
])
|
|
--
|
|
1.8.3.1
|
|
|