Update to latest stable release
(and fix _hardened_build macro) (dcbw)
This commit is contained in:
parent
538af3450c
commit
73de16b924
1
.gitignore
vendored
1
.gitignore
vendored
@ -27,3 +27,4 @@ ModemManager-0.4.git20100720.tar.bz2
|
||||
/ModemManager-0.7.991.git20130607.tar.bz2
|
||||
/ModemManager-0.7.991.git20130710.tar.xz
|
||||
/ModemManager-1.0.1.git20130723.tar.xz
|
||||
/ModemManager-1.2.0.tar.xz
|
||||
|
@ -1,24 +1,21 @@
|
||||
%global snapshot .git20130913
|
||||
|
||||
%global glib2_version 2.32
|
||||
%global systemd_dir %{_prefix}/lib/systemd/system
|
||||
|
||||
%global hardened_build 1
|
||||
%global _hardened_build 1
|
||||
|
||||
Summary: Mobile broadband modem management service
|
||||
Name: ModemManager
|
||||
Version: 1.1.0
|
||||
Release: 2%{snapshot}%{?dist}
|
||||
Version: 1.2.0
|
||||
Release: 1%{?dist}
|
||||
#
|
||||
# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
|
||||
# tarball built with:
|
||||
# ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
|
||||
# make distcheck
|
||||
# Source from http://freedesktop.org/software/ModemManager/
|
||||
#
|
||||
Source: %{name}-%{version}%{snapshot}.tar.xz
|
||||
Source: %{name}-%{version}.tar.xz
|
||||
License: GPLv2+
|
||||
Group: System Environment/Base
|
||||
|
||||
URL: http://www.gnome.org/projects/NetworkManager/
|
||||
URL: https://wiki.gnome.org/Projects/NetworkManager
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
Requires: glib2 >= %{glib2_version}
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
@ -89,9 +86,10 @@ intltoolize --force
|
||||
%configure \
|
||||
--enable-more-warnings=error \
|
||||
--with-udev-base-dir=%{_prefix}/lib/udev \
|
||||
--enable-gtk-doc=yes \
|
||||
--enable-gtk-doc \
|
||||
--with-qmi=yes \
|
||||
--with-mbim=yes \
|
||||
--with-newest-qmi-commands \
|
||||
--disable-static \
|
||||
--with-polkit=no \
|
||||
--with-dist-version=%{version}-%{release}
|
||||
@ -141,6 +139,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{systemd_dir}/ModemManager.service
|
||||
%{_datadir}/icons/hicolor/22x22/apps/*.png
|
||||
%{_mandir}/man8/*
|
||||
%{_datadir}/locale/*/LC_MESSAGES/ModemManager.mo
|
||||
|
||||
%files devel
|
||||
%{_includedir}/ModemManager/*.h
|
||||
@ -165,6 +164,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_datadir}/vala/vapi/libmm-glib.*
|
||||
|
||||
%changelog
|
||||
* Sat Feb 1 2014 poma <poma@gmail.com> - 1.2.0-1
|
||||
- Update to 1.2.0 release
|
||||
|
||||
* Fri Sep 13 2013 Dan Williams <dcbw@redhat.com> - 1.1.0-2.git20130913
|
||||
- Build with MBIM support
|
||||
- Enable Vala bindings
|
||||
|
@ -1,12 +1,11 @@
|
||||
diff -up ModemManager-0.4.998/src/tests/Makefile.am.foo ModemManager-0.4.998/src/tests/Makefile.am
|
||||
--- ModemManager-0.4.998/src/tests/Makefile.am.foo 2011-07-06 17:59:53.711343366 -0500
|
||||
+++ ModemManager-0.4.998/src/tests/Makefile.am 2011-07-06 18:00:08.971152593 -0500
|
||||
@@ -45,7 +45,6 @@ if WITH_TESTS
|
||||
@@ -3,7 +3,6 @@
|
||||
noinst_PROGRAMS = \
|
||||
test-modem-helpers \
|
||||
test-charsets \
|
||||
- test-qcdm-serial-port \
|
||||
test-at-serial-port \
|
||||
test-sms-part
|
||||
|
||||
|
||||
test-sms-part-3gpp \
|
||||
test-sms-part-cdma
|
||||
|
Loading…
Reference in New Issue
Block a user