New snapshot, specfile cleanups and fixes for latest snapshot
This commit is contained in:
parent
75ff58e256
commit
4f3603a278
1
.gitignore
vendored
1
.gitignore
vendored
@ -25,3 +25,4 @@ ModemManager-0.4.git20100720.tar.bz2
|
|||||||
/ModemManager-0.5.999.tar.bz2
|
/ModemManager-0.5.999.tar.bz2
|
||||||
/ModemManager-0.7.990.git20130515.tar.bz2
|
/ModemManager-0.7.990.git20130515.tar.bz2
|
||||||
/ModemManager-0.7.991.git20130607.tar.bz2
|
/ModemManager-0.7.991.git20130607.tar.bz2
|
||||||
|
/ModemManager-0.7.991.git20130710.tar.xz
|
||||||
|
@ -1,5 +1,4 @@
|
|||||||
%global snapshot .git20130607
|
%global snapshot .git20130710
|
||||||
%global ppp_version 2.4.5
|
|
||||||
%global glib2_version 2.32
|
%global glib2_version 2.32
|
||||||
%global systemd_dir %{_prefix}/lib/systemd/system
|
%global systemd_dir %{_prefix}/lib/systemd/system
|
||||||
|
|
||||||
@ -8,14 +7,14 @@
|
|||||||
Summary: Mobile broadband modem management service
|
Summary: Mobile broadband modem management service
|
||||||
Name: ModemManager
|
Name: ModemManager
|
||||||
Version: 0.7.991
|
Version: 0.7.991
|
||||||
Release: 1%{snapshot}%{?dist}
|
Release: 2%{snapshot}%{?dist}
|
||||||
#
|
#
|
||||||
# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
|
# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
|
||||||
# tarball built with:
|
# tarball built with:
|
||||||
# ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
|
# ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
|
||||||
# make distcheck
|
# make distcheck
|
||||||
#
|
#
|
||||||
Source: %{name}-%{version}%{snapshot}.tar.bz2
|
Source: %{name}-%{version}%{snapshot}.tar.xz
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
|
|
||||||
@ -25,8 +24,6 @@ Requires: glib2 >= %{glib2_version}
|
|||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
BuildRequires: libgudev1-devel >= 143
|
BuildRequires: libgudev1-devel >= 143
|
||||||
BuildRequires: libqmi-devel >= 1.3
|
BuildRequires: libqmi-devel >= 1.3
|
||||||
BuildRequires: ppp = %{ppp_version}
|
|
||||||
BuildRequires: ppp-devel = %{ppp_version}
|
|
||||||
BuildRequires: automake autoconf intltool libtool
|
BuildRequires: automake autoconf intltool libtool
|
||||||
BuildRequires: intltool
|
BuildRequires: intltool
|
||||||
BuildRequires: dia libxslt gtk-doc
|
BuildRequires: dia libxslt gtk-doc
|
||||||
@ -79,12 +76,10 @@ autoreconf -i --force
|
|||||||
intltoolize --force
|
intltoolize --force
|
||||||
%configure \
|
%configure \
|
||||||
--enable-more-warnings=error \
|
--enable-more-warnings=error \
|
||||||
--with-udev-base-dir=/lib/udev \
|
--with-udev-base-dir=%{_libdir}/udev \
|
||||||
--with-tests=yes \
|
|
||||||
--enable-gtk-doc=yes \
|
--enable-gtk-doc=yes \
|
||||||
--with-libqmi=yes \
|
--with-qmi=yes \
|
||||||
--disable-static \
|
--disable-static \
|
||||||
--with-pppd-plugin-dir=%{_libdir}/pppd/%{ppp_version} \
|
|
||||||
--with-polkit=no \
|
--with-polkit=no \
|
||||||
--with-dist-version=%{version}-%{release}
|
--with-dist-version=%{version}-%{release}
|
||||||
|
|
||||||
@ -98,8 +93,6 @@ make install DESTDIR=$RPM_BUILD_ROOT
|
|||||||
|
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
|
rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.la
|
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
|
|
||||||
|
|
||||||
%post
|
%post
|
||||||
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
|
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
|
||||||
@ -130,7 +123,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%attr(0755,root,root) %{_bindir}/mmcli
|
%attr(0755,root,root) %{_bindir}/mmcli
|
||||||
%dir %{_libdir}/%{name}
|
%dir %{_libdir}/%{name}
|
||||||
%attr(0755,root,root) %{_libdir}/%{name}/*.so*
|
%attr(0755,root,root) %{_libdir}/%{name}/*.so*
|
||||||
/lib/udev/rules.d/*
|
%{_libdir}/udev/rules.d/*
|
||||||
%{_datadir}/dbus-1/interfaces/*.xml
|
%{_datadir}/dbus-1/interfaces/*.xml
|
||||||
%{systemd_dir}/ModemManager.service
|
%{systemd_dir}/ModemManager.service
|
||||||
%{_datadir}/icons/hicolor/22x22/apps/*.png
|
%{_datadir}/icons/hicolor/22x22/apps/*.png
|
||||||
@ -154,6 +147,14 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%{_datadir}/gtk-doc/html/libmm-glib/*
|
%{_datadir}/gtk-doc/html/libmm-glib/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 10 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-2.git20130710
|
||||||
|
- Handle PNP connected devices
|
||||||
|
- Fall back to AT for messaging if QMI modem doesn't support the WMS service
|
||||||
|
- Fix IPv6 bearer creation for HSO devices
|
||||||
|
- Fix detection of supported modes on Icera-based modems
|
||||||
|
- Fix handling of some Icera-based modems with limited capability ports
|
||||||
|
- Add support for Olivetti Olicard 200
|
||||||
|
|
||||||
* Fri Jun 7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
|
* Fri Jun 7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
|
||||||
- Update to 0.7.991 snapshot
|
- Update to 0.7.991 snapshot
|
||||||
- Fix SMS validity parsing
|
- Fix SMS validity parsing
|
||||||
@ -227,7 +228,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.998-2.git20110706
|
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.998-2.git20110706
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
* Wed Jul 7 2011 Dan Williams <dcbw@redhat.com> - 0.4.998-1.git20110706
|
* Thu Jul 7 2011 Dan Williams <dcbw@redhat.com> - 0.4.998-1.git20110706
|
||||||
- Update to 0.5-beta4
|
- Update to 0.5-beta4
|
||||||
- gsm: various USSD fixes
|
- gsm: various USSD fixes
|
||||||
- samsung: support for Y3400 module and various other fixes
|
- samsung: support for Y3400 module and various other fixes
|
||||||
|
@ -2,11 +2,11 @@ diff -up ModemManager-0.4.998/src/tests/Makefile.am.foo ModemManager-0.4.998/src
|
|||||||
--- ModemManager-0.4.998/src/tests/Makefile.am.foo 2011-07-06 17:59:53.711343366 -0500
|
--- ModemManager-0.4.998/src/tests/Makefile.am.foo 2011-07-06 17:59:53.711343366 -0500
|
||||||
+++ ModemManager-0.4.998/src/tests/Makefile.am 2011-07-06 18:00:08.971152593 -0500
|
+++ ModemManager-0.4.998/src/tests/Makefile.am 2011-07-06 18:00:08.971152593 -0500
|
||||||
@@ -45,7 +45,6 @@ if WITH_TESTS
|
@@ -45,7 +45,6 @@ if WITH_TESTS
|
||||||
check-local: $(noinst_PROGRAMS)
|
noinst_PROGRAMS = \
|
||||||
$(abs_builddir)/test-modem-helpers
|
test-modem-helpers \
|
||||||
$(abs_builddir)/test-charsets
|
test-charsets \
|
||||||
- $(abs_builddir)/test-qcdm-serial-port
|
- test-qcdm-serial-port \
|
||||||
$(abs_builddir)/test-sms-part
|
test-at-serial-port \
|
||||||
if WITH_QMI
|
test-sms-part
|
||||||
$(abs_builddir)/test-modem-helpers-qmi
|
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user