0.21.2, enable zlib support.
This commit is contained in:
parent
f5147d66aa
commit
d7e52c7b1b
1
.gitignore
vendored
1
.gitignore
vendored
@ -84,3 +84,4 @@ LibRaw-0.9.1.tar.gz
|
||||
/0.21.0.tar.gz
|
||||
/0.21.1.tar.gz
|
||||
/LibRaw-0.21.1.tar.gz
|
||||
/LibRaw-0.21.2.tar.gz
|
||||
|
@ -1,22 +0,0 @@
|
||||
From 9ab70f6dca19229cb5caad7cc31af4e7501bac93 Mon Sep 17 00:00:00 2001
|
||||
From: Alex Tutubalin <lexa@lexa.ru>
|
||||
Date: Sat, 14 Jan 2023 18:32:59 +0300
|
||||
Subject: [PATCH] do not set shrink flag for 3/4 component images
|
||||
|
||||
---
|
||||
src/preprocessing/raw2image.cpp | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/preprocessing/raw2image.cpp b/src/preprocessing/raw2image.cpp
|
||||
index e65e2ad7..702cf290 100644
|
||||
--- a/src/preprocessing/raw2image.cpp
|
||||
+++ b/src/preprocessing/raw2image.cpp
|
||||
@@ -43,6 +43,8 @@ void LibRaw::raw2image_start()
|
||||
|
||||
// adjust for half mode!
|
||||
IO.shrink =
|
||||
+ !imgdata.rawdata.color4_image && !imgdata.rawdata.color3_image &&
|
||||
+ !imgdata.rawdata.float4_image && !imgdata.rawdata.float3_image &&
|
||||
P1.filters &&
|
||||
(O.half_size || ((O.threshold || O.aber[0] != 1 || O.aber[2] != 1)));
|
||||
|
12
LibRaw.spec
12
LibRaw.spec
@ -2,18 +2,18 @@
|
||||
|
||||
Summary: Library for reading RAW files obtained from digital photo cameras
|
||||
Name: LibRaw
|
||||
Version: 0.21.1
|
||||
Release: 7%{?dist}
|
||||
Version: 0.21.2
|
||||
Release: 1%{?dist}
|
||||
License: BSD-3-Clause and (CDDL-1.0 or LGPL-2.1-only)
|
||||
URL: https://www.libraw.org
|
||||
Source0: %{url}/data/%{name}-%{version}.tar.gz
|
||||
Patch0: LibRaw-pkgconfig.patch
|
||||
Patch1: 9ab70f6dca19229cb5caad7cc31af4e7501bac93.patch
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: pkgconfig(lcms2)
|
||||
BuildRequires: pkgconfig(jasper)
|
||||
BuildRequires: pkgconfig(libjpeg)
|
||||
BuildRequires: pkgconfig(zlib)
|
||||
BuildRequires: autoconf automake libtool
|
||||
BuildRequires: make
|
||||
|
||||
@ -60,7 +60,8 @@ autoreconf -if
|
||||
--enable-jasper \
|
||||
--enable-jpeg \
|
||||
--enable-lcms \
|
||||
--enable-openmp
|
||||
--enable-openmp \
|
||||
--enable-zlib
|
||||
|
||||
# https://fedoraproject.org/wiki/Packaging:Guidelines#Beware_of_Rpath
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
@ -107,6 +108,9 @@ rm -fv %{buildroot}%{_libdir}/lib*.la
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Dec 21 2023 Gwyn Ciesla <gwync@protonmail.com> - 0.21.2
|
||||
- 0.21.2, enable zlib support.
|
||||
|
||||
* Tue Nov 28 2023 Orion Poplawski <orion@nwra.com> - 0.21.1-7
|
||||
- Rebuild for jasper 4.1
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (LibRaw-0.21.1.tar.gz) = 8d11df0be2af5fd8a8251f150ccd59103319606f52effff541ee43e97ceb64f1a00a02bba7b730aedd0c1c705c1e465793c8a2a52769712c1102af7f5534dd5d
|
||||
SHA512 (LibRaw-0.21.2.tar.gz) = ba7839d8eb5f999982c7b89f89f63387d7fee82054d7edcc2698924e268559b561230e329a0c669bd6f7c075983da6c054a6d63fad49ab3c1e2e9edc653b2bae
|
||||
|
Loading…
Reference in New Issue
Block a user