0.18.7, with patch.
This commit is contained in:
parent
ca40c06e76
commit
be7395d335
3
.gitignore
vendored
3
.gitignore
vendored
@ -60,3 +60,6 @@ LibRaw-0.9.1.tar.gz
|
|||||||
/LibRaw-0.18.6.tar.gz
|
/LibRaw-0.18.6.tar.gz
|
||||||
/LibRaw-demosaic-pack-GPL2-0.18.6.tar.gz
|
/LibRaw-demosaic-pack-GPL2-0.18.6.tar.gz
|
||||||
/LibRaw-demosaic-pack-GPL3-0.18.6.tar.gz
|
/LibRaw-demosaic-pack-GPL3-0.18.6.tar.gz
|
||||||
|
/LibRaw-0.18.7.tar.gz
|
||||||
|
/LibRaw-demosaic-pack-GPL2-0.18.7.tar.gz
|
||||||
|
/LibRaw-demosaic-pack-GPL3-0.18.7.tar.gz
|
||||||
|
11
LibRaw-0.18.7-ambiguous.patch
Normal file
11
LibRaw-0.18.7-ambiguous.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- internal/dcraw_common.cpp~ 2018-01-18 23:57:03.000000000 -0600
|
||||||
|
+++ internal/dcraw_common.cpp 2018-01-19 11:50:19.746347270 -0600
|
||||||
|
@@ -6827,7 +6827,7 @@
|
||||||
|
if (table_buf[iLensData+9] &&
|
||||||
|
(fabs(imgdata.lens.makernotes.CurFocal) < 0.1f))
|
||||||
|
imgdata.lens.makernotes.CurFocal =
|
||||||
|
- 10*(table_buf[iLensData+9]>>2) * powf64(4, (table_buf[iLensData+9] & 0x03)-2);
|
||||||
|
+ 10*(table_buf[iLensData+9]>>2) * powf64((float)4, (table_buf[iLensData+9] & 0x03)-2);
|
||||||
|
if (table_buf[iLensData+10] & 0xf0)
|
||||||
|
imgdata.lens.makernotes.MaxAp4CurFocal =
|
||||||
|
powf64(2.0f, (float)((table_buf[iLensData+10] & 0xf0) >>4)/4.0f);
|
12
LibRaw.spec
12
LibRaw.spec
@ -1,6 +1,6 @@
|
|||||||
Summary: Library for reading RAW files obtained from digital photo cameras
|
Summary: Library for reading RAW files obtained from digital photo cameras
|
||||||
Name: LibRaw
|
Name: LibRaw
|
||||||
Version: 0.18.6
|
Version: 0.18.7
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -14,6 +14,7 @@ Source1: http://www.libraw.org/data/%{name}-demosaic-pack-GPL2-%{version}.tar.gz
|
|||||||
Source2: http://www.libraw.org/data/%{name}-demosaic-pack-GPL3-%{version}.tar.gz
|
Source2: http://www.libraw.org/data/%{name}-demosaic-pack-GPL3-%{version}.tar.gz
|
||||||
Patch0: LibRaw-0.6.0-pkgconfig.patch
|
Patch0: LibRaw-0.6.0-pkgconfig.patch
|
||||||
Patch1: LibRaw-0.17.1-CVE-2015-8366-8367.patch
|
Patch1: LibRaw-0.17.1-CVE-2015-8366-8367.patch
|
||||||
|
Patch2: LibRaw-0.18.7-ambiguous.patch
|
||||||
|
|
||||||
Provides: bundled(dcraw) = 9.25
|
Provides: bundled(dcraw) = 9.25
|
||||||
|
|
||||||
@ -55,6 +56,7 @@ LibRaw sample programs
|
|||||||
|
|
||||||
%patch0 -p0 -b .pkgconfig
|
%patch0 -p0 -b .pkgconfig
|
||||||
%patch1 -p1 -b .CVE-2015-8366
|
%patch1 -p1 -b .CVE-2015-8366
|
||||||
|
%patch2 -p0 -b .ambiguous
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --enable-examples=yes --enable-jasper --enable-lcms \
|
%configure --enable-examples=yes --enable-jasper --enable-lcms \
|
||||||
@ -75,17 +77,14 @@ chmod 644 manual/*.html
|
|||||||
make install DESTDIR=%{buildroot}
|
make install DESTDIR=%{buildroot}
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
|
||||||
%doc Changelog.txt
|
%doc Changelog.txt
|
||||||
%license LICENSE.CDDL LICENSE.LGPL COPYRIGHT
|
%license LICENSE.CDDL LICENSE.LGPL COPYRIGHT
|
||||||
%{_libdir}/*.so.*
|
%{_libdir}/*.so.*
|
||||||
|
|
||||||
%files static
|
%files static
|
||||||
%defattr(-,root,root,-)
|
|
||||||
%{_libdir}/*.a
|
%{_libdir}/*.a
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
|
||||||
%doc manual
|
%doc manual
|
||||||
%doc samples
|
%doc samples
|
||||||
%dir %{_includedir}/libraw
|
%dir %{_includedir}/libraw
|
||||||
@ -96,13 +95,16 @@ make install DESTDIR=%{buildroot}
|
|||||||
%exclude %{_docdir}/libraw/*
|
%exclude %{_docdir}/libraw/*
|
||||||
|
|
||||||
%files samples
|
%files samples
|
||||||
%defattr(-,root,root,-)
|
|
||||||
%{_bindir}/*
|
%{_bindir}/*
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
%post -p /sbin/ldconfig
|
||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 19 2018 Gwyn Ciesla <limburgher@gmail.com> - 0.18.7-1
|
||||||
|
- 0.18.7
|
||||||
|
- Patch for ambiguous function call.
|
||||||
|
|
||||||
* Wed Dec 06 2017 Gwyn Ciesla <limburgher@gmail.com> - 0.18.6-1
|
* Wed Dec 06 2017 Gwyn Ciesla <limburgher@gmail.com> - 0.18.6-1
|
||||||
- 0.18.6
|
- 0.18.6
|
||||||
|
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (LibRaw-0.18.6.tar.gz) = ce916a85dcc8ad50a631e9f0e4532d4cc300624b5c78d233531317f33cdf74363cdbcab1fbef3207e89b77bac5be370ef8ff1b806dbb9ae2c4cc0ec607b53e55
|
SHA512 (LibRaw-0.18.7.tar.gz) = 5d906e69427d4f9edff8b3bc24eb85896e037dd98578cf07c668b96f6abd82bc8dd9f937ecbca6472d334c4cf8d8cbc8b07c2c84aba748e22ec55cecc6a4ed78
|
||||||
SHA512 (LibRaw-demosaic-pack-GPL2-0.18.6.tar.gz) = 2a4f317c2594825a7a7ad62eb5592ad3d512026dc49b87123ae4f5a05731912fcf4f3e22169acbc1decf6b79aec34a7250d892b686fe824f8bb2c5afa759c7ae
|
SHA512 (LibRaw-demosaic-pack-GPL2-0.18.7.tar.gz) = 1a967eb06807bc5ce2177d4e13d394e8f4afe15e5ef07d9a49c1a2172f0961cd122a3bfa84fa66a203766d50735adacbffd48ba8deead8a202c3c2a1e4a97ffa
|
||||||
SHA512 (LibRaw-demosaic-pack-GPL3-0.18.6.tar.gz) = 53ad72654f407dbb3b591f2d1ff12de1cb273de5339d598e76260ee2e2c4095d70d3b0f30536cbb7eb06d802bcf6cc76e6b870837a3e4dc640f4a14da020a704
|
SHA512 (LibRaw-demosaic-pack-GPL3-0.18.7.tar.gz) = 347a39d8326e4614b83c2721baa09414738416d405d7db516d155a867902dd85cf51d156705d1fd0bc933802cd3a01cfb1c9da43f4cdff15b7a7253674b91c4a
|
||||||
|
Loading…
Reference in New Issue
Block a user