Build samples.
This commit is contained in:
parent
e3f1689c92
commit
2f49986ed1
@ -1,11 +0,0 @@
|
|||||||
--- internal/dcraw_common.cpp~ 2012-06-27 11:39:05.000000000 -0500
|
|
||||||
+++ internal/dcraw_common.cpp 2013-04-11 07:09:04.594518113 -0500
|
|
||||||
@@ -7277,7 +7277,7 @@
|
|
||||||
if (table[i].t_black) black = (ushort) table[i].t_black;
|
|
||||||
if (table[i].t_maximum) maximum = (ushort) table[i].t_maximum;
|
|
||||||
if (table[i].trans[0]) {
|
|
||||||
- for (j=0; j < 12; j++)
|
|
||||||
+ for (j=0; j < 3; j++)
|
|
||||||
#ifdef LIBRAW_LIBRARY_BUILD
|
|
||||||
imgdata.color.cam_xyz[0][j] =
|
|
||||||
#endif
|
|
@ -1,49 +0,0 @@
|
|||||||
diff -U3 -r LibRaw-0.14.8.orig/Changelog.rus LibRaw-0.14.8/Changelog.rus
|
|
||||||
--- LibRaw-0.14.8.orig/Changelog.rus 2013-05-17 14:54:17.000000000 -0500
|
|
||||||
+++ LibRaw-0.14.8/Changelog.rus 2013-05-31 05:31:45.970607271 -0500
|
|
||||||
@@ -1,4 +1,8 @@
|
|
||||||
-2013-05-21 Alex Tutubalin <lexa@lexa.ru>
|
|
||||||
+2013-05-31 Alex Tutubalin <lexa@lexa.ru>
|
|
||||||
+ * Исправлена ошибка при обработке поврежденных полноцветных
|
|
||||||
+ файлов (sRAW, Foveon)
|
|
||||||
+
|
|
||||||
+2013-05-21 Alex Tutubalin <lexa@lexa.ru>
|
|
||||||
* Исправлена ошибка в коде функции sony_decrypt(), приводившая
|
|
||||||
к неверному чтению камерного баланса белого на камерах Sony
|
|
||||||
если LibRaw была собрана gcc 4.8
|
|
||||||
diff -U3 -r LibRaw-0.14.8.orig/Changelog.txt LibRaw-0.14.8/Changelog.txt
|
|
||||||
--- LibRaw-0.14.8.orig/Changelog.txt 2013-05-17 14:54:17.000000000 -0500
|
|
||||||
+++ LibRaw-0.14.8/Changelog.txt 2013-05-31 05:31:45.970607271 -0500
|
|
||||||
@@ -1,3 +1,7 @@
|
|
||||||
+2013-05-31 Alex Tutubalin <lexa@lexa.ru>
|
|
||||||
+ * Fixed double call to free() on broken legacy-layout images
|
|
||||||
+ (backport from 0.15.x)
|
|
||||||
+
|
|
||||||
2013-05-21 Alex Tutubalin <lexa@lexa.ru>
|
|
||||||
* Fixed undefined behaviour in sony_decrypt() function.
|
|
||||||
This bug causes incorrect camera WB read for Sony cameras.
|
|
||||||
diff -U3 -r LibRaw-0.14.8.orig/src/libraw_cxx.cpp LibRaw-0.14.8/src/libraw_cxx.cpp
|
|
||||||
--- LibRaw-0.14.8.orig/src/libraw_cxx.cpp 2013-05-17 14:54:17.000000000 -0500
|
|
||||||
+++ LibRaw-0.14.8/src/libraw_cxx.cpp 2013-05-31 05:31:51.402607149 -0500
|
|
||||||
@@ -796,8 +796,8 @@
|
|
||||||
S.iheight= S.height;
|
|
||||||
IO.shrink = 0;
|
|
||||||
// allocate image as temporary buffer, size
|
|
||||||
- imgdata.rawdata.raw_alloc = calloc(S.iwidth*S.iheight,sizeof(*imgdata.image));
|
|
||||||
- imgdata.image = (ushort (*)[4]) imgdata.rawdata.raw_alloc;
|
|
||||||
+ imgdata.rawdata.raw_alloc = 0;
|
|
||||||
+ imgdata.image = (ushort (*)[4]) calloc(S.iwidth*S.iheight,sizeof(*imgdata.image));
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
||||||
@@ -807,8 +807,8 @@
|
|
||||||
// recover saved
|
|
||||||
if( decoder_info.decoder_flags & LIBRAW_DECODER_LEGACY)
|
|
||||||
{
|
|
||||||
- imgdata.image = 0;
|
|
||||||
- imgdata.rawdata.color_image = (ushort (*)[4]) imgdata.rawdata.raw_alloc;
|
|
||||||
+ imgdata.rawdata.raw_alloc = imgdata.rawdata.color_image = imgdata.image;
|
|
||||||
+ imgdata.image = 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
// calculate channel maximum
|
|
24
LibRaw.spec
24
LibRaw.spec
@ -1,8 +1,7 @@
|
|||||||
|
|
||||||
Summary: Library for reading RAW files obtained from digital photo cameras
|
Summary: Library for reading RAW files obtained from digital photo cameras
|
||||||
Name: LibRaw
|
Name: LibRaw
|
||||||
Version: 0.15.3
|
Version: 0.15.3
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
URL: http://www.libraw.org
|
URL: http://www.libraw.org
|
||||||
@ -10,12 +9,9 @@ URL: http://www.libraw.org
|
|||||||
BuildRequires: lcms2-devel
|
BuildRequires: lcms2-devel
|
||||||
BuildRequires: jasper-devel
|
BuildRequires: jasper-devel
|
||||||
|
|
||||||
|
|
||||||
Source0: http://www.libraw.org/data/%{name}-%{version}.tar.gz
|
Source0: http://www.libraw.org/data/%{name}-%{version}.tar.gz
|
||||||
Source1: http://www.libraw.org/data/%{name}-demosaic-pack-GPL2-%{version}.tar.gz
|
Source1: http://www.libraw.org/data/%{name}-demosaic-pack-GPL2-%{version}.tar.gz
|
||||||
Source2: http://www.libraw.org/data/%{name}-demosaic-pack-GPL3-%{version}.tar.gz
|
Source2: http://www.libraw.org/data/%{name}-demosaic-pack-GPL3-%{version}.tar.gz
|
||||||
#Patch0: LibRaw-0.14.7-segfault.patch
|
|
||||||
#Patch1: LibRaw-0.14.8-errorhandling.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
LibRaw is a library for reading RAW files obtained from digital photo
|
LibRaw is a library for reading RAW files obtained from digital photo
|
||||||
@ -42,13 +38,18 @@ Group: Development/Libraries
|
|||||||
%description static
|
%description static
|
||||||
LibRaw static development libraries.
|
LibRaw static development libraries.
|
||||||
|
|
||||||
|
%package samples
|
||||||
|
Summary: LibRaw sample programs
|
||||||
|
Group: Development/Libraries
|
||||||
|
|
||||||
|
%description samples
|
||||||
|
LibRaw sample programs
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -a1 -a2
|
%setup -q -a1 -a2
|
||||||
#%patch0 -p0
|
|
||||||
#%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --enable-examples=no --enable-jasper --enable-lcms \
|
%configure --enable-examples=yes --enable-jasper --enable-lcms \
|
||||||
--enable-demosaic-pack-gpl2 --enable-demosaic-pack-gpl3
|
--enable-demosaic-pack-gpl2 --enable-demosaic-pack-gpl3
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -80,10 +81,17 @@ make install DESTDIR=%{buildroot}
|
|||||||
%exclude %{_libdir}/*.la
|
%exclude %{_libdir}/*.la
|
||||||
%exclude %{_docdir}/libraw/*
|
%exclude %{_docdir}/libraw/*
|
||||||
|
|
||||||
|
%files samples
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%{_bindir}/*
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
%post -p /sbin/ldconfig
|
||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 07 2013 Jon Ciesla <limburgher@gmail.com> - 0.15.3-3
|
||||||
|
- Enable samples, BZ 991514,
|
||||||
|
|
||||||
* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15.3-2
|
* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15.3-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user