Initial version - 0.9.11-1

This commit is contained in:
Lukas Zapletal 2019-08-19 16:22:03 +02:00
parent 29cef1ad34
commit 705b15e99b
4 changed files with 92 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
/HdrHistogram_c-0.9.11.tar.gz

17
0001-respect-flags.patch Normal file
View File

@ -0,0 +1,17 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 561b5b0..b651093 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,9 +24,9 @@ set(HDR_SOVERSION ${HDR_SOVERSION_CURRENT})
ENABLE_TESTING()
if(UNIX)
- set(CMAKE_C_FLAGS "-Wall -Wno-unknown-pragmas -Wextra -Wshadow -Winit-self -Wmissing-prototypes -Wpedantic -D_GNU_SOURCE -std=gnu89")
- set(CMAKE_C_FLAGS_DEBUG "-O0 -g")
- set(CMAKE_C_FLAGS_RELEASE "-O3 -g")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wno-unknown-pragmas -Wextra -Wshadow -Winit-self -Wmissing-prototypes -Wpedantic -D_GNU_SOURCE -std=gnu89")
+ set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -O0 -g")
+ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O3 -g")
endif()
if(WIN32)

73
HdrHistogram_c.spec Normal file
View File

@ -0,0 +1,73 @@
Name: HdrHistogram_c
Version: 0.9.11
Release: 1%{?dist}
Summary: C port of the HdrHistogram
License: BSD and Public Domain
URL: https://github.com/HdrHistogram/%{name}
Source0: https://github.com/HdrHistogram/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
Patch0: 0001-respect-flags.patch
BuildRequires: gcc g++ cmake zlib-devel
%description
C port of High Dynamic Range (HDR) Histogram.
%package devel
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%prep
%autosetup -n %{name}-%{version}
%build
%cmake .
%make_build
%check
ls test
test/hdr_atomic_test
test/hdr_histogram_test
%install
rm -rf $RPM_BUILD_ROOT
%make_install
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%ldconfig_post
%ldconfig_postun
%files
%license LICENSE.txt
%doc README.md
%exclude %{_bindir}/hiccup
%exclude %{_bindir}/hdr_decoder
%exclude %{_bindir}/perftest
%exclude %{_bindir}/hdr_histogram_log_test
%exclude %{_bindir}/hdr_histogram_test
%{_libdir}/libhdr_histogram.so.3.1.2
%{_libdir}/libhdr_histogram.so.3
%exclude %{_libdir}/libhdr_histogram_static.a
%files devel
%dir %{_includedir}/hdr
%{_includedir}/hdr/hdr_thread.h
%{_includedir}/hdr/hdr_interval_recorder.h
%{_includedir}/hdr/hdr_writer_reader_phaser.h
%{_includedir}/hdr/hdr_time.h
%{_includedir}/hdr/hdr_histogram_log.h
%{_includedir}/hdr/hdr_histogram.h
%{_libdir}/libhdr_histogram.so
%changelog
* Wed Aug 14 2019 Lukáš Zapletal 0.9.11-1
- Initial package version

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (HdrHistogram_c-0.9.11.tar.gz) = 0a83b35cdf6366b7b26b815af2107c86d71b80c334cde2e2aacc7aa02b3dbd05434651c84e5e0127608aebb3d9d52b717ddeec92c00ec705b0dee06b23d6e816