Removed CMAKE patch

This commit is contained in:
Lukas Zapletal 2020-02-12 09:52:14 +01:00
parent 73e708d070
commit 27cfce7ecf
3 changed files with 8 additions and 21 deletions

5
.gitignore vendored
View File

@ -1,2 +1,5 @@
/HdrHistogram_c-0.9.11.tar.gz
.build*
x86_64/
HdrHistogram_c-*.rpm
/HdrHistogram_c-*.tar.gz
/HdrHistogram_c-0.9.12.tar.gz

View File

@ -1,17 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 561b5b0..b651093 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,9 +24,9 @@ set(HDR_SOVERSION ${HDR_SOVERSION_CURRENT})
ENABLE_TESTING()
if(UNIX)
- set(CMAKE_C_FLAGS "-Wall -Wno-unknown-pragmas -Wextra -Wshadow -Winit-self -Wmissing-prototypes -Wpedantic -D_GNU_SOURCE -std=gnu89")
- set(CMAKE_C_FLAGS_DEBUG "-O0 -g")
- set(CMAKE_C_FLAGS_RELEASE "-O3 -g")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wno-unknown-pragmas -Wextra -Wshadow -Winit-self -Wmissing-prototypes -Wpedantic -D_GNU_SOURCE -std=gnu89")
+ set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -O0 -g")
+ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O3 -g")
endif()
if(WIN32)

View File

@ -5,7 +5,6 @@ Summary: C port of the HdrHistogram
License: BSD and Public Domain
URL: https://github.com/HdrHistogram/%{name}
Source0: https://github.com/HdrHistogram/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
Patch0: 0001-respect-flags.patch
BuildRequires: gcc g++ cmake zlib-devel
@ -40,6 +39,7 @@ test/hdr_histogram_test
rm -rf $RPM_BUILD_ROOT
%make_install
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
find $RPM_BUILD_ROOT
%ldconfig_post
@ -54,8 +54,9 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%exclude %{_bindir}/perftest
%exclude %{_bindir}/hdr_histogram_log_test
%exclude %{_bindir}/hdr_histogram_test
%{_libdir}/libhdr_histogram.so.3.1.2
%{_libdir}/libhdr_histogram.so.3
%exclude %{_bindir}/hdr_histogram_atomic_test
%{_libdir}/libhdr_histogram.so.4.2.0
%{_libdir}/libhdr_histogram.so.4
%exclude %{_libdir}/libhdr_histogram_static.a
%files devel