Update to 0.29.15 (#1800158)
This commit is contained in:
parent
7d0ab88403
commit
5ae908bc2e
1
.gitignore
vendored
1
.gitignore
vendored
@ -40,3 +40,4 @@ Cython-0.12.1.tar.gz
|
||||
/Cython-0.29.12.tar.gz
|
||||
/Cython-0.29.13.tar.gz
|
||||
/Cython-0.29.14.tar.gz
|
||||
/Cython-0.29.15.tar.gz
|
||||
|
@ -1,35 +0,0 @@
|
||||
From 1cd24026e9cf6d63d539b359f8ba5155fd48ae21 Mon Sep 17 00:00:00 2001
|
||||
From: Stefan Behnel <stefan_ml@behnel.de>
|
||||
Date: Fri, 15 Mar 2019 00:10:05 +0100
|
||||
Subject: [PATCH] Import "Iterable" ABC class from "collections.abc" in Py3
|
||||
instead of deprecated "collections" package.
|
||||
|
||||
---
|
||||
Cython/Build/Dependencies.py | 7 ++++++-
|
||||
1 file changed, 6 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Cython/Build/Dependencies.py b/Cython/Build/Dependencies.py
|
||||
index a4e5c60bee..eb03004e24 100644
|
||||
--- a/Cython/Build/Dependencies.py
|
||||
+++ b/Cython/Build/Dependencies.py
|
||||
@@ -18,6 +18,11 @@
|
||||
from distutils.util import strtobool
|
||||
import zipfile
|
||||
|
||||
+try:
|
||||
+ from collections.abc import Iterable
|
||||
+except ImportError:
|
||||
+ from collections import Iterable
|
||||
+
|
||||
try:
|
||||
import gzip
|
||||
gzip_open = gzip.open
|
||||
@@ -749,7 +754,7 @@ def create_extension_list(patterns, exclude=None, ctx=None, aliases=None, quiet=
|
||||
exclude = []
|
||||
if patterns is None:
|
||||
return [], {}
|
||||
- elif isinstance(patterns, basestring) or not isinstance(patterns, collections.Iterable):
|
||||
+ elif isinstance(patterns, basestring) or not isinstance(patterns, Iterable):
|
||||
patterns = [patterns]
|
||||
explicit_modules = set([m.name for m in patterns if isinstance(m, Extension)])
|
||||
seen = set()
|
10
Cython.spec
10
Cython.spec
@ -4,18 +4,15 @@
|
||||
%bcond_without tests
|
||||
|
||||
Name: Cython
|
||||
Version: 0.29.14
|
||||
Version: 0.29.15
|
||||
%global upver %{version_no_tilde %{nil}}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Language for writing Python extension modules
|
||||
|
||||
License: ASL 2.0
|
||||
URL: http://www.cython.org
|
||||
Source: https://github.com/cython/cython/archive/%{upver}/%{srcname}-%{version}.tar.gz
|
||||
|
||||
# Python 3.9 compatibility
|
||||
Patch1: https://github.com/cython/cython/commit/1cd24026e9cf6d63d539b359f8ba5155fd48ae21.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
%if %{with tests}
|
||||
BuildRequires: gcc-c++
|
||||
@ -106,6 +103,9 @@ cp -p cython-mode-init.el cython-mode-init.elc %{buildroot}%{_emacs_sitestartdir
|
||||
%{_emacs_sitestartdir}/cython*.el*
|
||||
|
||||
%changelog
|
||||
* Sat Feb 08 2020 Miro Hrončok <mhroncok@redhat.com> - 0.29.15-1
|
||||
- Update to 0.29.15 (#1800158)
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.29.14-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (Cython-0.29.14.tar.gz) = fa1575fc5ec7ee19de34f91a15bdd45d889f54217dbe2a9654604ada90d8d86fe7bceb86449c41b68d6b65459769916a0d7d5f5da21c5597aedc876cde4e37df
|
||||
SHA512 (Cython-0.29.15.tar.gz) = bd0872359d31a41750353bb0d7f03c2a40aa2bf6e492148e693321cef15b02ae4f8d5f5a00efde7216f09a6ac06f2bb3ded9d00e27ad0cfc53605f3a9ef55af8
|
||||
|
Loading…
Reference in New Issue
Block a user