Backport couple of patches
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
parent
867ac56a5d
commit
195ed45bcd
25
0001-Check-sys.path-for-.pxi-files-too.patch
Normal file
25
0001-Check-sys.path-for-.pxi-files-too.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 97de55acf4efe3c3ae2b5a955578cae71958dfe7 Mon Sep 17 00:00:00 2001
|
||||
From: Jeroen Demeyer <jdemeyer@cage.ugent.be>
|
||||
Date: Sun, 7 Feb 2016 17:07:54 +0100
|
||||
Subject: [PATCH] Check sys.path for .pxi files too
|
||||
|
||||
---
|
||||
Cython/Compiler/Main.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Cython/Compiler/Main.py b/Cython/Compiler/Main.py
|
||||
index 65b3cd309..d4d0f788b 100644
|
||||
--- a/Cython/Compiler/Main.py
|
||||
+++ b/Cython/Compiler/Main.py
|
||||
@@ -269,7 +269,7 @@ class Context(object):
|
||||
# Search list of include directories for filename.
|
||||
# Reports an error and returns None if not found.
|
||||
path = self.search_include_directories(filename, "", pos,
|
||||
- include=True)
|
||||
+ include=True, sys_path=True)
|
||||
if not path:
|
||||
error(pos, "'%s' not found" % filename)
|
||||
return path
|
||||
--
|
||||
2.11.0
|
||||
|
32
0001-fix-typo-in-Compiler-Options.py.patch
Normal file
32
0001-fix-typo-in-Compiler-Options.py.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From 3526e08741c05dd122ffe827d9d8b5864a3436f5 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Wed, 21 Dec 2016 14:31:08 +0100
|
||||
Subject: [PATCH] fix typo in Compiler/Options.py
|
||||
|
||||
Reported-by: Paulo Andrade <paulo.cesar.pereira.de.andrade@gmail.com>
|
||||
References: https://bugzilla.redhat.com/show_bug.cgi?id=1406533
|
||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
Cython/Compiler/Options.py | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Cython/Compiler/Options.py b/Cython/Compiler/Options.py
|
||||
index ddafa202a..893dab23f 100644
|
||||
--- a/Cython/Compiler/Options.py
|
||||
+++ b/Cython/Compiler/Options.py
|
||||
@@ -8,10 +8,10 @@ class ShouldBeFromDirective(object):
|
||||
|
||||
known_directives = []
|
||||
|
||||
- def __init__(self, options_name, directive_name=None, dissallow=False):
|
||||
+ def __init__(self, options_name, directive_name=None, disallow=False):
|
||||
self.options_name = options_name
|
||||
self.directive_name = directive_name or options_name
|
||||
- self.dissallow = dissallow
|
||||
+ self.disallow = disallow
|
||||
self.known_directives.append(self)
|
||||
|
||||
def __nonzero__(self):
|
||||
--
|
||||
2.11.0
|
||||
|
12
Cython.spec
12
Cython.spec
@ -6,13 +6,20 @@
|
||||
|
||||
Name: Cython
|
||||
Version: 0.25.2
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: A language for writing Python extension modules
|
||||
|
||||
License: Python
|
||||
URL: http://www.cython.org
|
||||
Source: https://github.com/cython/cython/archive/%{version}/%{srcname}-%{version}.tar.gz
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1406533
|
||||
# https://github.com/cython/cython/pull/1560
|
||||
Patch0001: 0001-fix-typo-in-Compiler-Options.py.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1406905
|
||||
# https://github.com/cython/cython/pull/483
|
||||
Patch0002: 0001-Check-sys.path-for-.pxi-files-too.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
%if %{with tests}
|
||||
BuildRequires: gcc-c++
|
||||
@ -105,6 +112,9 @@ rm -rf %{buildroot}%{python2_sitelib}/setuptools/tests
|
||||
%{python3_sitearch}/__pycache__/%{upname}.*
|
||||
|
||||
%changelog
|
||||
* Thu Dec 22 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.25.2-3
|
||||
- Backport couple of patches
|
||||
|
||||
* Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 0.25.2-2
|
||||
- Rebuild for Python 3.6
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user