Rebuilt sources for automake 1.11.3

This commit is contained in:
Shakthi Kannan 2012-05-02 15:09:39 +05:30
parent a2fe5e6d11
commit 9c7ba49aec
5 changed files with 9 additions and 97 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/CUnit-2.1-2-src.tar.bz2
/CUnit-2.1-3-src.tar.bz2

View File

@ -1,29 +0,0 @@
diff -up CUnit-2.1-2/doc/headers/Makefile.am.fix CUnit-2.1-2/doc/headers/Makefile.am
--- CUnit-2.1-2/doc/headers/Makefile.am.fix 2011-01-29 23:02:48.979554008 +0530
+++ CUnit-2.1-2/doc/headers/Makefile.am 2011-01-29 23:03:17.265554008 +0530
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in
-dochdrdir = $(prefix)/doc/@PACKAGE@/headers
+dochdrdir = $(datarootdir)/doc/@PACKAGE@/headers
INCLUDE_FILES = \
Automated.h \
diff -up CUnit-2.1-2/doc/Makefile.am.fix CUnit-2.1-2/doc/Makefile.am
--- CUnit-2.1-2/doc/Makefile.am.fix 2011-01-29 23:03:29.287553948 +0530
+++ CUnit-2.1-2/doc/Makefile.am 2011-01-29 23:03:43.111554042 +0530
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in
-docdir = $(prefix)/doc/@PACKAGE@
+docdir = $(datarootdir)/doc/@PACKAGE@
doc_DATA = \
CUnit_doc.css \
@@ -13,4 +13,4 @@ doc_DATA = \
test_registry.html \
writing_tests.html
-SUBDIRS = headers
\ No newline at end of file
+SUBDIRS = headers

View File

@ -1,57 +0,0 @@
diff -up CUnit-2.1-2/Man/man3/CUnit.3.man CUnit-2.1-2/Man/man3/CUnit.3
--- CUnit-2.1-2/Man/man3/CUnit.3.man 2011-01-29 23:04:42.302553933 +0530
+++ CUnit-2.1-2/Man/man3/CUnit.3 2011-01-29 23:06:46.210553841 +0530
@@ -473,7 +473,7 @@ dynamically. The following functions ar
be used instead of directly setting the value of the data structure members. All
return CUE_SUCCESS on success, and the indicated error code on failure.
.P
-.TP5
+.TP 5
.B "CU_ErrorCode CU_set_suite_name(CU_pSuite pSuite, const char *strNewName)"
.TP 5
.B "CU_ErrorCode CU_set_test_name(CU_pTest pTest, const char *strNewName)"
@@ -481,7 +481,7 @@ These functions change the name of regis
are available as the
.B pSuite->pName</I>
and
-.BpTest->pName
+.B pTest->pName
data structure members. If the suite or test is NULL, then CUE_NOSUITE or CUE_NOTEST
is returned, respectively. If strNewName is NULL, then CUE_NO_SUITENAME or
CUE_NO_TESTNAME is returned, respectively.
@@ -518,13 +518,13 @@ nothing is known about the suite or test
data structures to enumerate the suites and tests. This is not directly supported in
the client API.
.P
-.TP5
+.TP 5
.B "CU_pSuite CU_get_suite(const char* strName)"
-.TP5
+.TP 5
.B "CU_pSuite CU_get_suite_at_pos(unsigned int pos)"
-.TP5
+.TP 5
.B "unsigned int CU_get_suite_pos(CU_pSuite pSuite)"
-.TP5
+.TP 5
.B "unsigned int CU_get_suite_pos_by_name(const char* strName)"
</P>
These functions facilitate lookup of suites registered in the active test registry.
@@ -539,13 +539,13 @@ These return 0 if the suite cannot be fo
CUnit error state to CUE_NOREGISTRY> if the registry is not initialized. As appropriate,
CUE_NO_SUITENAME is set if strName is NULL, and CUE_NOSUITE is set if pSuite is NULL.
.P
-.TP5
+.TP 5
.B "CU_pTest CU_get_test(CU_pSuite pSuite, const char *strName)"
-.TP5
+.TP 5
.B "CU_pTest CU_get_test_at_pos<(CU_pSuite pSuite, unsigned int pos)"
-.TP5
+.TP 5
.B "unsigned int CU_get_test_pos<(CU_pSuite pSuite, CU_pTest pTest)"
-.TP5
+.TP 5
.B "unsigned int CU_get_test_pos_by_name(CU_pSuite pSuite, const char *strName)"
These functions facilitate lookup of tests registered in suites. The first
2 functions allow lookup of the test by name or position and return NULL if the

View File

@ -1,16 +1,12 @@
Name: CUnit
Version: 2.1.2
Release: 8%{?dist}
Version: 2.1.3
Release: 1%{?dist}
Summary: A unit testing framework for C
Group: System Environment/Libraries
License: LGPLv2+
URL: http://cunit.sourceforge.net/
Source0: http://downloads.sourceforge.net/cunit/%{name}-2.1-2-src.tar.bz2
# Fixes docroot path and manpage errors
Patch0: CUnit-2.1-2-docroot-fix.patch
Patch1: CUnit-2.1-2-manpage-fix.patch
Source0: http://downloads.sourceforge.net/cunit/%{name}-2.1-3-src.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: automake
@ -31,9 +27,7 @@ The %{name}-devel package contains the header files
and libraries for use with CUnit package.
%prep
%setup -q -n %{name}-2.1-2
%patch0 -p1 -b .fix
%patch1 -p1 -b .man
%setup -q -n %{name}-2.1-3
find -name *.c -exec chmod -x {} \;
%build
@ -70,6 +64,9 @@ rm -rf %{buildroot}
%{_mandir}/man3/CUnit.3*
%changelog
* Wed May 2 2012 Shakthi Kannan <shakthimaan [AT] fedoraproject dot org> 2.1.3-1
- Updated to 2.1.3 sources re-run with autoreconf.
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.2-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild

View File

@ -1 +1 @@
31c62bd7a65007737ba28b7aafc44d3a CUnit-2.1-2-src.tar.bz2
e5180e2fa788abf6172c921ee19fae6a CUnit-2.1-3-src.tar.bz2