Resolves: Bug 1916937 - Rebase 389-ds-base on RHEL 9.0 beta (rhbz#1916937)
This commit is contained in:
parent
cc220abe01
commit
a5b3b10a0d
1
.gitignore
vendored
1
.gitignore
vendored
@ -202,3 +202,4 @@
|
||||
/389-ds-base-2.0.2.tar.bz2
|
||||
/389-ds-base-2.0.3.tar.bz2
|
||||
/rust-openssl-770ba32702abd2b4cab80727958c27ac3043c3ec.tar.gz
|
||||
/389-ds-base-2.0.5.tar.bz2
|
||||
|
@ -1,30 +0,0 @@
|
||||
diff --git a/src/Cargo.lock b/src/Cargo.lock
|
||||
index 56097be..fd177d4 100644
|
||||
--- a/src/Cargo.lock
|
||||
+++ b/src/Cargo.lock
|
||||
@@ -449,21 +449,21 @@ checksum = "13bd41f508810a131401606d54ac32a467c97172d74ba7662562ebba5ad07fa0"
|
||||
|
||||
[[package]]
|
||||
name = "openssl"
|
||||
-version = "0.10.32"
|
||||
+version = "0.10.33"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
checksum = "038d43985d1ddca7a9900630d8cd031b56e4794eecc2e9ea39dd17aa04399a70"
|
||||
dependencies = [
|
||||
"bitflags",
|
||||
- "cfg-if",
|
||||
+ "cfg-if 1.0.0",
|
||||
"foreign-types",
|
||||
- "lazy_static",
|
||||
"libc",
|
||||
+ "once_cell",
|
||||
"openssl-sys",
|
||||
]
|
||||
|
||||
[[package]]
|
||||
name = "openssl-sys"
|
||||
-version = "0.9.60"
|
||||
+version = "0.9.61"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
checksum = "921fc71883267538946025deffb622905ecad223c28efbfdef9bb59a0175f3e6"
|
||||
dependencies = [
|
129
389-ds-base.spec
129
389-ds-base.spec
@ -46,9 +46,9 @@ ExcludeArch: i686
|
||||
|
||||
Summary: 389 Directory Server (base)
|
||||
Name: 389-ds-base
|
||||
Version: 2.0.3
|
||||
Release: %{?relprefix}4%{?prerel}%{?dist}
|
||||
License: GPLv3+
|
||||
Version: 2.0.5
|
||||
Release: %{?relprefix}1%{?prerel}%{?dist}
|
||||
License: GPLv3+ and ASL 2.0 and MPLv2.0 and Boost
|
||||
URL: https://www.port389.org
|
||||
Conflicts: selinux-policy-base < 3.9.8
|
||||
Conflicts: freeipa-server < 4.0.3
|
||||
@ -57,6 +57,89 @@ Obsoletes: %{name}-legacy-tools < 1.4.4.6
|
||||
Obsoletes: %{name}-legacy-tools-debuginfo < 1.4.4.6
|
||||
Provides: ldif2ldbm >= 0
|
||||
|
||||
##### Bundled cargo crates list - START #####
|
||||
Provides: bundled(crate(ahash)) = 0.7.2
|
||||
Provides: bundled(crate(ansi_term)) = 0.11.0
|
||||
Provides: bundled(crate(atty)) = 0.2.14
|
||||
Provides: bundled(crate(autocfg)) = 1.0.1
|
||||
Provides: bundled(crate(base64)) = 0.13.0
|
||||
Provides: bundled(crate(bitflags)) = 1.2.1
|
||||
Provides: bundled(crate(byteorder)) = 1.4.3
|
||||
Provides: bundled(crate(cbindgen)) = 0.9.1
|
||||
Provides: bundled(crate(cc)) = 1.0.67
|
||||
Provides: bundled(crate(cfg-if)) = 1.0.0
|
||||
Provides: bundled(crate(clap)) = 2.33.3
|
||||
Provides: bundled(crate(concread)) = 0.2.9
|
||||
Provides: bundled(crate(crossbeam)) = 0.8.0
|
||||
Provides: bundled(crate(crossbeam-channel)) = 0.5.1
|
||||
Provides: bundled(crate(crossbeam-deque)) = 0.8.0
|
||||
Provides: bundled(crate(crossbeam-epoch)) = 0.9.3
|
||||
Provides: bundled(crate(crossbeam-queue)) = 0.3.1
|
||||
Provides: bundled(crate(crossbeam-utils)) = 0.8.3
|
||||
Provides: bundled(crate(entryuuid)) = 0.1.0
|
||||
Provides: bundled(crate(entryuuid_syntax)) = 0.1.0
|
||||
Provides: bundled(crate(fernet)) = 0.1.4
|
||||
Provides: bundled(crate(foreign-types)) = 0.3.2
|
||||
Provides: bundled(crate(foreign-types-shared)) = 0.1.1
|
||||
Provides: bundled(crate(getrandom)) = 0.2.2
|
||||
Provides: bundled(crate(hermit-abi)) = 0.1.18
|
||||
Provides: bundled(crate(instant)) = 0.1.9
|
||||
Provides: bundled(crate(itoa)) = 0.4.7
|
||||
Provides: bundled(crate(jobserver)) = 0.1.21
|
||||
Provides: bundled(crate(lazy_static)) = 1.4.0
|
||||
Provides: bundled(crate(libc)) = 0.2.93
|
||||
Provides: bundled(crate(librnsslapd)) = 0.1.0
|
||||
Provides: bundled(crate(librslapd)) = 0.1.0
|
||||
Provides: bundled(crate(lock_api)) = 0.4.3
|
||||
Provides: bundled(crate(log)) = 0.4.14
|
||||
Provides: bundled(crate(memoffset)) = 0.6.3
|
||||
Provides: bundled(crate(once_cell)) = 1.7.2
|
||||
Provides: bundled(crate(openssl)) = 0.10.33
|
||||
Provides: bundled(crate(openssl-sys)) = 0.9.61
|
||||
Provides: bundled(crate(parking_lot)) = 0.11.1
|
||||
Provides: bundled(crate(parking_lot_core)) = 0.8.3
|
||||
Provides: bundled(crate(paste)) = 0.1.18
|
||||
Provides: bundled(crate(paste-impl)) = 0.1.18
|
||||
Provides: bundled(crate(pkg-config)) = 0.3.19
|
||||
Provides: bundled(crate(ppv-lite86)) = 0.2.10
|
||||
Provides: bundled(crate(proc-macro-hack)) = 0.5.19
|
||||
Provides: bundled(crate(proc-macro2)) = 1.0.26
|
||||
Provides: bundled(crate(pwdchan)) = 0.1.0
|
||||
Provides: bundled(crate(quote)) = 1.0.9
|
||||
Provides: bundled(crate(rand)) = 0.8.3
|
||||
Provides: bundled(crate(rand_chacha)) = 0.3.0
|
||||
Provides: bundled(crate(rand_core)) = 0.6.2
|
||||
Provides: bundled(crate(rand_hc)) = 0.3.0
|
||||
Provides: bundled(crate(redox_syscall)) = 0.2.6
|
||||
Provides: bundled(crate(remove_dir_all)) = 0.5.3
|
||||
Provides: bundled(crate(ryu)) = 1.0.5
|
||||
Provides: bundled(crate(scopeguard)) = 1.1.0
|
||||
Provides: bundled(crate(serde)) = 1.0.125
|
||||
Provides: bundled(crate(serde_derive)) = 1.0.125
|
||||
Provides: bundled(crate(serde_json)) = 1.0.64
|
||||
Provides: bundled(crate(slapd)) = 0.1.0
|
||||
Provides: bundled(crate(slapi_r_plugin)) = 0.1.0
|
||||
Provides: bundled(crate(smallvec)) = 1.6.1
|
||||
Provides: bundled(crate(strsim)) = 0.8.0
|
||||
Provides: bundled(crate(syn)) = 1.0.69
|
||||
Provides: bundled(crate(synstructure)) = 0.12.4
|
||||
Provides: bundled(crate(tempfile)) = 3.2.0
|
||||
Provides: bundled(crate(textwrap)) = 0.11.0
|
||||
Provides: bundled(crate(toml)) = 0.5.8
|
||||
Provides: bundled(crate(unicode-width)) = 0.1.8
|
||||
Provides: bundled(crate(unicode-xid)) = 0.2.1
|
||||
Provides: bundled(crate(uuid)) = 0.8.2
|
||||
Provides: bundled(crate(vcpkg)) = 0.2.11
|
||||
Provides: bundled(crate(vec_map)) = 0.8.2
|
||||
Provides: bundled(crate(version_check)) = 0.9.3
|
||||
Provides: bundled(crate(wasi)) = 0.10.2+wasi_snapshot_preview1
|
||||
Provides: bundled(crate(winapi)) = 0.3.9
|
||||
Provides: bundled(crate(winapi-i686-pc-windows-gnu)) = 0.4.0
|
||||
Provides: bundled(crate(winapi-x86_64-pc-windows-gnu)) = 0.4.0
|
||||
Provides: bundled(crate(zeroize)) = 1.2.0
|
||||
Provides: bundled(crate(zeroize_derive)) = 1.0.1
|
||||
##### Bundled cargo crates list - END #####
|
||||
|
||||
BuildRequires: nspr-devel
|
||||
BuildRequires: nss-devel >= 3.34
|
||||
BuildRequires: openldap-devel
|
||||
@ -171,12 +254,11 @@ Source2: %{name}-devel.README
|
||||
Source3: https://github.com/jemalloc/%{jemalloc_name}/releases/download/%{jemalloc_ver}/%{jemalloc_name}-%{jemalloc_ver}.tar.bz2
|
||||
%endif
|
||||
|
||||
# Initial support for OpenSSL 3.0.0-alpha16
|
||||
# Initial support for OpenSSL 3.0.0-alpha16 - requires create openssl 0.10.33
|
||||
# https://github.com/sfackler/rust-openssl/pull/1264
|
||||
%global rust_openssl_commit 770ba32702abd2b4cab80727958c27ac3043c3ec
|
||||
%global rust_openssl rust-openssl-%{rust_openssl_commit}
|
||||
Source4: https://github.com/sfackler/rust-openssl/archive/%{rust_openssl_commit}/%{rust_openssl}.tar.gz
|
||||
Patch0: 389-ds-base-rust-openssl-300.patch
|
||||
|
||||
%description
|
||||
389 Directory Server is an LDAPv3 compliant server. The base package includes
|
||||
@ -286,7 +368,6 @@ cp %{SOURCE2} README.devel
|
||||
|
||||
rm -rf vendor/openssl{,-sys}/*
|
||||
tar -xf %{SOURCE4} -C vendor/ --strip-components=1 %{rust_openssl}/openssl{,-sys}/
|
||||
%patch0 -p1
|
||||
|
||||
# The configure macro will modify some autoconf-related files, which upsets
|
||||
# cargo when it tries to verify checksums in those files. If we just truncate
|
||||
@ -631,6 +712,42 @@ exit 0
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun May 30 2021 Mark Reynolds <mreynolds@redhat.com> - 2.0.5-1
|
||||
- Bump version to 2.0.5
|
||||
- Issue 4778 - RFE - Allow setting TOD for db compaction and add task
|
||||
- Issue 4169 - UI - Port plugin tables to PF4
|
||||
- Issue 4656 - Allow backward compatilbity for replication plugin name change
|
||||
- Issue 4764 - replicated operation sometime checks ACI (#4783)
|
||||
- Issue 2820 - Fix CI test suite issues
|
||||
- Issue 4781 - There are some typos in man-pages
|
||||
- Issue 4773 - Enable interval feature of DNA plugin
|
||||
- Issue 4623 - RFE - Monitor the current DB locks (#4762)
|
||||
- Issue 3555 - Fix UI audit issue
|
||||
- Issue 4725 - Fix compiler warnings
|
||||
- Issue 4770 - Lower FIPS logging severity
|
||||
- Issue 4765 - database suffix unexpectdly changed from .db to .db4 (#4766)
|
||||
- Issue 4725 - [RFE] DS - Update the password policy to support a Temporary Password Rules (#4727)
|
||||
- Issue 4747 - Remove unstable/unstatus tests from PRCI (#4748)
|
||||
- Issue 4759 - Fix coverity issue (#4760)
|
||||
- Issue 4169 - UI - Migrate Buttons to PF4 (#4745)
|
||||
- Issue 4714 - dscontainer fails with rootless podman
|
||||
- Issue 4750 - Fix compiler warning in retrocl (#4751)
|
||||
- Issue 4742 - UI - should always use LDAPI path when calling CLI
|
||||
- Issue 4169 - UI - Migrate Server, Security, and Schema tables to PF4
|
||||
- Issue 4667 - incorrect accounting of readers in vattr rwlock (#4732)
|
||||
- Issue 4701 - RFE - Exclude attributes from retro changelog (#4723)
|
||||
- Issue 4740 - Fix CI lib389 userPwdPolicy and subtreePwdPolicy (#4741)
|
||||
- Issue 4711 - SECURITY FIX - SIGSEV with sync_repl (#4738)
|
||||
- Issue 4734 - import of entry with no parent warning (#4735)
|
||||
- Issue 4729 - GitHub Actions fails to run pytest tests
|
||||
- Issue 4656 - Remove problematic language from source code
|
||||
- Issue 4632 - dscontainer: SyntaxWarning: "is" with a literal.
|
||||
- Issue 4169 - UI - migrate replication tables to PF4
|
||||
- Issue 4637 - ndn cache leak (#4724)
|
||||
- Issue 4577 - Fix ASAN flags in specfile
|
||||
- Issue 4169 - UI - PF4 migration - database tables
|
||||
- issue 4653 - refactor ldbm backend to allow replacement of BDB - phase 3e - dbscan (#4709)
|
||||
|
||||
* Mon May 24 2021 Simon Pichugin <spichugi@redhat.com> - 2.0.3-4
|
||||
- Initial support for OpenSSL 3.0.0-alpha16
|
||||
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (389-ds-base-2.0.3.tar.bz2) = 48f0dcd7e4853646ea9bb38ec742f2b421b7bd6477d33070a8c97a764021ab7fa6fc005cb75ea87860b7b70998dc4df87790cf1c2bda3e6c0a9f08d39b00f6d2
|
||||
SHA512 (389-ds-base-2.0.5.tar.bz2) = 37f9cdcf26cfe4ba861917f50cca1bfc4f709c19da7895cdef8c68a54b617cdc0884577c2dd6c3fb233cd69341e2c7f9a77f1b3f0498f36a6c476e346123cc8a
|
||||
SHA512 (jemalloc-5.2.1.tar.bz2) = 0bbb77564d767cef0c6fe1b97b705d368ddb360d55596945aea8c3ba5889fbce10479d85ad492c91d987caacdbbdccc706aa3688e321460069f00c05814fae02
|
||||
SHA512 (rust-openssl-770ba32702abd2b4cab80727958c27ac3043c3ec.tar.gz) = 82888c18beafae8cd8122fe91d00fd32c60ab1ed47db4da691ca762b5102eee4cbfcd6f333fcb1769ba1b65b655f726050b1deccdfdf7ec7b21728c51cd2c750
|
||||
|
Loading…
Reference in New Issue
Block a user