Bump version to 2.4.0
Issue 5156 - RFE that implement slapi_memberof (#5694) Issue 5734 - RFE - Exclude pwdFailureTime and ContextCSN (#5735) Issue 5726 - ns-slapd crashing in ldbm_back_upgradednformat (#5727) Issue 4758 - Add tests for WebUI Issue 5718 - Memory leak in connection table (#5719) Issue 5705 - Add config parameter to close client conns on failed bind (#5712) Issue 4758 - Add tests for WebUI Issue 5643 - Memory leak in entryrdn during delete (#5717) Issue 5714 - UI - fix typo, db settings, log settings, and LDAP editor paginations Issue 5701 - CLI - Fix referral mode setting (#5708) Bump openssl from 0.10.45 to 0.10.48 in /src (#5709) Issue 5710 - subtree search statistics for index lookup does not report ancestorid/entryrdn lookups (#5711) Issue 5697 - Obsolete nsslapd-ldapimaprootdn attribute (#5698) Issue 1081 - Stop schema replication from overwriting x-origin Issue 4812 - Listener thread does not scale with a high num of established connections (#5706) Issue 4812 - Listener thread does not scale with a high num of established connections (#5681) Bump webpack from 5.75.0 to 5.76.0 in /src/cockpit/389-console (#5699) Issue 5598 - (3rd) In 2.x, SRCH throughput drops by 10% because of handling of referral (#5692) Issue 5598 - (2nd) In 2.x, SRCH throughput drops by 10% because of handling of referral (#5691) Issue 5687 - UI - sensitive information disclosure Issue 5661 - LMDB hangs while Rebuilding the replication changelog RUV (#5676) Issue 5554 - Add more tests to security_basic_test suite Issue 4583 - Update specfile to skip checks of ASAN builds Issue 4758 - Add tests for WebUI Issue 3604 - UI - Add support for Subject Alternative Names in CSR Issue 5600 - buffer overflow when enabling sync repl plugin when dynamic plugins is enabled Issue 5640 - Update logconv for new logging format Issue 5162 - CI - fix error message for invalid pem file Issue 5598 - In 2.x, SRCH throughput drops by 10% because of handling of referral (#5604) Issue 5671 - covscan - clang warning (#5672) Issue 5267 - CI - Fix issues with nsslapd-return-original-entrydn Issue 5666 - CLI - Add timeout parameter for tasks Issue 5567 - CLI - make ldifgen use the same default ldif name for all options Issue 5647 - Fix unused variable warning from previous commit (#5670) Issue 5162 - Lib389 - verify certificate type before adding Issue 5642 - Build fails against setuptools 67.0.0 Issue 5630 - CLI - need to add logging filter for stdout Issue 5646 - CLI/UI - do not hardcode password storage schemes Issue 5640 - Update logconv for new logging format issue 5647 - covscan: memory leak in audit log when adding entries (#5650) Issue 5658 - CLI - unable to add attribute with matching rule Issue 5653 - covscan - fix invalid dereference Issue 5652 - Libasan crash in replication/cascading_test (#5659) Issue 5628 - Handle graceful timeout in CI tests (#5657) Issue 5648 - Covscan - Compiler warnings (#5651) Issue 5630 - CLI - error messages should goto stderr Issue 2435 - RFE - Raise IDL Scan Limit to INT_MAX (#5639) Issue 5632 - CLI - improve error handling with db2ldif Issue 5517 - Replication conflict CI test sometime fails (#5518) Issue 5634 - Deprecated warning related to github action workflow code (#5635) Issue 5637 - Covscan - fix Buffer Overflows (#5638) Issue 5624 - RFE - UI - export certificates, and import text base64 encoded certificates Bump tokio from 1.24.1 to 1.25.0 in /src (#5629) Issue 4577 - Add LMDB pytest github action (#5627) Issue 4293 - RFE - CLI - add dsrc options for setting user and group subtrees Remove stale libevent(-devel) dependency Issue 5578 - dscreate ds-root does not normaile paths (#5613) Issue 5497 - boolean attributes should be case insensitive
This commit is contained in:
parent
763153ab35
commit
4278187fdb
1
.gitignore
vendored
1
.gitignore
vendored
@ -219,3 +219,4 @@
|
||||
/389-ds-base-2.3.0.tar.bz2
|
||||
/389-ds-base-2.3.1.tar.bz2
|
||||
/389-ds-base-2.3.2.tar.bz2
|
||||
/389-ds-base-2.4.0.tar.bz2
|
||||
|
@ -1,180 +0,0 @@
|
||||
From c0e2f68423ddde9bb91250d3f96dfc8617889514 Mon Sep 17 00:00:00 2001
|
||||
From: Viktor Ashirov <vashirov@redhat.com>
|
||||
Date: Mon, 13 Feb 2023 18:39:20 +0100
|
||||
Subject: [PATCH] Issue 5642 - Build fails against setuptools 67.0.0
|
||||
|
||||
Bug Description:
|
||||
`setuptools` 67.0.0 vendors `packaging` 23.0 which dropped `LegacyVersion`.
|
||||
|
||||
Fix Description:
|
||||
Replace `LegacyVersion` with `DSVersion` to compare version strings that are
|
||||
not compatible with PEP 440 and PEP 508.
|
||||
|
||||
Reviewed by: @mreynolds389, @progier389
|
||||
|
||||
Fixes: https://github.com/389ds/389-ds-base/issues/5642
|
||||
---
|
||||
src/lib389/lib389/nss_ssl.py | 11 +---
|
||||
src/lib389/lib389/tests/dsversion_test.py | 12 ++++
|
||||
src/lib389/lib389/utils.py | 80 ++++++++++++++++++++---
|
||||
3 files changed, 86 insertions(+), 17 deletions(-)
|
||||
create mode 100644 src/lib389/lib389/tests/dsversion_test.py
|
||||
|
||||
diff --git a/src/lib389/lib389/nss_ssl.py b/src/lib389/lib389/nss_ssl.py
|
||||
index 9e4ac09f8..d5e5c4679 100644
|
||||
--- a/src/lib389/lib389/nss_ssl.py
|
||||
+++ b/src/lib389/lib389/nss_ssl.py
|
||||
@@ -23,16 +23,9 @@
|
||||
from lib389.passwd import password_generate
|
||||
from lib389._mapped_object_lint import DSLint
|
||||
from lib389.lint import DSCERTLE0001, DSCERTLE0002
|
||||
-from lib389.utils import ensure_str, format_cmd_list
|
||||
+from lib389.utils import ensure_str, format_cmd_list, DSVersion
|
||||
import uuid
|
||||
|
||||
-# Setuptools ships with 'packaging' module, let's use it from there
|
||||
-try:
|
||||
- from pkg_resources.extern.packaging.version import LegacyVersion
|
||||
-# Fallback to a normal 'packaging' module in case 'setuptools' is stripped
|
||||
-except:
|
||||
- from packaging.version import LegacyVersion
|
||||
-
|
||||
KEYBITS = 4096
|
||||
CA_NAME = 'Self-Signed-CA'
|
||||
CERT_NAME = 'Server-Cert'
|
||||
@@ -249,7 +242,7 @@ def openssl_rehash(self, certdir):
|
||||
openssl_version = check_output(['/usr/bin/openssl', 'version']).decode('utf-8').strip()
|
||||
except subprocess.CalledProcessError as e:
|
||||
raise ValueError(e.output.decode('utf-8').rstrip())
|
||||
- rehash_available = LegacyVersion(openssl_version.split(' ')[1]) >= LegacyVersion('1.1.0')
|
||||
+ rehash_available = DSVersion(openssl_version.split(' ')[1]) >= DSVersion('1.1.0')
|
||||
|
||||
if rehash_available:
|
||||
cmd = ['/usr/bin/openssl', 'rehash', certdir]
|
||||
diff --git a/src/lib389/lib389/tests/dsversion_test.py b/src/lib389/lib389/tests/dsversion_test.py
|
||||
new file mode 100644
|
||||
index 000000000..2a420067f
|
||||
--- /dev/null
|
||||
+++ b/src/lib389/lib389/tests/dsversion_test.py
|
||||
@@ -0,0 +1,12 @@
|
||||
+from lib389.utils import DSVersion
|
||||
+import pytest
|
||||
+
|
||||
+versions = [('1.3.10.1', '1.3.2.1'),
|
||||
+ ('2.3.2', '1.4.4.4'),
|
||||
+ ('2.3.2.202302121950git1b4f5a5bf', '2.3.2'),
|
||||
+ ('1.1.0a', '1.1.0')]
|
||||
+
|
||||
+@pytest.mark.parametrize("x,y", versions)
|
||||
+def test_dsversion(x, y):
|
||||
+ assert DSVersion(x) > DSVersion(y)
|
||||
+
|
||||
diff --git a/src/lib389/lib389/utils.py b/src/lib389/lib389/utils.py
|
||||
index 5566184b0..af77e519b 100644
|
||||
--- a/src/lib389/lib389/utils.py
|
||||
+++ b/src/lib389/lib389/utils.py
|
||||
@@ -42,12 +42,6 @@ def wait(self):
|
||||
import subprocess
|
||||
import math
|
||||
import errno
|
||||
-# Setuptools ships with 'packaging' module, let's use it from there
|
||||
-try:
|
||||
- from pkg_resources.extern.packaging.version import LegacyVersion
|
||||
-# Fallback to a normal 'packaging' module in case 'setuptools' is stripped
|
||||
-except:
|
||||
- from packaging.version import LegacyVersion
|
||||
from socket import getfqdn
|
||||
from ldapurl import LDAPUrl
|
||||
from contextlib import closing
|
||||
@@ -1218,6 +1212,76 @@ def generate_ds_params(inst_num, role=ReplicaRole.STANDALONE):
|
||||
|
||||
return instance_data
|
||||
|
||||
+class DSVersion():
|
||||
+ def __init__(self, version):
|
||||
+ self._version = str(version)
|
||||
+ self._key = _cmpkey(self._version)
|
||||
+
|
||||
+ def __str__(self):
|
||||
+ return self._version
|
||||
+
|
||||
+ def __repr__(self):
|
||||
+ return f"<DSVersion('{self}')>"
|
||||
+
|
||||
+ def __hash__(self):
|
||||
+ return hash(self._key)
|
||||
+
|
||||
+ def __lt__(self, other):
|
||||
+ if not isinstance(other, DSVersion):
|
||||
+ return NotImplemented
|
||||
+
|
||||
+ return self._key < other._key
|
||||
+
|
||||
+ def __le__(self, other):
|
||||
+ if not isinstance(other, DSVersion):
|
||||
+ return NotImplemented
|
||||
+
|
||||
+ return self._key <= other._key
|
||||
+
|
||||
+ def __eq__(self, other):
|
||||
+ if not isinstance(other, DSVersion):
|
||||
+ return NotImplemented
|
||||
+
|
||||
+ return self._key == other._key
|
||||
+
|
||||
+ def __ge__(self, other):
|
||||
+ if not isinstance(other, DSVersion):
|
||||
+ return NotImplemented
|
||||
+
|
||||
+ return self._key >= other._key
|
||||
+
|
||||
+ def __gt__(self, other):
|
||||
+ if not isinstance(other, DSVersion):
|
||||
+ return NotImplemented
|
||||
+
|
||||
+ return self._key > other._key
|
||||
+
|
||||
+ def __ne__(self, other):
|
||||
+ if not isinstance(other, DSVersion):
|
||||
+ return NotImplemented
|
||||
+
|
||||
+ return self._key != other._key
|
||||
+
|
||||
+
|
||||
+def _parse_version_parts(s):
|
||||
+ for part in re.compile(r"(\d+ | [a-z]+ | \. | -)", re.VERBOSE).split(s):
|
||||
+
|
||||
+ if not part or part == ".":
|
||||
+ continue
|
||||
+
|
||||
+ if part[:1] in "0123456789":
|
||||
+ # pad for numeric comparison
|
||||
+ yield part.zfill(8)
|
||||
+ else:
|
||||
+ yield "*" + part
|
||||
+
|
||||
+def _cmpkey(version):
|
||||
+ parts = []
|
||||
+ for part in _parse_version_parts(version.lower()):
|
||||
+ parts.append(part)
|
||||
+
|
||||
+ return tuple(parts)
|
||||
+
|
||||
|
||||
def get_ds_version(paths=None):
|
||||
"""
|
||||
@@ -1245,9 +1309,9 @@ def ds_is_related(relation, *ver, instance=None):
|
||||
if len(ver) > 1:
|
||||
for cmp_ver in ver:
|
||||
if cmp_ver.startswith(ds_ver[:3]):
|
||||
- return ops[relation](LegacyVersion(ds_ver),LegacyVersion(cmp_ver))
|
||||
+ return ops[relation](DSVersion(ds_ver), DSVersion(cmp_ver))
|
||||
else:
|
||||
- return ops[relation](LegacyVersion(ds_ver), LegacyVersion(ver[0]))
|
||||
+ return ops[relation](DSVersion(ds_ver), DSVersion(ver[0]))
|
||||
|
||||
|
||||
def ds_is_older(*ver, instance=None):
|
||||
--
|
||||
2.39.2
|
||||
|
163
389-ds-base.spec
163
389-ds-base.spec
@ -45,9 +45,9 @@ ExcludeArch: i686
|
||||
|
||||
Summary: 389 Directory Server (base)
|
||||
Name: 389-ds-base
|
||||
Version: 2.3.2
|
||||
Release: 3%{?dist}
|
||||
License: GPLv3+ and (ASL 2.0 or MIT)
|
||||
Version: 2.4.0
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+ and (ASL 2.0 or MIT) and MIT and (Unlicense or MIT) and MPLv2.0 and BSD and (ASL 2.0 with exceptions or ASL 2.0 or MIT) and ASL 2.0 and (ASL 2.0 or Boost) and ((MIT or ASL 2.0) and Unicode-DFS-2016)
|
||||
URL: https://www.port389.org
|
||||
Conflicts: selinux-policy-base < 3.9.8
|
||||
Conflicts: freeipa-server < 4.0.3
|
||||
@ -65,39 +65,44 @@ Provides: bundled(crate(base64)) = 0.13.1
|
||||
Provides: bundled(crate(bitflags)) = 1.3.2
|
||||
Provides: bundled(crate(byteorder)) = 1.4.3
|
||||
Provides: bundled(crate(cbindgen)) = 0.9.1
|
||||
Provides: bundled(crate(cc)) = 1.0.78
|
||||
Provides: bundled(crate(cc)) = 1.0.79
|
||||
Provides: bundled(crate(cfg-if)) = 1.0.0
|
||||
Provides: bundled(crate(clap)) = 2.34.0
|
||||
Provides: bundled(crate(concread)) = 0.2.21
|
||||
Provides: bundled(crate(crossbeam)) = 0.8.2
|
||||
Provides: bundled(crate(crossbeam-channel)) = 0.5.6
|
||||
Provides: bundled(crate(crossbeam-deque)) = 0.8.2
|
||||
Provides: bundled(crate(crossbeam-epoch)) = 0.9.13
|
||||
Provides: bundled(crate(crossbeam-channel)) = 0.5.8
|
||||
Provides: bundled(crate(crossbeam-deque)) = 0.8.3
|
||||
Provides: bundled(crate(crossbeam-epoch)) = 0.9.14
|
||||
Provides: bundled(crate(crossbeam-queue)) = 0.3.8
|
||||
Provides: bundled(crate(crossbeam-utils)) = 0.8.14
|
||||
Provides: bundled(crate(crossbeam-utils)) = 0.8.15
|
||||
Provides: bundled(crate(entryuuid)) = 0.1.0
|
||||
Provides: bundled(crate(entryuuid_syntax)) = 0.1.0
|
||||
Provides: bundled(crate(fastrand)) = 1.8.0
|
||||
Provides: bundled(crate(errno)) = 0.3.1
|
||||
Provides: bundled(crate(errno-dragonfly)) = 0.1.2
|
||||
Provides: bundled(crate(fastrand)) = 1.9.0
|
||||
Provides: bundled(crate(fernet)) = 0.1.4
|
||||
Provides: bundled(crate(foreign-types)) = 0.3.2
|
||||
Provides: bundled(crate(foreign-types-shared)) = 0.1.1
|
||||
Provides: bundled(crate(getrandom)) = 0.2.8
|
||||
Provides: bundled(crate(getrandom)) = 0.2.9
|
||||
Provides: bundled(crate(hashbrown)) = 0.12.3
|
||||
Provides: bundled(crate(hermit-abi)) = 0.1.19
|
||||
Provides: bundled(crate(hermit-abi)) = 0.3.1
|
||||
Provides: bundled(crate(instant)) = 0.1.12
|
||||
Provides: bundled(crate(itoa)) = 1.0.5
|
||||
Provides: bundled(crate(jobserver)) = 0.1.25
|
||||
Provides: bundled(crate(libc)) = 0.2.139
|
||||
Provides: bundled(crate(io-lifetimes)) = 1.0.10
|
||||
Provides: bundled(crate(itoa)) = 1.0.6
|
||||
Provides: bundled(crate(jobserver)) = 0.1.26
|
||||
Provides: bundled(crate(libc)) = 0.2.142
|
||||
Provides: bundled(crate(librnsslapd)) = 0.1.0
|
||||
Provides: bundled(crate(librslapd)) = 0.1.0
|
||||
Provides: bundled(crate(linux-raw-sys)) = 0.3.4
|
||||
Provides: bundled(crate(lock_api)) = 0.4.9
|
||||
Provides: bundled(crate(log)) = 0.4.17
|
||||
Provides: bundled(crate(lru)) = 0.7.8
|
||||
Provides: bundled(crate(memoffset)) = 0.7.1
|
||||
Provides: bundled(crate(once_cell)) = 1.17.0
|
||||
Provides: bundled(crate(openssl)) = 0.10.45
|
||||
Provides: bundled(crate(openssl-macros)) = 0.1.0
|
||||
Provides: bundled(crate(openssl-sys)) = 0.9.80
|
||||
Provides: bundled(crate(memoffset)) = 0.8.0
|
||||
Provides: bundled(crate(once_cell)) = 1.17.1
|
||||
Provides: bundled(crate(openssl)) = 0.10.52
|
||||
Provides: bundled(crate(openssl-macros)) = 0.1.1
|
||||
Provides: bundled(crate(openssl-sys)) = 0.9.87
|
||||
Provides: bundled(crate(parking_lot)) = 0.11.2
|
||||
Provides: bundled(crate(parking_lot_core)) = 0.8.6
|
||||
Provides: bundled(crate(paste)) = 0.1.18
|
||||
@ -106,33 +111,33 @@ Provides: bundled(crate(pin-project-lite)) = 0.2.9
|
||||
Provides: bundled(crate(pkg-config)) = 0.3.26
|
||||
Provides: bundled(crate(ppv-lite86)) = 0.2.17
|
||||
Provides: bundled(crate(proc-macro-hack)) = 0.5.20+deprecated
|
||||
Provides: bundled(crate(proc-macro2)) = 1.0.50
|
||||
Provides: bundled(crate(proc-macro2)) = 1.0.56
|
||||
Provides: bundled(crate(pwdchan)) = 0.1.0
|
||||
Provides: bundled(crate(quote)) = 1.0.23
|
||||
Provides: bundled(crate(quote)) = 1.0.26
|
||||
Provides: bundled(crate(rand)) = 0.8.5
|
||||
Provides: bundled(crate(rand_chacha)) = 0.3.1
|
||||
Provides: bundled(crate(rand_core)) = 0.6.4
|
||||
Provides: bundled(crate(redox_syscall)) = 0.2.16
|
||||
Provides: bundled(crate(remove_dir_all)) = 0.5.3
|
||||
Provides: bundled(crate(ryu)) = 1.0.12
|
||||
Provides: bundled(crate(redox_syscall)) = 0.3.5
|
||||
Provides: bundled(crate(rustix)) = 0.37.14
|
||||
Provides: bundled(crate(ryu)) = 1.0.13
|
||||
Provides: bundled(crate(scopeguard)) = 1.1.0
|
||||
Provides: bundled(crate(serde)) = 1.0.152
|
||||
Provides: bundled(crate(serde_derive)) = 1.0.152
|
||||
Provides: bundled(crate(serde_json)) = 1.0.91
|
||||
Provides: bundled(crate(serde)) = 1.0.160
|
||||
Provides: bundled(crate(serde_derive)) = 1.0.160
|
||||
Provides: bundled(crate(serde_json)) = 1.0.96
|
||||
Provides: bundled(crate(slapd)) = 0.1.0
|
||||
Provides: bundled(crate(slapi_r_plugin)) = 0.1.0
|
||||
Provides: bundled(crate(smallvec)) = 1.10.0
|
||||
Provides: bundled(crate(strsim)) = 0.8.0
|
||||
Provides: bundled(crate(syn)) = 1.0.107
|
||||
Provides: bundled(crate(synstructure)) = 0.12.6
|
||||
Provides: bundled(crate(tempfile)) = 3.3.0
|
||||
Provides: bundled(crate(syn)) = 1.0.109
|
||||
Provides: bundled(crate(syn)) = 2.0.15
|
||||
Provides: bundled(crate(tempfile)) = 3.5.0
|
||||
Provides: bundled(crate(textwrap)) = 0.11.0
|
||||
Provides: bundled(crate(tokio)) = 1.24.2
|
||||
Provides: bundled(crate(tokio-macros)) = 1.8.2
|
||||
Provides: bundled(crate(tokio)) = 1.28.0
|
||||
Provides: bundled(crate(tokio-macros)) = 2.1.0
|
||||
Provides: bundled(crate(toml)) = 0.5.11
|
||||
Provides: bundled(crate(unicode-ident)) = 1.0.6
|
||||
Provides: bundled(crate(unicode-ident)) = 1.0.8
|
||||
Provides: bundled(crate(unicode-width)) = 0.1.10
|
||||
Provides: bundled(crate(unicode-xid)) = 0.2.4
|
||||
Provides: bundled(crate(uuid)) = 0.8.2
|
||||
Provides: bundled(crate(vcpkg)) = 0.2.15
|
||||
Provides: bundled(crate(vec_map)) = 0.8.2
|
||||
@ -141,16 +146,26 @@ Provides: bundled(crate(wasi)) = 0.11.0+wasi_snapshot_preview1
|
||||
Provides: bundled(crate(winapi)) = 0.3.9
|
||||
Provides: bundled(crate(winapi-i686-pc-windows-gnu)) = 0.4.0
|
||||
Provides: bundled(crate(winapi-x86_64-pc-windows-gnu)) = 0.4.0
|
||||
Provides: bundled(crate(windows-sys)) = 0.42.0
|
||||
Provides: bundled(crate(windows_aarch64_gnullvm)) = 0.42.1
|
||||
Provides: bundled(crate(windows_aarch64_msvc)) = 0.42.1
|
||||
Provides: bundled(crate(windows_i686_gnu)) = 0.42.1
|
||||
Provides: bundled(crate(windows_i686_msvc)) = 0.42.1
|
||||
Provides: bundled(crate(windows_x86_64_gnu)) = 0.42.1
|
||||
Provides: bundled(crate(windows_x86_64_gnullvm)) = 0.42.1
|
||||
Provides: bundled(crate(windows_x86_64_msvc)) = 0.42.1
|
||||
Provides: bundled(crate(zeroize)) = 1.5.7
|
||||
Provides: bundled(crate(zeroize_derive)) = 1.3.3
|
||||
Provides: bundled(crate(windows-sys)) = 0.45.0
|
||||
Provides: bundled(crate(windows-sys)) = 0.48.0
|
||||
Provides: bundled(crate(windows-targets)) = 0.42.2
|
||||
Provides: bundled(crate(windows-targets)) = 0.48.0
|
||||
Provides: bundled(crate(windows_aarch64_gnullvm)) = 0.42.2
|
||||
Provides: bundled(crate(windows_aarch64_gnullvm)) = 0.48.0
|
||||
Provides: bundled(crate(windows_aarch64_msvc)) = 0.42.2
|
||||
Provides: bundled(crate(windows_aarch64_msvc)) = 0.48.0
|
||||
Provides: bundled(crate(windows_i686_gnu)) = 0.42.2
|
||||
Provides: bundled(crate(windows_i686_gnu)) = 0.48.0
|
||||
Provides: bundled(crate(windows_i686_msvc)) = 0.42.2
|
||||
Provides: bundled(crate(windows_i686_msvc)) = 0.48.0
|
||||
Provides: bundled(crate(windows_x86_64_gnu)) = 0.42.2
|
||||
Provides: bundled(crate(windows_x86_64_gnu)) = 0.48.0
|
||||
Provides: bundled(crate(windows_x86_64_gnullvm)) = 0.42.2
|
||||
Provides: bundled(crate(windows_x86_64_gnullvm)) = 0.48.0
|
||||
Provides: bundled(crate(windows_x86_64_msvc)) = 0.42.2
|
||||
Provides: bundled(crate(windows_x86_64_msvc)) = 0.48.0
|
||||
Provides: bundled(crate(zeroize)) = 1.6.0
|
||||
Provides: bundled(crate(zeroize_derive)) = 1.4.2
|
||||
##### Bundled cargo crates list - END #####
|
||||
|
||||
BuildRequires: nspr-devel >= 4.32
|
||||
@ -214,6 +229,7 @@ BuildRequires: python%{python3_pkgversion}-argcomplete
|
||||
BuildRequires: python%{python3_pkgversion}-argparse-manpage
|
||||
BuildRequires: python%{python3_pkgversion}-libselinux
|
||||
BuildRequires: python%{python3_pkgversion}-policycoreutils
|
||||
BuildRequires: python%{python3_pkgversion}-cryptography
|
||||
|
||||
# For cockpit
|
||||
%if %{use_cockpit}
|
||||
@ -277,7 +293,6 @@ Source2: %{name}-devel.README
|
||||
Source3: https://github.com/jemalloc/%{jemalloc_name}/releases/download/%{jemalloc_ver}/%{jemalloc_name}-%{jemalloc_ver}.tar.bz2
|
||||
%endif
|
||||
Source4: 389-ds-base.sysusers
|
||||
Patch0: 0001-Issue-5642-Build-fails-against-setuptools-67.0.0.patch
|
||||
|
||||
%description
|
||||
389 Directory Server is an LDAPv3 compliant server. The base package includes
|
||||
@ -356,6 +371,7 @@ Requires: python%{python3_pkgversion}-dateutil
|
||||
Requires: python%{python3_pkgversion}-argcomplete
|
||||
Requires: python%{python3_pkgversion}-libselinux
|
||||
Requires: python%{python3_pkgversion}-setuptools
|
||||
Requires: python%{python3_pkgversion}-cryptography
|
||||
%{?python_provide:%python_provide python%{python3_pkgversion}-lib389}
|
||||
|
||||
%description -n python%{python3_pkgversion}-lib389
|
||||
@ -710,6 +726,67 @@ exit 0
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Apr 25 2023 Mark Reynolds <mreynolds@redhat.com> - 2.4.0-1
|
||||
- Bump version to 2.4.0
|
||||
- Issue 5156 - RFE that implement slapi_memberof (#5694)
|
||||
- Issue 5734 - RFE - Exclude pwdFailureTime and ContextCSN (#5735)
|
||||
- Issue 5726 - ns-slapd crashing in ldbm_back_upgradednformat (#5727)
|
||||
- Issue 4758 - Add tests for WebUI
|
||||
- Issue 5718 - Memory leak in connection table (#5719)
|
||||
- Issue 5705 - Add config parameter to close client conns on failed bind (#5712)
|
||||
- Issue 4758 - Add tests for WebUI
|
||||
- Issue 5643 - Memory leak in entryrdn during delete (#5717)
|
||||
- Issue 5714 - UI - fix typo, db settings, log settings, and LDAP editor paginations
|
||||
- Issue 5701 - CLI - Fix referral mode setting (#5708)
|
||||
- Bump openssl from 0.10.45 to 0.10.48 in /src (#5709)
|
||||
- Issue 5710 - subtree search statistics for index lookup does not report ancestorid/entryrdn lookups (#5711)
|
||||
- Issue 5697 - Obsolete nsslapd-ldapimaprootdn attribute (#5698)
|
||||
- Issue 1081 - Stop schema replication from overwriting x-origin
|
||||
- Issue 4812 - Listener thread does not scale with a high num of established connections (#5706)
|
||||
- Issue 4812 - Listener thread does not scale with a high num of established connections (#5681)
|
||||
- Bump webpack from 5.75.0 to 5.76.0 in /src/cockpit/389-console (#5699)
|
||||
- Issue 5598 - (3rd) In 2.x, SRCH throughput drops by 10% because of handling of referral (#5692)
|
||||
- Issue 5598 - (2nd) In 2.x, SRCH throughput drops by 10% because of handling of referral (#5691)
|
||||
- Issue 5687 - UI - sensitive information disclosure
|
||||
- Issue 5661 - LMDB hangs while Rebuilding the replication changelog RUV (#5676)
|
||||
- Issue 5554 - Add more tests to security_basic_test suite
|
||||
- Issue 4583 - Update specfile to skip checks of ASAN builds
|
||||
- Issue 4758 - Add tests for WebUI
|
||||
- Issue 3604 - UI - Add support for Subject Alternative Names in CSR
|
||||
- Issue 5600 - buffer overflow when enabling sync repl plugin when dynamic plugins is enabled
|
||||
- Issue 5640 - Update logconv for new logging format
|
||||
- Issue 5162 - CI - fix error message for invalid pem file
|
||||
- Issue 5598 - In 2.x, SRCH throughput drops by 10% because of handling of referral (#5604)
|
||||
- Issue 5671 - covscan - clang warning (#5672)
|
||||
- Issue 5267 - CI - Fix issues with nsslapd-return-original-entrydn
|
||||
- Issue 5666 - CLI - Add timeout parameter for tasks
|
||||
- Issue 5567 - CLI - make ldifgen use the same default ldif name for all options
|
||||
- Issue 5647 - Fix unused variable warning from previous commit (#5670)
|
||||
- Issue 5162 - Lib389 - verify certificate type before adding
|
||||
- Issue 5642 - Build fails against setuptools 67.0.0
|
||||
- Issue 5630 - CLI - need to add logging filter for stdout
|
||||
- Issue 5646 - CLI/UI - do not hardcode password storage schemes
|
||||
- Issue 5640 - Update logconv for new logging format
|
||||
- issue 5647 - covscan: memory leak in audit log when adding entries (#5650)
|
||||
- Issue 5658 - CLI - unable to add attribute with matching rule
|
||||
- Issue 5653 - covscan - fix invalid dereference
|
||||
- Issue 5652 - Libasan crash in replication/cascading_test (#5659)
|
||||
- Issue 5628 - Handle graceful timeout in CI tests (#5657)
|
||||
- Issue 5648 - Covscan - Compiler warnings (#5651)
|
||||
- Issue 5630 - CLI - error messages should goto stderr
|
||||
- Issue 2435 - RFE - Raise IDL Scan Limit to INT_MAX (#5639)
|
||||
- Issue 5632 - CLI - improve error handling with db2ldif
|
||||
- Issue 5517 - Replication conflict CI test sometime fails (#5518)
|
||||
- Issue 5634 - Deprecated warning related to github action workflow code (#5635)
|
||||
- Issue 5637 - Covscan - fix Buffer Overflows (#5638)
|
||||
- Issue 5624 - RFE - UI - export certificates, and import text base64 encoded certificates
|
||||
- Bump tokio from 1.24.1 to 1.25.0 in /src (#5629)
|
||||
- Issue 4577 - Add LMDB pytest github action (#5627)
|
||||
- Issue 4293 - RFE - CLI - add dsrc options for setting user and group subtrees
|
||||
- Remove stale libevent(-devel) dependency
|
||||
- Issue 5578 - dscreate ds-root does not normaile paths (#5613)
|
||||
- Issue 5497 - boolean attributes should be case insensitive
|
||||
|
||||
* Fri Mar 31 2023 Viktor Ashirov <vashirov@redhat.com> - 2.3.2-3
|
||||
- Fix build issue against setuptools 67.0.0 (#2183375)
|
||||
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (jemalloc-5.3.0.tar.bz2) = 22907bb052096e2caffb6e4e23548aecc5cc9283dce476896a2b1127eee64170e3562fa2e7db9571298814a7a2c7df6e8d1fbe152bd3f3b0c1abec22a2de34b1
|
||||
SHA512 (389-ds-base-2.3.2.tar.bz2) = 20bf8e2ce1781886e62a9500cdf709d11b860f0f61de44ecb1be7c3a6be1fe306783b6eeb3e37933f494c640dd140e247a4a266091ffd81cf00f58af37e6577e
|
||||
SHA512 (389-ds-base-2.4.0.tar.bz2) = 2bcfe9fcc41a48639d88109d530334b80ecfd6d7bf640c565bea843206b387a616d5a1a330b801439783467810a092e0027f7dff43755696e66eea9f6c06057c
|
||||
|
Loading…
Reference in New Issue
Block a user