Bump version to 1.4.3.2
Issue 49254 - Fix compiler failures and warnings Issue 50741 - cont bdb_start - Detected Disorderly Shutdown Issue 50836 - Port Schema UI tab to React Issue 50842 - Decrease 389-console Cockpit component size Issue 50790 - Add result text when filter is invalid Issue 50627 - Add ASAN logs to HTML report Issue 50834 - Incorrectly setting the NSS default SSL version max Issue 50829 - Disk monitoring rotated log cleanup causes heap-use-after-free Issue 50709 - (cont) Several memory leaks reported by Valgrind for 389-ds 1.3.9.1-10 Issue 50784 - performance testing scripts Issue 50599 - Fix memory leak when removing db region files Issue 49395 - Set the default TLS version min to TLS1.2 Issue 50818 - dsconf pwdpolicy get error Issue 50824 - dsctl remove fails with "name 'ensure_str' is not defined" Issue 50599 - Remove db region files prior to db recovery Issue 50812 - dscontainer executable should be placed under /usr/libexec/dirsrv/ Issue 50816 - dsconf allows the root password to be set to nothing Issue 50798 - incorrect bytes in format string(fix import issue)
This commit is contained in:
parent
a2478bfa8c
commit
00c5c5cf49
1
.gitignore
vendored
1
.gitignore
vendored
@ -187,3 +187,4 @@
|
||||
/389-ds-base-1.4.2.5.tar.bz2
|
||||
/389-ds-base-1.4.3.1.tar.bz2
|
||||
/jemalloc-5.2.1.tar.bz2
|
||||
/389-ds-base-1.4.3.2.tar.bz2
|
||||
|
@ -1,45 +0,0 @@
|
||||
From 828aad0769cee2c58e073ac446558cc614ed7a96 Mon Sep 17 00:00:00 2001
|
||||
From: Mark Reynolds <mreynolds@redhat.com>
|
||||
Date: Mon, 13 Jan 2020 17:17:40 -0500
|
||||
Subject: [PATCH] Issue 50798 - incorrect bytes in format string(fix import
|
||||
issue)
|
||||
|
||||
Description: The previous commit did not import ensure_list_str() from
|
||||
utils.py
|
||||
|
||||
relates: https://pagure.io/389-ds-base/issue/50798
|
||||
|
||||
Reviewed by: mreynolds (one line commit rule)
|
||||
---
|
||||
src/lib389/lib389/instance/remove.py | 2 +-
|
||||
src/lib389/lib389/instance/setup.py | 1 +
|
||||
2 files changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/lib389/lib389/instance/remove.py b/src/lib389/lib389/instance/remove.py
|
||||
index 41eaeb4a6..e54e64e5c 100644
|
||||
--- a/src/lib389/lib389/instance/remove.py
|
||||
+++ b/src/lib389/lib389/instance/remove.py
|
||||
@@ -11,7 +11,7 @@ import shutil
|
||||
import subprocess
|
||||
import logging
|
||||
from lib389.nss_ssl import NssSsl
|
||||
-from lib389.utils import selinux_label_port, assert_c
|
||||
+from lib389.utils import selinux_label_port, assert_c, ensure_list_str
|
||||
|
||||
|
||||
######################## WARNING #############################
|
||||
diff --git a/src/lib389/lib389/instance/setup.py b/src/lib389/lib389/instance/setup.py
|
||||
index ead3db1b6..6ee71b5d0 100644
|
||||
--- a/src/lib389/lib389/instance/setup.py
|
||||
+++ b/src/lib389/lib389/instance/setup.py
|
||||
@@ -33,6 +33,7 @@ from lib389.utils import (
|
||||
assert_c,
|
||||
is_a_dn,
|
||||
ensure_str,
|
||||
+ ensure_list_str,
|
||||
normalizeDN,
|
||||
socket_check_open,
|
||||
selinux_label_port,
|
||||
--
|
||||
2.24.1
|
||||
|
@ -1,37 +0,0 @@
|
||||
From 4f9aafca9a9927812da5e37ce71d79d1fd23b25a Mon Sep 17 00:00:00 2001
|
||||
From: Matus Honek <mhonek@redhat.com>
|
||||
Date: Thu, 16 Jan 2020 12:21:45 +0100
|
||||
Subject: [PATCH 1/2] Issue 50824 - dsctl remove fails with "name 'ensure_str'
|
||||
is not defined"
|
||||
|
||||
Bug Description:
|
||||
Missing import since commit c39c7bb.
|
||||
|
||||
Fix Description:
|
||||
Add the import.
|
||||
|
||||
Fixes https://pagure.io/389-ds-base/issue/50824
|
||||
|
||||
Author: Matus Honek <mhonek@redhat.com>
|
||||
|
||||
Review by: Mark (thanks!)
|
||||
---
|
||||
src/lib389/lib389/instance/remove.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/lib389/lib389/instance/remove.py b/src/lib389/lib389/instance/remove.py
|
||||
index e54e64e5c..e48b294df 100644
|
||||
--- a/src/lib389/lib389/instance/remove.py
|
||||
+++ b/src/lib389/lib389/instance/remove.py
|
||||
@@ -11,7 +11,7 @@ import shutil
|
||||
import subprocess
|
||||
import logging
|
||||
from lib389.nss_ssl import NssSsl
|
||||
-from lib389.utils import selinux_label_port, assert_c, ensure_list_str
|
||||
+from lib389.utils import selinux_label_port, assert_c, ensure_str, ensure_list_str
|
||||
|
||||
|
||||
######################## WARNING #############################
|
||||
--
|
||||
2.24.1
|
||||
|
@ -1,49 +0,0 @@
|
||||
From 2a6784884fa931643f52ff01dc7dacf3da0be90f Mon Sep 17 00:00:00 2001
|
||||
From: Mark Reynolds <mreynolds@redhat.com>
|
||||
Date: Mon, 13 Jan 2020 19:17:04 -0500
|
||||
Subject: [PATCH 2/2] Issue 50818 - dsconf pwdpolicy get error
|
||||
|
||||
Description: When trying to retrieve a global or local policy we now see:
|
||||
|
||||
policyError: 'PwPolicyManager' object has no attribute 'get_attr_list'
|
||||
|
||||
Someone removed the function get_attr_list() along the way.
|
||||
Added the same logic back, and improved it to only report attributes
|
||||
that are set.
|
||||
|
||||
relates: https://pagure.io/389-ds-base/issue/50818
|
||||
|
||||
Reviewed by: spichugi(Thanks!)
|
||||
---
|
||||
src/lib389/lib389/cli_conf/pwpolicy.py | 9 +++++----
|
||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/lib389/lib389/cli_conf/pwpolicy.py b/src/lib389/lib389/cli_conf/pwpolicy.py
|
||||
index f911997bf..67bfd8767 100644
|
||||
--- a/src/lib389/lib389/cli_conf/pwpolicy.py
|
||||
+++ b/src/lib389/lib389/cli_conf/pwpolicy.py
|
||||
@@ -35,16 +35,17 @@ def _get_policy_type(inst, dn=None):
|
||||
def _get_pw_policy(inst, targetdn, log, use_json=None):
|
||||
pwp_manager = PwPolicyManager(inst)
|
||||
policy_type = _get_policy_type(inst, targetdn)
|
||||
- attr_list = pwp_manager.get_attr_list()
|
||||
+ attr_list = list(pwp_manager.arg_to_attr.values())
|
||||
if "global" in policy_type.lower():
|
||||
targetdn = 'cn=config'
|
||||
attr_list.extend(['passwordIsGlobalPolicy', 'nsslapd-pwpolicy_local'])
|
||||
- attrs = inst.config.get_attrs_vals_utf8(attr_list)
|
||||
+ all_attrs = inst.config.get_attrs_vals_utf8(attr_list)
|
||||
+ attrs = {k: v for k, v in all_attrs.items() if len(v) > 0}
|
||||
else:
|
||||
policy = pwp_manager.get_pwpolicy_entry(targetdn)
|
||||
targetdn = policy.dn
|
||||
- attrs = policy.get_attrs_vals_utf8(attr_list)
|
||||
-
|
||||
+ all_attrs = policy.get_attrs_vals_utf8(attr_list)
|
||||
+ attrs = {k: v for k, v in all_attrs.items() if len(v) > 0}
|
||||
if use_json:
|
||||
print(json.dumps({"type": "entry", "pwp_type": policy_type, "dn": ensure_str(targetdn), "attrs": attrs}))
|
||||
else:
|
||||
--
|
||||
2.24.1
|
||||
|
@ -44,8 +44,8 @@ ExcludeArch: i686
|
||||
|
||||
Summary: 389 Directory Server (base)
|
||||
Name: 389-ds-base
|
||||
Version: 1.4.3.1
|
||||
Release: %{?relprefix}3%{?prerel}%{?dist}
|
||||
Version: 1.4.3.2
|
||||
Release: %{?relprefix}1%{?prerel}%{?dist}
|
||||
License: GPLv3+
|
||||
URL: https://www.port389.org
|
||||
Conflicts: selinux-policy-base < 3.9.8
|
||||
@ -172,16 +172,6 @@ Source2: %{name}-devel.README
|
||||
Source3: https://github.com/jemalloc/%{jemalloc_name}/releases/download/%{jemalloc_ver}/%{jemalloc_name}-%{jemalloc_ver}.tar.bz2
|
||||
%endif
|
||||
|
||||
# Backport of https://pagure.io/389-ds-base/c/828aad0
|
||||
# Fixes a missing import that broke FreeIPA deployment
|
||||
Patch0: 0001-Issue-50798-incorrect-bytes-in-format-string-fix-imp.patch
|
||||
# https://pagure.io/389-ds-base/c/4f9aafc
|
||||
# Fixes another missing import
|
||||
Patch1: 0001-Issue-50824-dsctl-remove-fails-with-name-ensure_str-.patch
|
||||
# https://pagure.io/389-ds-base/c/2a67848
|
||||
# Fixes a removed function
|
||||
Patch2: 0002-Issue-50818-dsconf-pwdpolicy-get-error.patch
|
||||
|
||||
%description
|
||||
389 Directory Server is an LDAPv3 compliant server. The base package includes
|
||||
the LDAP server and command line utilities for server administration.
|
||||
@ -303,9 +293,6 @@ A cockpit UI Plugin for configuring and administering the 389 Directory Server
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?prerel}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%if %{bundle_jemalloc}
|
||||
%setup -q -n %{name}-%{version}%{?prerel} -T -D -b 3
|
||||
@ -771,13 +758,34 @@ exit 0
|
||||
%{_mandir}/man8/dsctl.8.gz
|
||||
%{_sbindir}/dsidm
|
||||
%{_mandir}/man8/dsidm.8.gz
|
||||
%{_sbindir}/dscontainer
|
||||
%{_libexecdir}/%{pkgname}/dscontainer
|
||||
|
||||
%files -n cockpit-389-ds -f cockpit.list
|
||||
%{_datarootdir}/metainfo/389-console/org.port389.cockpit_console.metainfo.xml
|
||||
%doc README.md
|
||||
|
||||
%changelog
|
||||
* Thu Jan 23 2020 Mark Reynolds <mreynolds@redhat.com> - 1.4.3.2-1
|
||||
- Bump version to 1.4.3.2
|
||||
- Issue 49254 - Fix compiler failures and warnings
|
||||
- Issue 50741 - cont bdb_start - Detected Disorderly Shutdown
|
||||
- Issue 50836 - Port Schema UI tab to React
|
||||
- Issue 50842 - Decrease 389-console Cockpit component size
|
||||
- Issue 50790 - Add result text when filter is invalid
|
||||
- Issue 50627 - Add ASAN logs to HTML report
|
||||
- Issue 50834 - Incorrectly setting the NSS default SSL version max
|
||||
- Issue 50829 - Disk monitoring rotated log cleanup causes heap-use-after-free
|
||||
- Issue 50709 - (cont) Several memory leaks reported by Valgrind for 389-ds 1.3.9.1-10
|
||||
- Issue 50784 - performance testing scripts
|
||||
- Issue 50599 - Fix memory leak when removing db region files
|
||||
- Issue 49395 - Set the default TLS version min to TLS1.2
|
||||
- Issue 50818 - dsconf pwdpolicy get error
|
||||
- Issue 50824 - dsctl remove fails with "name 'ensure_str' is not defined"
|
||||
- Issue 50599 - Remove db region files prior to db recovery
|
||||
- Issue 50812 - dscontainer executable should be placed under /usr/libexec/dirsrv/
|
||||
- Issue 50816 - dsconf allows the root password to be set to nothing
|
||||
- Issue 50798 - incorrect bytes in format string(fix import issue)
|
||||
|
||||
* Thu Jan 16 2020 Adam Williamson <awilliam@redhat.com> - 1.4.3.1-3
|
||||
- Backport two more import/missing function fixes
|
||||
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (389-ds-base-1.4.3.1.tar.bz2) = f210c46d19635d9251982e193ddea08912ece9f2ef60e1487fbfd37678a8ad660a25c5925ab6d4f29576335be195485822a3ca5b71a0d11a861eb598885b362b
|
||||
SHA512 (389-ds-base-1.4.3.2.tar.bz2) = e747c96428b0b79cbea6f01c07214b8ee3456b6f5d93fd27da905c56690e370925d70939765d68c43dd74ecd7121bfe61d84314b8127d83dded45186120caa5e
|
||||
SHA512 (jemalloc-5.2.1.tar.bz2) = 0bbb77564d767cef0c6fe1b97b705d368ddb360d55596945aea8c3ba5889fbce10479d85ad492c91d987caacdbbdccc706aa3688e321460069f00c05814fae02
|
||||
|
Loading…
Reference in New Issue
Block a user